Kodi Community Forum

Full Version: Auto update at startup not working
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I formatted my two htpc computers last week and switched from OpenElec to LibreElec.

Htpc1 has the files on it and us the primary. When I turn it on it scans and updates with all newly added files.

Htpc2 in the living room connects to htpc1, both connected to the same router with cat5e cable, not wifi. Update library at startup is enabled, I even have it set to not start kodi until neyworn is connected, and nothing. If I click to update it will scan and find new files no problem. So it connects, it plays files, sees files and update does work for movies and TV... But, at startup nothing.

I ran the clean library, disabled update at startup, rebooted, enabled auto update library, rebooted again and no change.

Any ideas before I formatted and reinstall? With openelec, update library on startup worked for the past 2yrs no problems.
(2019-01-01, 08:48)THRobinson Wrote: [ -> ]Htpc2 in the living room connects to htpc1,

How is it connected to the database of the "main" htpc? Where is the data stored and how do you share the data between those two HTPCs?

Be aware, that if you are using UPnP, the other HTPC (which connects to the HTPC1) only presents what HTPC1 holds. So triggering an update won't do anything if the HTPC1 doesn't have any new data to present. And as by using UPnP, an update of the library of HTPC2 isn't necessary at all, as it doesn't have it's own library (if UPnP is in use).

So we need a bit more information if you are using some network protocol (such as SMB or NFS) to share your library/data or how do you share it.
I'm not very good with this stuff, I usually just fight with it until it works so bear with me...

HTPC1 is the main one. Old QuadCore PC with LibreElec installed to a 32GB SSD drive, and I have two internal 3TB HDD's... one for TV series and one for Movies. Both 3TB HDD's are shared. Scarped data is stored locally to the SSD drive.

HTPC2 is an old Dell PC with LibreElec installed in the living room. No files (media) saved on HTPC2, but when it scrapes the library data is stored locally to it's own drive.

Both are connected to the router with Cat5e ethernet cable, not WiFi.

I use to be able to Browse the network and find/add the shares, but after upgrading from OpenElec to LibreElec it wouldn't allow it. I had to add the location under SMB using the IP address. My android tablet was able to browse/add through SMB but not HTPC2. HTPC1 also connects to a shared drive on my personal PC (Win10 connected with ethernet) which I use for transferring and testing video files. I had to manually add it using the IP address and passwords as well.

When I turn HTPC1 on, it scans for new files and updates/scrapes no problem.

When I turn HTPC2 on, I don't see the usual stuff in the upper-right corner where it's scanning and downloading info from TVDB and such. If I click to update manually, it finds all the new movies/tvseries and updates no problems. Playback is fine as well. Basically HTPC2 works fine, no issues, library looks good and can scrape... it just won't update/scrape at startup.

Under OpenElec, and before that Win7 (few years back now) HTPC2 would simply detect the new files on HTPC1 and update the library. Been doing it that way for maybe 5yrs now. 

Before I simply wipe it out and reinstall and rescrape, I wanted to see if anything I should try first.

Again, I did try cleaning the library, disabling auto update, enabling the option to wait 10sec for network before starting Kodi, did a reboot, enabled auto update library, rebooted again, and it didn't update anything. I manually ran the update and about 20 new files showed up because I added a new TV series and a couple movies.

Both HTPC1 and HTPC2 had the C:\ drives formatted and the most current copy of LibreElec installed. I didn't update/convert OpenElec to LibreElec, rather I opted to just wipe it fully out and start over again. 

Hopefully that helps?
ok, this sounds all pretty good, and I guess we have enough information now to request a full Debug Log from HTPC2 which doesn't do the automatic update on startup.

Please make sure HTPC1 is up and running befor you fire up HTPC2. For the log, I would like to see it the following way:

- enable debug logging
- restart the machine (HTPC2)
- and then, after the restart, grab the log. This ensures, that we have a Debug Log from the start.

Thanks in advance.