Kodi Community Forum

Full Version: Touble with latest svn (13467)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I just compiled the latest svn on Ubuntu 7.10. However, i am unable to play any video files. When i try to play them nothing happens. (Pictures and mp3s work fine). Lookin through the log, i get this error: "21:27:07 T:2872023952 M:106610688 DEBUG: Loading: /home/xbmc/xbmcbin/13467/system/players/dvdplayer/avcodec-51-i486-linux.so
21:27:07 T:2872023952 M:106610688 ERROR: Unable to load /home/xbmc/xbmcbin/13467/system/players/dvdplayer/avcodec-51-i486-linux.so, reason: /lib/tls/i686/cm
ov/libc.so.6: version `GLIBC_2.7' not found (required by /home/xbmc/xbmcbin/13467/system/players/dvdplayer/avcodec-51-i486-linux.so)" How do i fix this? Huh
Some dllloader stuff changed.

Do a "make distclean" and rebuild.
Ok, tried with make distclean and latest svn (13472). Still same problem and error in the logs ('GLIBC_2.7' not found)...
Whetever, i'm doing a "do-release-upgrade", hopefully it will work in 8.04. Has been planning on upgrading a while, and might as well do it now. (But please fix this issue if it affects all <8.04 users).
Ok, now I'm running 8.04 and xbmc works fine.
I'm pretty sure we have the right to drop support whenever we don't feel like maintaining it, not that we have. Regardless, blame malloc Wink
ldt0 Wrote:Ok, tried with make distclean and latest svn (13472). Still same problem and error in the logs ('GLIBC_2.7' not found)...

Okay, I have hit this error too - thought it was specific to DVD playback but it's not. Am on 13474 having just distcleaned and am recompiling now...

Same exact error - doh! I am betting MANY will see this, breaks support for all vids it looks like since ffMPEG libraries cannot load <sigh> Music plays though so all is not lostRofl
This shouldn't be happening as of svn 13465 (it was a problem from 13430-13464). What is your build method?

I am getting the same. Portions from xbmc.log:

10:04:26 T:3060557664 M:249397248 NOTICE: Starting XBMC, Platform: GNU/Linux. Built on Jun 9 2008 (SVN:13486M)

10:04:39 T:2935524240 M:187715584 DEBUG: Loading: /usr/local/share/xbmc/system/players/dvdplayer/avcodec-51-i486-linux.so
10:04:39 T:2935524240 M:187715584 ERROR: Unable to load /usr/local/share/xbmc/system/players/dvdplayer/avcodec-51-i486-linux.so, reason: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.7' not found (required by /usr/local/share/xbmc/sys

My build method:

make distclean; ./configure --enable-debug=no; make -j2; sudo make install
Updating to 8.04 solves the problem since 8.04 is built/based on GLIBC 2.7. Though of course i think the problem still needs to be solved since dropping support for everything <8.04 is probably not a good idea. Laugh
We solved the problem in the latest SVN.