Kodi Community Forum

Full Version: USB not working on boot (for remote only), Remove / Insert then working.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi All,

I have a very annoying scenario, im using a Pro Chosen USB Remote, when i plug in the USB receiver it works fine however if i leave plug in and turn off or restart my kodi box the remote act's as if the reciever is not plugged in.

If i have a keyboard plugged in, the keyboard works throughout reboot process, so I think its the drivers not loading on boot.

I've left the reciever in for 30 minutes after reboot to test its just a delay in applying drivers and gone through my wits end of google searching for a solution so hopeing someone will have an idea.
I have tested with estuary skin and same occurs
Tried differentUSB ports

If anyone could talk me through how to add a script to run on delayed start up to disable usb ports then re-enable this would be a great bandaid but i do not know linux or where to begin with somthing like this.

Kodi Version 18: #0102, 02-Jan-2019: Generic -- Release post ([skin] Bump GUI ABI to 5.14.0)
Log File: http://ix.io/1xrz (updated logs with add-ons uninstalled)

Motherboard: ASUS AT3N7A-I
CPU: Intel Atom 330 @ 1.6GHz
GPU: ION/Integrated/SSE2 - Nvidea VT1708S

Many Thanks, Sheoguard.
The forum moderators have determined that banned addons (wiki) are present on your system. To receive assistance here, these banned items must be removed. If a clean log is not submitted within 3 days, then the relevant post(s) will be removed after this time.
My apologies, i have removed the add-ons and re-uploaded

Log File: http://ix.io/1xrj
You've missed a few:

18:49:47.348 T:140491303988608 NOTICE: ADDON: plugin.video.neptune v1.4.9 installed
18:49:47.350 T:140491303988608 NOTICE: ADDON: script.covenant.artwork v1.0.3 installed
18:49:47.350 T:140491303988608 NOTICE: ADDON: script.covenant.metadata v1.0.2 installed
18:49:47.352 T:140491303988608 NOTICE: ADDON: script.module.schism.common v2017.06.08 installed
18:49:47.352 T:140491303988608 NOTICE: ADDON: script.neptune.artwork v1.1.2 installed

Some may be orphaned scripts and such (which are still running on your device, doing who knows what...?) which you'd have to remove manually outside Kodi.
Just wiped out my kodibox and re-installed.

Log files: http://ix.io/1xrz

re-tested still the same just in case.

found this in log: -

Jan 03 19:37:17 LibreELEC kernel: usb usb4-port5: unable to enumerate USB device
Seeing that:

Jan 03 19:37:52 LibreELEC kernel: usb 4-5: new full-speed USB device number 6 using ohci-pci
and the following lines...

about 30 secs after the line you posted above. Is that the time where you removed the receiver and plugged it in again?

that sounds about right.
It looks like either a hardware issue or a driver issue. The error it's throwing, -62, is ETIME : Timer expired. The device isn't responding when polled by the USB driver. Sometimes devices don't support USB power management properly and that can trigger this. You can try turning that off for the device. See: https://hamwaves.com/usb.autosuspend/en/