Kodi Community Forum

Full Version: Unable to stream external subitles over UPNP
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hy Guys,

I am not able to stream external subtitles over UPNP. I have Kodi 17.6 
       
On Kodi UPnP server, services settings - UPNP / DLNA - set "look for external subtitles" is switched on.

The subtitle (.srt, .txt) file name is same as the movie's name and it's in the movie's folder 

Subtitle storage location: next to the video 

I have tried with several client, androit tv, windows 10 PC etc.. but same result.

Browse for subtitle options does not work.  

If I try to play the movies from server side everything works okey.

Can anybody confirm if Kodi do read subtitles using UPNP


I do not even know where to start. I have checked all the setting and it seems okey.
It's a longstanding issue AFAIK, and there may have been improvements/fixes on this in Kodi Leia 18. I would test K18, as Kodi 17 is a closed book.
For me it was one of the bigger reasons to not use UPnP again. I'm now using NFS for file retrieving and a MySQL datatabase for metadata sharing.