Kodi Community Forum

Full Version: Mint 19 (xfce) + Kodi 18 installed via flatpak
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I was setting up the Add-Ons in Kodi 17; but having way too many problems which referred me to the log. So I replaced everything with Kodi 19, which was only available as a flatpak. This worked great! Even my main "go look at the log" install worked. (FYI: it was Youtube of all things)

But, Kodi 18 has also has install problems - which is expected with so many add-ons.

But, WHERE IS THE LOG UNDER FLATPAK? Is there one?  Maybe locations like this should be named in the System  module?
(2019-01-15, 04:04)lindzay Wrote: [ -> ]So I replaced everything with Kodi 19, which was only available as a flatpak.
There is no Kodi 19. Not at least for a year. So what DID you install?

(2019-01-15, 04:04)lindzay Wrote: [ -> ]But, Kodi 18 has also has install problems - which is expected with so many add-ons.
"So many add-ons"? The default Kodi installation hardly installs any add-ons. Again, where did you get your installation file(s) from? AFAIK, the default debug log (wiki) location hasn't changed.
Okay, I read that wrong. Usually, official add-ons for Kodi 17 are not a problem for Kodi 18. If there are add-ons giving you problems, which are those?
Sorry Mint19 - Kodi 18 ... Hey, I got it right 2X out of 3.

The add-ons are from the "official" repository (installed via the flatpak?) ... I assume they're the Kodi 18 version if I read the Wiki correctly.

* Cheddar
* The Hollywood Reporter
* PopcornTV
* PopcornFlix - it all looks OK, except nothing will play. And there was an error while exiting.
* Team Kodi - Youtube - when "Kodi Oscars Movie Tutorial" ended so did Kodi ... but the next one was OK so I guess there's no problem here.

Hmmmm ... maybe it's my problem because nothing's plays except Youtube videos and my Video-Embycon movies.
Anyway, tonight I thought I'd go back to Kodi 17; but, too late. Kodi 17 is no longer in the Mint repository but has been replaced by Kodi 18 (Yeah!) ... But the package is "broken" (Boo!). Guess I'll wait a day or two and look again.

THE END
Kodi's PPA doesn't work for you?
how about telling us what problem you have exactly, along with a Debug Log?
As I said originally - my version of Kodi 18 was installed via the flatpak - right from the repositories. That's the one I wanted to know where the log files were being put ... although I strongly suspect they don't exist - I certainly cannot find them.

Going back to Kodi 17 - I couldn't because it was gone, poofed out of the repository. But thanks Klojum, it was the repository - I also had the /unstable one in the PPAs. It said it did NOT install; but obviously did (Aghhhh - I should have double checked)

As far as the Kodi 18 package being broken; maybe it was because I was using a 32bit PC? Dunno - tomorrow I'll spin my chair sideways and try with a 64bit PC.

And finally wsnipex , circling back to the thread's start, I would love to give you a Debug log from a flatpak - I think flatpaks are a great idea.

So ignore everything I've posted except - where is the log file in a flatpak install?

Klojum - is that a penguin on the polar bear? It is so wrong on so many levels. Every time I see it I laugh, not smile, laugh!
under flatpak the userdata dir is: ~/.var/app/tv.kodi.Kodi/data
so the log is ~/.var/app/tv.kodi.Kodi/data/temp/kodi.log
Thank you .... Thank you .... Thank you ....