Kodi Community Forum

Full Version: Stuttering despite high fps
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi

For some reason games on my odroid c2 (CoreElec + kodi18 rc5) stutter even though the framerate is stable at 59.5-60.5 fps, according to the debug overlay.
It almost looks like a refresh rate mismatch. Games usually run smooth for a few seconds then stutter slightly, rinse and repeat.
I have tried 60/59.940/50 Hz on PAL and NTSC games on different systems and emulators (SNES+NES) and they all seem to be affected.
It's not that obvious so I don't notice it on slower games but you can see it very clearly in fast-paced (side-scrolling) games such as Super Mario (SNES).
Who is to blame here? My device? Kodi? CoreElec?
I have the exact same issue with Kodi 18 Windows 10 64 bit. Every 7-8 seconds any game in any emulator stutters. And I doubt the cause is my hardware: Core i7 5920k (6 core) @ 3.8ghz, 16 gb ram, SSD, 1060 GTX and no strange background processes.

I too tried 59, and 60 hz because it also looked to me like a framerate / refresh mismatch but no luck.

Definetively there is something weird with retroarch support in kodi 18.
Have you tried to disable rewinding in Kodi Settings, Game section?