Kodi Community Forum

Full Version: Unable to play HEVC stream
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Unable to play HEVC stream by tvheadend HTSP addon
No problem to play HEVC file

Code:

General
ID                                       : 1 (0x1)
Complete name                            : sample.ts
Format                                   : MPEG-TS
File size                                : 11.3 MiB
Duration                                 : 53s 453ms
Overall bit rate mode                    : Variable
Overall bit rate                         : 1 772 Kbps

Video
ID                                       : 256 (0x100)
Menu ID                                  : 1 (0x1)
Format                                   : HEVC
Format/Info                              : High Efficiency Video Coding
Format profile                           : [email protected]@Main
Codec ID                                 : 36
Duration                                 : 53s 520ms
Width                                    : 1 440 pixels
Height                                   : 1 080 pixels
Display aspect ratio                     : 16:9
Frame rate                               : 29.970 (30000/1001) fps
Standard                                 : Component
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Color range                              : Limited

Audio
ID                                       : 257 (0x101)
Menu ID                                  : 1 (0x1)
Format                                   : AAC
Format/Info                              : Advanced Audio Codec
Format version                           : Version 2
Format profile                           : LC
Muxing mode                              : ADTS
Codec ID                                 : 15
Duration                                 : 53s 973ms
Bit rate mode                            : Variable
Channel(s)                               : 2 channels
Channel positions                        : Front: L R
Sampling rate                            : 48.0 KHz
Frame rate                               : 46.875 fps (1024 spf)
Compression mode                         : Lossy
Delay relative to video                  : -701ms

Menu
ID                                       : 4096 (0x1000)
Menu ID                                  : 1 (0x1)
Duration                                 : 53s 453ms
List                                     : 256 (0x100) (HEVC) / 257 (0x101) (AAC)
Service name                             : Service01
Service provider                         : FFmpeg
Service type                             : digital television
To receive meaningful assistance you will need to provide a full debug log.

The instructions are here... debug log (wiki)

If you are using the Basic Method, then ensure the following is applied...
1.Enable debugging in Settings>System Settings>Logging,
2.Restart Kodi
3.Replicate the problem.
4.Upload the log to Kodi Paste Site manually or use the Kodi Logfile Uploader. (wiki) With either method post the link to the log back here.

If you are using the Advanced Method ensure you have correctly created and applied the advancedsettings.xml file (wiki)

In both instances, you should see the word DEBUG throughout the log.

Note: Full logs only. No partial or redacted logs
Do NOT post your logs directly into the forum. Use the Kodi Paste Site. Post the link to your pasted log in the forum
I uploaded log
https://paste.kodi.tv/
(2019-01-27, 10:02)k3park Wrote: [ -> ]I uploaded log
Yes, unfortunately you forgot the do steps 1, 2 and 3 as per above request, and only did step 4.

There is no video being played in your log file.
This is play log

Code:

17:05:47.603 T:123145368293376   DEBUG: AddOnLog: Tvheadend HTSP Client: pvr.hts - demux open
17:05:47.603 T:123145368293376   DEBUG: AddOnLog: Tvheadend HTSP Client: pvr.hts - demux subscribe to 297189685
17:05:47.603 T:123145368293376   DEBUG: AddOnLog: Tvheadend HTSP Client: pvr.hts - demux successfully subscribed to channel id 297189685, subscription id 1
17:05:47.605 T:123145368293376   DEBUG: CDVDInputStreamPVRManager - Open - playback has started on filename pvr://channels/tv/All channels/pvr.hts_297189685.pvr
17:05:47.605 T:123145368293376   DEBUG: CDVDInputStreamPVRManager::Open - stream opened: pvr://channels/tv/All channels/pvr.hts_297189685.pvr
17:05:47.605 T:123145368293376  NOTICE: Creating Demuxer
17:05:47.605 T:123145382322176   DEBUG: AddOnLog: Tvheadend HTSP Client: pvr.hts - demux unhandled subscription message [subscriptionGrace]
17:05:47.605 T:123145368293376   DEBUG: OnPlayBackStarted: play state was 1, starting 1
17:05:47.605 T:123145368293376   DEBUG: CVideoPlayer::SetCaching - caching state 2
17:05:47.605 T:4612924864   DEBUG: PlayFile: OpenFile succeed, play state 2
17:05:47.605 T:123145368293376   DEBUG: CDVDClock::SetSpeedAdjust - adjusted:0.000000
17:05:47.605 T:4612924864   DEBUG: OnPlayBackStarted: play state was 2, starting 0
17:05:47.607 T:123145375883264   DEBUG: CGUIInfoManager::SetCurrentMovie(pvr://channels/tv/All channels/pvr.hts_297189685.pvr)
17:05:47.607 T:123145369366528   DEBUG: CAnnouncementManager - Announcement: OnPlay from xbmc
17:05:47.607 T:123145369366528   DEBUG: GOT ANNOUNCEMENT, type: 1, from xbmc, message OnPlay
17:05:47.778 T:123145375346688   DEBUG: Version Check: Version installed {u'major': 17, u'tag': u'stable', u'minor': 6, u'revision': u'20171114-a9a7a20'}
17:05:47.778 T:123145375346688   DEBUG: Version Check: Version available  {u'major': u'17', u'extrainfo': u'final', u'tagversion': u'', u'tag': u'stable', u'addon_support': u'yes', u'minor': u'6', u'revision': u'20171114-a9a7a20'}
17:05:47.778 T:123145375346688   DEBUG: Version Check: There is no newer stable available
17:05:47.778 T:123145375346688    INFO: CPythonInvoker(0, /Users/user/Library/Application Support/Kodi/addons/service.xbmc.versioncheck/service.py): script successfully run
17:05:47.781 T:123145375346688    INFO: Python script stopped
17:05:47.781 T:123145375346688   DEBUG: Thread LanguageInvoker 123145375346688 terminating
17:05:50.287 T:4612924864   DEBUG: ------ Window Deinit (Pointer.xml) ------
17:05:50.508 T:4612924864   DEBUG: ------ Window Init (Pointer.xml) ------
17:05:53.690 T:4612924864   DEBUG: ------ Window Deinit (Pointer.xml) ------
Problem persists in 18 Leia

I Think this is kodi problem
HEVC streaming playable in vlc with same tvh server