Kodi Community Forum

Full Version: 10 minute screensaver
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Running Leia stable (18.0 Git:20190128-d81c34c) on Linux Mint 18.3 Sylvia

Whenever Kodi is idle/video paused for 10 minutes, it switches off the screen. I've checked screensaver settings in Kodi and it is disabled.
I've checked screensaver settings in Cinnamon and MATE and they are both disabled also

Is there a way of disabling this please ?
if you haven't done already, check the power saving options as well (both in Mint as in Kodi as well).
most linux distros will have a 'blank screen after X minutes' option under the power settings.

in Kodi, check Settings > System > Power saving > Put display to sleep when idle
Sorry, should have mentioned that I've already checked the distro and Kodi power saving, and both are disabled.
Incidentally, it never went to sleep in Kodi 17.6
could you post a Debug Log?

- enable debug logging in kodi
- restart kodi
- let it idle for 10 minutes until the screen goes blank
OK, thanks. Did that. When the screen went blank, checked the log and there were no additional entries.
Log uploaded : https://pastebin.com/NEh0qfC5
as there's nothing logged, it's not very likely the screen blanking is initiated by kodi.

can you run this command in a terminal and paste the output here?
xset -q
I'm having the exact same symptoms as the OP, on Ubuntu 16.04.5 (same Kodi version): putting the screen to sleep is disabled in both the OS and Kodi, but my monitor shuts off after ~10 minutes. 
This started immediately after upgrading Kodi.  I've changed no other settings.  For ~2 years (as long as I've had this machine), and a few Kodi major versions, Kodi would always just dim the screen, not completely blank it or shut the monitor off.Here's the output of
Quote:xset -q
:
Quote:[email protected]:~$ xset -q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000002
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    on     02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  500    repeat rate:  30
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
Colors:
  default colormap:  0x69    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/Type1,built-ins
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On
Try:

1.) xset s off -dpms
2.) kodi

from the same terminal. Still 10 minutes issue?
(2019-02-02, 11:58)fritsch Wrote: [ -> ]Try:

1.) xset s off -dpms
2.) kodi

from the same terminal. Still 10 minutes issue?
That seems to have done it.  Thank you!  For anyone else who's reading, since I start Kodi automatically once a certain user logs in, I ended up editing the Kodi X session:

Edit /usr/share/xsessions/kodi.desktop and point it to a new executable:

[Desktop Entry]
Name=Kodi
Comment=This session will start Kodi media center
Exec=kodi-no-blank-screen
TryExec=kodi-no-blank-screen
Type=Application
(Note the `Exec` and `TryExec`.) 

`kodi-no-blank-screen` didn't exist, so I created it in /usr/bin/ and made it executable.  It's just

#!/bin/sh

xset s off -dpms

/usr/bin/kodi-standalone -fs
(2019-02-02, 22:18)StallmanWasRight Wrote: [ -> ]
(2019-02-02, 11:58)fritsch Wrote: [ -> ]Try:

1.) xset s off -dpms
2.) kodi

from the same terminal. Still 10 minutes issue?
That seems to have done it.  Thank you!  For anyone else who's reading, since I start Kodi automatically once a certain user logs in, I ended up editing the Kodi X session:

Edit /usr/share/xsessions/kodi.desktop and point it to a new executable:
[Desktop Entry]
Name=Kodi
Comment=This session will start Kodi media center
Exec=kodi-no-blank-screen
TryExec=kodi-no-blank-screen
Type=Application
(Note the `Exec` and `TryExec`.) 

`kodi-no-blank-screen` didn't exist, so I created it in /usr/bin/ and made it executable.  It's just

#!/bin/sh

xset s off -dpms

/usr/bin/kodi-standalone -fs
 
 Thanks for this. A nice elegant workaround.
However surely this IS a Kodi issue as previous versions never put the screen to sleep !?
It's not kodi putting you to sleep, but your system configured to do DPMS ... we are an application and - unlike in v17 - we don't kill your system settings ... if you play a video / music with viz we won't switch you anywhere.
In short: if you want that your system does not go into power saving mode, disable it in the system - and this is NOT Mint / whatever screensaver.
Are you running Kodi from within Mint/Ubuntu, so you first boot into the OS and then run Kodi?

I ask because on my system if I run Kodi from the desktop the screensaver kicks in. If you boot directly into Kodi this doesn't happen.

Just a thought.

To set your system to auto boot into Kodi:

1. Create /etc/lightdm/lightdm.conf
sudo nano /etc/lightdm/lightdm.conf

2. Add the following lines (kodi is the username, substitute your Linux username)
[Seat:*]
autologin-user=kodi
autologin-session=kodi

3. Quit and save then reboot

Nick
I confirm a bug. The display shuts down in 10 minutes of idle. This happened after upgrading to Kodi Leia.
Ubuntu 18.04, Kodi in headless configuration. All sleep functions of Kodi and OS are suppressed.

I'll try the workaround, thanks.
Pages: 1 2