Kodi Community Forum

Full Version: RetroPlayer / PS1 controller issue
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have a wired 360 controller which has worked fine with RetroPlayer for NES/SNES/GENESIS and MAME but today I tried loading a Playstation 1 ROM and I get nothing.  Strange thing, I can access the RetroPlayer menu but I can't start a game.  I went into the Controller option where I get a list of controllers and even went as far re-configuring the Playerstation gamepad but still nothing.  Is there an extra step that needs to be done that I'm missing?  Also, when the game loads I see a couple of messages about dual shock controllers.  Maybe its trying to locate them?
I made a little progress.  Some games I can get the controller working and others I cannot.  The first game was Command & Conqueror which I tried both Beetle & Rearmed with the same result.  I was able to get Asteroids to play in Beetle.  Is there controller issue with some games and RP when emulating the PS1?  

Here is a log of my experiments:
https://pastebin.com/zdFWkKpu
I got it worked out!  After I enabled DualShock Analog button toggle in PSX Beetle settings everything is working.  The button mapping changed but that is a problem for another day.
Hello, how do you map an old console's virtual controler to a real Xbox controler?
Thanks
Gz
When your in-game you can press select + X to bring up the RetroPlayer settings, in there you can get to the Controls menu to configure the buttons.
X does not work on my Xbox One controller but I got it with the escape button of my keyboard. Thanks.

Then I have the Colecovision controller but a text says "nothing to map". Any idea?
Sorry, I have not messed with the Coleco yet.  If I get a chance today I will try and report back my results.  I would suggest creating a new thread for this so your question doesn't get lost in this thread.
I installed the Colecovision Controller add on, but still no way to "map" keys - as it just says "Nothing to map"