Kodi Community Forum

Full Version: Could not connect to Kodi Add-on repository
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
SETUP
Version of Kodi: Kodi 18 Leia
Windows Version: Windows 10 Pro
CPU/Architecture: Intel i3 3220, 64 bit
RAM: 8GB

ISSUE
Tried to install YouTube video addon from Kodi Add-on repository.
An error message is displayed "Could not connect to repository"

LOG FILE
iremeyaroj.kodi (paste)

What I have tried so far
Have a similar issue with Raspberry Pi running LibreELEC 9.0.0.
Was advised in LibreELEC forum that the Add-ons host is out of sync so the checksum does not match, thus Kodi cannot load the repo files.


Wondering if this would be the cause of the issue and whether it could be resolved in the near future.

Thank you.
Appreciate if someone could advise.
Thank you.
I have pinged a couple of team members. It is possibly a problem with the mirror that serves your location. Just waiting for a response.
@darkblaster77

Could you advise the following...
1. How often do you have this problem?
2. When did it start?
3. Is the issue continuous or do you sometimes have access to the repo update, and sometimes you don't?

Can you provide another Debug Log thanks. With this one, can you go into Settings>System Settings>Component Logging and enable The libcURL library (HTTP(S), DAV) . Make sure you capture the Update Repository again.

Thanks
1. How often do you have this problem?
All the time.

2. When did it start?
I first encountered this error when I ran LibreELEC 9.0.0 (Kodi 18 Leia) on my Raspberry Pi.
Similarly, I have posted in LibreELEC forum.  https://forum.libreelec.tv/thread/14458-...epository/
And I am also experiencing the same issue running Kodi 18 Leia on Windows 10.


3. Is the issue continuous or do you sometimes have access to the repo update, and sometimes you don't?
Not able to get it to work once.


Uninstall Kodi and did a fresh installation.
Encountered the same error message when I tried to install YouTube video add-on from official Kodi repository.

Enable component logging as requested. Please refer to the log file below.
ecumozojek.kodi (paste)

Thank you.
Thanks. That was massively helpful.
I now see what is happening, but I need to verify why it happens and how we can stop it Smile

I do not think we need more logs at this point, please let us investigate on the mirror infrastructure.
We were thrown a bit by this, because at first glance it seems you are being redirected by us, to go to one of our mirrors.

This is not the case. You are being redirected by someone else, to request your file through an internet caching server located at 103.1.138.206
You basically get told to connect through http://103.1.138.206/<whatever_you_asked_for&gt; so it can download the file and cache it for other users.

Sadly, this cache is a bit broken and doesn't handle arguments to the query correctly.

The cache receives from you that you want to get the checksum of http://mirrors.kodi.tv/addons/leia/addons.xml.gz?sha256 but it strips off the ?sha256 and asks our mirror for the http://103.1.138.206/mirrors.kodi.tv/add...ons.xml.gz instead, which is not a checksum but a binary file. Kodi receives this binary nonsense as a checksum value.

Later when you download the file your machine calculates the checksum of it, and notices that it doesn't match the binary nonsense you got earlier.

If possible, you could try not using an internet provider that doesn't use this 'broken and nontransparant internet accelerator'
If the 'accelerator' is an optional feature or something you signed up for, try to disable it.

Not great news I am afraid. This will likely break other websites and applications on the internet as well.

Kib

EDIT: the server calls itself "www.Singaporeapp.com (Cdn Cache Server V2.0)"
I have no luck turning off the internet accelerator.

However, I managed to overcome this issue.
I did an initial connection through my mobile data.
Once the list in Kodi repository is shown, I can switch back to the original connection and proceed with the installation.

Strange but it works. =)