Kodi Community Forum

Full Version: Does not download movie thumbnails from filmaffinity.es
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hello...

Recently I have noticed that automatic scan of movie contents, does not download properly all the movie info, as well as it does not download current movie thumbnail. This ocurrs with filmaffinity sources (spanish films).

The current scrapper does not good with filmaffinity, I guess, although it is running perfectly with IMDB, by example, downloading all the data and thumbs.

A week ago, filmaffinity scrapper was running perfect, downloading all data without problems.... ¿maybe changes at website?

I have seen this:
http://forum.xbmc.org/showthread.php?tid...lmaffinity
(but it seems offtopic)

Have someone tested it recentlyHuhHuh? (i am using curring svn version). Filmaffinity is godness por spanish people.

Thanks.
Hi!

<td ><img src="/imgs/countries/US.jpg" title="Estados Unidos" border="0" align="middle"></td>

The country title used to be in the alt field but it is (obviously) not there anymore. If the page is being parsed with REE, you will probably have to update them.

Cheers!
they are, patch is most welcome
Hola, gracias por postear, porque si no no me entero, tengo poco tiempo últimamente y no tengo pelis nuevas y no he probado por lo tanto el scrapper.
Acabo de entrar a filmaffinity y aparentemente el aspecto de la página sigue siendo igual, pero claro, basta con que en el html haya cualquier detalle diferente para que no lea nada.
Le echaré un vistazo cuando vuelva de vacaciones mañana 24 (que aquí celebramos San Juan).

La única pega es que aunque lo arregle mañana, los de xbmc tardan bastante en publicarlo en una siguiente versión, ya miraré de cómo postearlo en algún sitio para los impacientes

Un saludo

HectorziN
hectorzin, did you notice revision 13676

iirc you asked for this at some point in timeSmile
Sorry, I forgot to write in English.

I will test the scrapper and fix it this week. I am on holidays until tomorrow 23.

Thanks.
cool,

revision 13676 allows you to use a tag

SearchStringEncoding on <CreateSearchUrl> to specify which encoding you want. iirc this backend does not want utf-8..
I dind't notice this revision. I didn't receive an email to my comment on this.
Thanks a lot spiff. I will make a patch that also includes the UTF encoding. this will allow finding tittles with ñ caracter as well.
HectorziN Wrote:I dind't notice this revision. I didn't receive an email to my comment on this.
Thanks a lot spiff. I will make a patch that also includes the UTF encoding. this will allow finding tittles with ñ caracter as well.

Thanks thanks so much for taking care of this scrapper... Wink
Torre Wrote:Hi!

<td ><img src="/imgs/countries/US.jpg" title="Estados Unidos" border="0" align="middle"></td>

The country title used to be in the alt field but it is (obviously) not there anymore. If the page is being parsed with REE, you will probably have to update them.

Cheers!

Yes, this is the problem, but I don't understand why all the scraper faults and not only the tag for this field.

I am fixing it right now.
spiff Wrote:cool,

revision 13676 allows you to use a tag

SearchStringEncoding on <CreateSearchUrl> to specify which encoding you want. iirc this backend does not want utf-8..

Hi spiff, I cannot find documentation about how to use SerachStringEncoding.
I have fixed the scraper, but i would like to fix the encoding to allow searching titles with ñ or á é í ó ú.

Thanks.
HEY...

Wonderful.... HectorziN has emailed me the new XML file... I have just compiled svn version using this xml updated file, and the scrapper did good.

It is currently fixed, perfect.

Please, update xml version at current svn with HectorziN one... The link given to me by HectorziN is:

http://xbmc.svn.sourceforge.net/viewvc/*...finity.xml

Thanks so much... HectorziN , 10 points...
hi!?
13792 and seems to be not updated into svn.
Hi Spiff, do you know why in the last compilation changelog http://t3ch.yi.se/changes.php is no reference to 13676?

thanks!
Hi Spiff, do you know about if 13676 is included in last builds?
Pages: 1 2