Kodi Community Forum

Full Version: Help with custom images in Leia
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Just starting on the journey in skinning - I've tried searching the forum, but couldn't see the answer to my question.

Im on Leia and skinning the Estuary.

Basically, I would like an IMDB icon to be a part of my media flags - i.e. to appear at the bottom of the screen when a movie / tv show is selected.

I am planning on doing this by altering the Includes.xml

So far, I have duplicated RatingCircle and renamed it RatingCircleBottom. I've got the rating to display just next to duration by including 
<control type="group">
<top>10</top>
<width>60</width>
<align>left</align>
<aligny>center</aligny>
<include content="RatingCircleBottom">
</include>
</control>
 in the MediaFlags section.

My next step is adding the IMDB image to the section. I have the image in my skin folder customnameskin/media/sausage/imdb.png
I tried creating another <include name="imdbicon"> and then creating another <control type="group"><include content="imdbicon"> just before the code above.

<include name="imdbicon">
        <control type="image">
            <left>3</left>
            <top>-3</top>
            <align>center</align>
            <aligny>center</aligny>
            <width>44</width>
            <height>44</height>
            <texture>sausage/imdb.png</texture>
        </control>
    </include>

However, no go.

Tried also including the imdb icon in the following way

    <include name="UserRatingContentBottom">
        `<visible>!String.IsEmpty($PARAM[infolabel])</visible>
        <control type="image">
            <left>3</left>
            <top>-3</top>
            <width>44</width>
            <height>44</height>
            <aspectratio>keep</aspectratio>
            <texture colordiffuse="button_focus">special://skin/media/sausage/imdb.png</texture>
        </control>
        <control type="label">
            <left>3</left>
            <top>-3</top>
            <align>center</align>
            <aligny>center</aligny>
            <width>44</width>
            <height>44</height>
            <font>font20_title</font>
            <label>$INFO[$PARAM[infolabel]]</label>
        </control>
` </include>`

That hasn't worked either.

I wonder whether I am missing something? I can see the texture files (interestingly, I have renamed them and removed them from the folder and haven't noticed any difference).

Any thoughts?
this is the correct way to load a texture from the media folder: <texture>sausage/imdb.png</texture>
the special://skin/ prefix is only needed for using textures outside of the media folder.

in case kodi can't find a texture, it will be logged in the Debug Log, so always check that.

if renaming/removing makes no difference (if i understand you correctly) make sure there is no Textures.xbt file present in the media folder.
Thanks! I totally forgot about debug log.

Lo behold, CGUITextureManager::GetTexturePath: could not find texture 'sausage/imdb.png'.

It's strange, as the image is there.

Any thoughts?
if kodi can't find it, it's not there ;-)

not sure what OS you're using, but unless it's windows, you'll have to keep case-sensitivity in mind.
I created the appropriate tree in a backup kodi folder, which i thought I changed the paths to.

I hadn't. 

It works wonderfully now

Thanks!