Kodi Community Forum

Full Version: KODI 18.1 NON NEON FOR Tegra 2 and Android 4.0.3
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Doesn't work on Xperia SP running Android 4.3... any updates coming to this?
Does not open .apk file after download.

Any suggestions?

Device: Tablet Acer Iconia A1-830 running android 4.4.2.

https://www.gsmarena.com/acer_iconia_a1_830-5930.php
I think it's because there is a problem  with  value to the API Level  "SDKVersion" in manifest file.  I don't know much of anything.. anyway  I used apk edit pro to fixed it but after that  app didn't work . 
I tested kodi version 17.6 for android 4.0.3 device  and I can say that it works very well . However , InputStream Adaptive addon is not available and it isn't possible to install it and in this way many addons cannot work.
That's why I tested kodi 18.1 . However, since kodi version 17.6 for android 4.0.3 works well ,  I'm asking  kindly if it is possible to release a kodi version 17.6 for android 4.0.3 that include InputStream Adaptive addon . 
 
*It is easy to guess English is not my native language but I hope  it's pretty clear to understand what I mean.
(2019-03-12, 17:37)tetramarreta Wrote: [ -> ]Please test version 18.1 for NON-NEON Android 4.0.3 or higher (without MediaCodec "

With all Addons
Please Test

https://www.dropbox.com/s/xt51cilw6m3t0r...1.apk?dl=0



Hi,i want to test it,but it's can't be download in China,could you share it by another link? thanks
(2019-03-12, 17:37)tetramarreta Wrote: [ -> ]Please test version 18.1 for NON-NEON Android 4.0.3 or higher (without MediaCodec "

With all Addons
Please Test

https://www.dropbox.com/s/xt51cilw6m3t0r...1.apk?dl=0
Please test version 18.1 for NON-NEON Android 4.0.3 or higher (without MediaCodec "

With all Addons
Please Test

https://www.dropbox.com/s/xt51cilw6m3t0r...1.apk?dl=0
Hi,i want to test it,but it's can't be download in China,could you share it by another link? thanks
(2019-03-12, 17:37)tetramarreta Wrote: [ -> ]Please test version 18.1 for NON-NEON Android 4.0.3 or higher (without MediaCodec "

With all Addons
Please Test

https://www.dropbox.com/s/xt51cilw6m3t0r...1.apk?dl=0


hi, when i downloaded it on my android 4.4.2 it gave an analysis error, the app is on api 21 and this app only works on android 5.0 and higher, i tried to decrease it to api 19 (android 4.4) by the apk editor pro, the kodi opened and loaded the first boot page until the end, but after that the application darkened and closed, does anyone have any idea how to fix it, kodi 18 is the only one that works add Netflix
Por favor alguém conseguiu ajeitar?? Minha tv tem Android 4.4 e queria assistir Disney+ nela, só que o app é incompatível, com o kodi 18 eu poderia assistir super bem nela, agradeceria muito se alguém ajudasse❤️
This 18.1 build does not work on an Asus TF101, 17.6 works.
Are the Kodi Team going the way of Apple and forgetting its roots?
There is a huge market of people who have high end devices but slightly outdated.
Someone please help. You love this OS too much to have others suffer.
This isn't right! Especially, since there's many of you who have a passion for this. 

Toshiba Thrive (AT100), Android version 4.0.4, Kernel 2.639.4, ("Non-Neon")
[50%+ of default apps disabled, 400MB-420MB ram free on average]

We downloaded and clicked on the app several times and receive the same message,
 "there was an error parsing the package".

This app doesn't work with our devices, plus its outdated.

The previous builds have no functioning repos - Allow us to be worthy of the Matrix!


We are all on a raft and Wilson is floating away, say it isn't so...
(2022-02-16, 19:12)okokok Wrote: [ -> ]Are the Kodi Team going the way of Apple and forgetting its roots?
There is a huge market of people who have high end devices but slightly outdated.
You call an OS that is 11 years old "slightly outdated"? Well, perhaps that could be your perception after your hibernation away from our forum for some 14 years.
Comparing us to Apple wouldn't be fair to us IMO. All the releases we have done as XBMC and Kodi were free of charge to the public. I don't remember Apple doing that.

(2022-02-16, 19:12)okokok Wrote: [ -> ]You love this OS too much to have others suffer.
Kodi is not about OSes. And telling us we make others suffer is you having quite a twisted mindset. Android 4.0 is some 11 years old. We are not in the business of reviving the dead. Kodi has had a minimum requirement of Android 5 for quite some time now. Life goes on. I suggest you do the same.

(2022-02-16, 19:12)okokok Wrote: [ -> ]This isn't right! Especially, since there's many of you who have a passion for this. 
Apparently not that many, as we are out of a dedicated Kodi developer for Android for some time now. And unfortunately, these developers do not grow on trees or out in the fields.
You really are cold as ice! But all joking aside, I appreciate the response.

One, two, eleven, it still is a solid device after checking it out a bit. Pick one up and see for yourself if you have money to waste.
I got mine from a family member who was talked into buying it at Verizon.
I thought it as broken until I realized it uses a mini laptop brink and found it in a laptop bag used for travel.

Here's some info for others suffering within "404 Nightmare".
It's old, unsupported and doesn't provide functionality that current Kodi needs to run properly (or indeed at all).

Plus as noted, we don't exactly have an infinite resource of developers, especially for Android. So we support modern versions only, as they provide the capabilities that Kodi needs. If you must run something ancient, then you will need to run an equivalently ancient version of Kodi on it, and that will certainly be a very degraded experience. Addons for the most part won't work for example - certainly current ones won't as they are Python3 and any older version of Kodi needs addons in Python2.

Basically it's not going to happen, and the way things are going with Android development it's only going to get worse potentially.
After testing the different builds available and much patience waiting for the lists to populate,
I am now streaming movies online just fine by turning both accelerators OFF within the options menu.
The verdict is, as of 02/17/2022, the last build compatible with the Toshiba Thrive (AT100) is KODI 17.6 NON NEON FOR Tegra 2 and Android 4.0.3.
The hardware has been saved and this cold case comes to a close. Now time for retro gaming, movies, and HDMI out!
If the kodi-guide is done correctly the system runs great with 44% of the 725MB of ram left to spare!
I'm a little surprised there, as I thought 17.x was the cut-off where Android 5 and up was needed.

So you might find that not everything works if you do a wider test, but if it's enough for your needs (as it seems to be from the imgur clip) then good luck to you with it, and enjoy! Smile
Pages: 1 2