Kodi Community Forum

Full Version: Kodi 18.1 how can I set fps matching refreshrate
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm on obuntu server 18.04.2 with Nvidia Geforce GTX750ti and i3 4330.
Right know I have the problem, that the fps did not match to the refreshrate anymore.
while I watchig Live-TV or video H264 59,94fps the frames per second goes down.
so it's horrible to watch.

KODI settings
System ->Player->Processing:
Enable HQ Scalers for scaling above: 20%
Allow hardware acceleration - VDPAU: on
Use Mpeg-2 VDPAU: Yes
Use Mpeg-4 VDPAU: No
UseVC-1 VDPAU: on


System -> Player -> Playback
Adjust Refreshrate to match video: On start / stop
Sync Playback to Display: Off

debug log
Please have debugging already enabled when you (re)start Kodi. Enabling debugging manually somewhere "in the middle" might overlook certain logging in the beginning.

Also, which Nvidia drivers are you using: the proprietary one (which version?) or Nouveau?
I'm using the proprietary one 418.56

obuyokemir.kodi (paste)
Maybe I'm wrong, but why do you think the stream you are playing is a 59.94 fps stream? Kodi seems to detect it as a 25fps stream:

2019-03-23 20:22:45.835 T:139671508674304 NOTICE: Whitelist search for: width: 1920, height: 1080, fps: 25.000, 3D: false

As for the reason you don't have anything set in your whitelist you will have the "Kodi 17"-feeling for that and Kodi seems to switch perfectly fine to a doubled refreshrate:

Code:

2019-03-23 20:22:45.835 T:139671508674304 DEBUG: Whitelist is empty using default one
2019-03-23 20:22:45.835 T:139671508674304 DEBUG: Trying to find exact refresh rate
2019-03-23 20:22:45.836 T:139671508674304 DEBUG: No exact whitelisted resolution matched, trying double refresh rate
2019-03-23 20:22:45.836 T:139671508674304 DEBUG: Matched fuzzy whitelisted Resolution HDMI-0: 1920x1080 @ 50.00Hz (24)
2019-03-23 20:22:45.836 T:139671508674304 NOTICE: Display resolution ADJUST : HDMI-0: 1920x1080 @ 50.00Hz (24) (weight: 0.000)
2019-03-23 20:22:45.838 T:139674881012608 NOTICE: CWinSystemX11::SetFullScreen - calling xrandr
2019-03-23 20:22:45.838 T:139674881012608 DEBUG: OnLostDevice - notify display change event
2019-03-23 20:22:46.226 T:139674881012608 NOTICE: VideoPlayer: OnLostDisplay received
2019-03-23 20:22:46.226 T:139674881012608 WARNING: CDVDMessageQueue(audio):Tongueut MSGQ_NOT_INITIALIZED
2019-03-23 20:22:46.226 T:139674881012608 WARNING: CDVDMessageQueue(video):Tongueut MSGQ_NOT_INITIALIZED
2019-03-23 20:22:46.226 T:139674881012608 DEBUG: Flush - flushing renderer
2019-03-23 20:22:46.231 T:139674881012608 INFO: XRANDR: /usr/lib/x86_64-linux-gnu/kodi/kodi-xrandr --screen 0 --output HDMI-0 --mode 0x1c7

The mode 0x1c7 Kodi switches to is:

2019-03-23 20:18:49.153 T:139674881012608 INFO: ID:0x1c7 Name:1920x1080 Refresh:50.000000 Width:1920 Height:1080

So, beside the fact that I might have missed the section in the log where it is mentioned that you are currently playing a 59.94 fps stream or Kodi detects the stream wrong, I don't see what Kodi does wrong here.
The real issue the OP has, kodi sets the right FPS, but his setup cannot provide those FPS anymore. Therefore he gets stutter and it feels unwatchable.

If you press ctl shift o  (kodi-send -a PlayerDebug) do you get skips or drops?

I would suggest you just remove the nvidia card from this system entirely. The 4330 Haswell is much better tested and therefore might have better performance.
@DaVu 
the log from the first post was a 59,94 stream. I pressed "o" and kodi shows me 1920x1080 59,94p
the second log was live-tv from the TVH server with 1080p50hz.
What do you mean with Kodi 17 feeling?

@fritsch 
yes, you a right. the i3 ist good enough. But I use dolphin-emu for my two Kids. It worked for years without problems.
Kodi starts the streams with the right fps but after a while it goes down. I only found this on 50hz and 59,94hz streams.

I'm wondering if it could be related to my Samsung TV. last year I've to buy a new Samsung. I'm not shure but I think
it was from this time on. But not sure.
No - it's not related. Nvidia is not really tested anymore as this is deadend with their inability to extend VDPAU support for wayland, etc.

If it worked for years, please downgrade. Never change a running system. No one in kodi wants to support a "blob only vendor" relying on outdated technology.

Try to start kodi like this to not accidently running into the EGL path: 
Code:
KODI_GL_INTERFACE=GLX kodi
@:'fritsch'

I followed your manual. And it works yesterday without that issue.
So it is like you said the Nvidia.

So to use dolphin again I‘ve to look for a i5 or i7 Haswell.

Thanks for your help!