Kodi Community Forum

Full Version: Black screen on kodi with upgrade from Kodibuntu 16.04 to kodi on lubuntu 18.04.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello,

I had an up-to-date kodibuntu based on lubuntu 16.04.
As i updated to 18.04, i had to remove and reinstall kodi (removing all kodibuntu packages), using kodi ppa (2:18.1+git20190217.1232-final-0bionic).

Now, when kodi starts automatically i get a black screen with some horizontal lines.
Sound is working, party autostart start playing, so kodi works, except for the display.

If if restart kodi service from command line, everything works fine.
So it may not only be related to kodi, maybe it starts before a needed service ?

Booting with addons and userdata folders removed doesn't change anything.

Here's the debug log when kodi is autostarting with a black screen :
https://paste.ee/p/iyLBf

And here's the one when i restart it manually and everything works fine :
https://paste.ee/p/6emDN

Comparing both logs doesn't show anything really different from kodi side, or maybe i missed something.

Here's some hardware details :
Quote:[email protected]:/home/kodi/.kodi/temp# uname -a
Linux HTPC 4.15.0-46-generic #49-Ubuntu SMP Wed Feb 6 09:33:07 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

[email protected]:/home/kodi/.kodi/temp# lspci
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 14h Processor Root Complex
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 7340]
00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler HDMI Audio
00:04.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 14h Processor Root Port
00:10.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB XHCI Controller (rev 03)
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 40)
00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB OHCI Controller (rev 11)
00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB EHCI Controller (rev 11)
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB OHCI Controller (rev 11)
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB EHCI Controller (rev 11)
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 14)
00:14.1 IDE interface: Advanced Micro Devices, Inc. [AMD] FCH IDE Controller (rev 40)
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 01)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 11)
00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD] FCH PCI Bridge (rev 40)
00:14.5 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB OHCI Controller (rev 11)
00:14.7 SD Host controller: Advanced Micro Devices, Inc. [AMD] FCH SD Flash Controller
00:15.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Hudson PCI to PCI bridge (PCIE port 0)
00:15.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Hudson PCI to PCI bridge (PCIE port 2)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 0 (rev 43)
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 3
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 6
00:18.6 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 5
00:18.7 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 7
03:00.0 Network controller: Intel Corporation Centrino Wireless-N 135 (rev c4)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)

Any idea ?
Seems to be an issue with X Server :
https://pastebin.com/V692K6nz
I may have found the cause :
Quote:[email protected]:/etc/lightdm# ll
total 36
drwxr-xr-x   4 root root  4096 Mar 23 20:19 ./
drwxr-xr-x 151 root root 12288 Mar 23 19:16 ../
-rwxr--r--   1 root root   195 Oct 27  2016 lightdm.conf*
drwxr-xr-x   2 root root  4096 Mar 23 17:59 lightdm.conf.d/
lrwxrwxrwx   1 root root    55 May 20  2015 lightdm-gtk-greeter.conf -> /etc/alternatives/lightdm-gtk-greeter-config-derivative
drwxr-xr-x   2 root root  4096 Mar 23 17:01 lightdm-gtk-greeter.conf.d/
-rw-r--r--   1 root root  2970 Mar 20  2018 lightdm-gtk-greeter.conf.dpkg-new
-rw-r--r--   1 root root   452 Oct 30  2014 users.conf

[email protected]:/etc/lightdm# ll /etc/alternatives/lightdm-gtk-greeter-config-derivative
lrwxrwxrwx 1 root root 51 May 20  2015 /etc/alternatives/lightdm-gtk-greeter-config-derivative -> /etc/xdg/kodibuntu/lightdm/lightdm-gtk-greeter.conf
/etc/xdg/kodibuntu/lightdm/lightdm-gtk-greeter.conf doesn't exist anymore.

So, i replaced lightdm-gtk-greeter.conf with lightdm-gtk-greeter.conf.dpkg-new but it doesn't help.
And the issue disappeared ...
Well Big Grin