Kodi Community Forum

Full Version: Updated Kodi on Ubuntu 18.04.2 does not play ts (MPEG transposrt stream)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
This is weird. The problem is back again with the freshly created kodi configuration.

I'll have to go through each of the changes that I made to see what causes this problem. I only have three AddOns (so far):
* TVHeadEnd
* East Anglian Film Archive
* British Council Film

I'll post back if I find out what is causing this.
The problem occurs whenever the following
UPnP / DLNA -> Look for remote UPnP players
UPnP / DLNA -> Allow remote control via UPnP
two settings are true

Setting them to false and restarting Kodi resolves the issue.

[Edit: this problem also exists with Kodi on Fedora - it is easy to reproduce]
Does your network have a computer that anounces upnp player capabilities?
When you say "announcing upnp player capabilities" do you mean a computer that is discoverable via something like upnp_info and which reports that it is a Media Renderer? If you do then we  have an AVR which reports that it has "Device Type: urn: schemas-upnp-org:device:MediaRenderer:1".

Though as far as I am aware we do not use such features even if they are present.  There are adult children around so I cant be 100% sure.

My own usage of UPnP is pretty basic and only uses the Ubuntu Kodi's ability to be a Media Server.
You can enable UPNP component logging and see what you get in the log? After reenabling: UPnP / DLNA -> Look for remote UPnP players

Edit: What happens if you press "c" open with Videoplayer?
Here is the requested log: dimivaligo (paste)

The various IP addresses mentioned in the log are:
10.0.2.5  The Ubuntu Kodi machine
10.0.2.6  The AVR that I mentioned above
10.0.11.130 One of my daughter's android devices.

When I press "c" nothing happens.
c on the file you want to play, then choose VideoPlayer. Okay, but I think we have the culprit. Kodi trying to playback via the AVR / UPNP. So disable upnp renderer, please.
Sorry, I didn't explain myself very well.  When I pressed "c" after having selected a ts file, I was asked to select from the options: Play, Information, and Mark as viewed.  I selected Play, the popup disappeared and nothing else happened.

I'll keep set to false:
UPnP / DLNA -> Look for remote UPnP players
UPnP / DLNA -> Allow remote control via UPnP

If you need me to carry out any more tests don't hesitate to ask.
(2019-03-30, 10:09)wsnipex Wrote: [ -> ]there was another report of a broken fedora kodi package. You can try our flatpak version instead

Indeed, flatpak version would have been the best solution to this problem.
In the end it seems that, when using Kodi on Fedora the best solution is to use the Flatpak version as I found with a separate issue:
https://forum.kodi.tv/showthread.php?tid...pid2843406

With the Flatpak version of Kodi the UPnP problem of this thread does not occur.
Pages: 1 2