Kodi Community Forum

Full Version: TMDB TV scraper not working with one show
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm having an issue getting a show recognized and I have no idea how to proceed.  My kids have a single DVD of the show "Jake and the Never Land Pirates" that I converted to video files, one episode per file, and added to the library.  But no matter what I do, I cannot get the scraper to recognize the episodes.  All the other shows I added work, this is the only one with issues.  I use the same filename template for all shows, for example "s01e01 - Hide The Hideout!.mp4"  I've tried Kodi on my Raspberry Pi, Android, and Windows, and none of them will scrape.  I tried searching but a lot of the advice I found didn't apply, like settings for the old tvdb scraper and stuff.

In the debug logs, it appears to properly parse the episode number and season:
Quote:DEBUG: VideoInfoScanner: Found episode match D:\Videos\Jake And The Never Land Pirates\Season 01\s01e01 - Hide The Hideout!.mp4 (s1e1) [s([0-9]+)[ ._x-]*e([0-9]+(?Sad?:[a-i]|\.[1-9])(?![0-9]))?)([^\\/]*)$]
But then later on it gives me this:
Quote:DEBUG: VIDEO::CVideoInfoScanner::OnProcessSeriesFolder - no match for show: 'Jake and the Never Land Pirates', season: 1, episode: 1.0, airdate: '01/01/1601', title: ''
My entire debug log can be found at edodafecoh.kodi (paste)

This single issue has been driving me insane all weekend, I would appreciate any advice anyone can give me.

I can see the problem in your log and I was able to replicate the problem here also. There is nothing wrong with your setup or your naming of the show.

The problem is the entry at TheMovieDB, but I cannot figure out what is causing it to fix it. For some reason, clicking on S01E01 episode to edit it takes you to a completely different episode, so there seems to be a glitch there.

I have left a message for one of the Moderators there to take a look at the problem.

In the meantime, you can enable setting 3.6 here... https://kodi.wiki/view/Settings/Media/Videos#Library and then go back into your library and delete the partially scraped TV Show.

You can keep an eye on progress here... https://www.themoviedb.org/tv/34891-jake...uage=en-US
Thank you.  I had tried so many things and couldn't figure out what's going on.  Thanks for the info, I'll clear the show out and wait for it to be fixed.
I have identified another show with what appears to be the same issue, the show is "The Adventures Of Teddy Ruxpin", which is getting pulled into the library as "Angry Birds Toons" for some reason.  The episodes have Angry Birds titles and descriptions, but Teddy Ruxpin pictures.  Does this show have the same crossed-linked episodes the other one does?  The first show was at one point also coming in as Angry Birds Toons when I was messing with the name trying to get it to work.  I can provide a debug log later if needed.

Also, the issue that was posted for the first show doesn't seem to have been acknowledged yet.  How long does it usually take for things like this to get fixed?
Neither of those two shows have a problem at TheMovieDB, and they scrape perfectly fine for me here.

The mixing of TV Shows is indicative of bad nfo files from Sonarr/Radarr. Are you using nfo files?

Remove the two shows from the library and rescrape both of them and capture it in a debug log and I will have a look.

No response from TheMovieDB yet regarding your initial question.
Sorry about the false alarm, I am using a second Kodi system to get my shows properly named, and I added the individual show's base folder but forgot to select the "This folder contains one TV show option."  Selecting that option and the show scraped as it should.  I discovered this when it scraped fine on my main system, after asking for help of course.
No problem. Glad you solved that issue. Smile