Kodi Community Forum

Full Version: Cannot play iso files over smb with Kodi 18.1 on Fedora 29
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
One CPU core is stuck at 100% when I try to play an iso DVD image from an SMB source.  To recover I need to reboot.

Here are the details of my Kodi installation (team-xbmc stable):
 Starting Kodi from RPM Fusion (18.1 Git:20190220-nogitfound). Platform: Linux x86 64-bit
 Using Release Kodi x64 build
 Kodi compiled 2019-02-20 by GCC 8.2.1 for Linux x86 64-bit version 4.20.8 (267272)
 Running on Fedora 29 (Workstation Edition), kernel: Linux x86 64-bit version 5.0.5-200.fc29.x86_64
 FFmpeg version/source: 4.0.4
 Host CPU: Intel® Core™ i5 CPU 760 @ 2.80GHz, 4 cores available


Here is the log (I have enabled SMB component logging): aqimagefet (paste)

Within the log, the action begins at 2019-04-07 08:16:02.661

From the same SMB source, I am able to play correctly mkv and ts files.

The same problem is not present on LibreELEC 8.2.5 running on a raspberry Pi.

I am unsure if this is a Kodi or PC configuration issue or possibly a Kodi bug.

Can anyone point me in the right direction please?
Problem is not the samba source - but the out of tree libdvd that Fedora most likely builds.

Please build kodi from source and don't use external libdvd, but the one we ship.
Thanks fritsch.

Rather than build from the official source, I decided to try the flatpack package of Kodi that is available.
This worked perfectly and I can now play iso over smb!

For my workstation the flatpack version is more than adequate.

Problem solved.
Perfect.