Kodi Community Forum

Full Version: Can’t edit/view advancedsettings
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I’m having issues since my kodi updated to kodi UWP leia 18.5.2.
I had to replace my router so apparently after kodi got auto updated with new IP address that was assigned on my network devices. So the library was somewhat messed up... and the lunch screen of kodi is crashing.
first I did reset static IP on windows and my cloud to their original IP. Also kodi is setup with MySQL on the same windows machine. I reading the right log and see it crashes after a lot of miss directions on music and video libraries.
How can I reset nighter the MySQL or the kodi setting regarding the library? I did not know that advanced settings xml is restricted. Is it because it’s part of kodi UWP?
I don't think we have a made a 18.5.2 version, just the v18.2 up to now, just to be precise.

In a proper router, you can set your own DHCP pool, and even fixate the IP address for each unique hardware MAC address (=each network device).
This way you can have your media/file server have its own dedicated IP address, all your network devices can remain on the default "auto dhcp" setting, and nothing will have to be changed in your Kodi setup.
Thread moved to uwp section
Well I did that since the new router is a “new” ISP’s invention to take ownership on administrative settings (I Might’ve not read the tiny words) they do provide mobile app with minimal control. so until I figure-out what to do with the new ISP’s router. I set up the IP on the adapter of my devices. Working fine yet the router did was smart to attached with to same hosts names...
so back to my main question: why the advance settings are forbidden to view nor edit? Should I just drop the exciting MySQL DB? how to be sure the kodi will rebuild the library right? Except kodi.log do I have another trace I could check to find why it’s taking so long to load? BTW kodi did starts after a long time I didn’t bare to wait to see how long.
When checking the recent activity under download in win10store I see this version Kodi 18.2.500.0
On kodi startup it’s written just 18.2
Read your first line again, you said you were running 18.5.2

What do you mean by 'the advance settings are forbidden to view nor edit?'
If you have an advancedsettings.xml file in userdata then you must have put it thereHuh
(2019-05-04, 16:50)trogggy Wrote: [ -> ]Read your first line again, you said you were running 18.5.2

What do you mean by 'the advance settings are forbidden to view nor edit?'
If you have an advancedsettings.xml file in userdata then you must have put it thereHuh

This is why I was too confused about not having rights to view or edit advancessetting.xml. I do have admin rights on it...
When kodi did load up after long time I managed to browse from kodi’s File menu to the advanced settings xml and I could view the content. The section for MySQL is now included two IPs... and I cannot edit it to keep the right one. so every time kodi is loading it’s holding on the fault IP trying to connect to each library version there is... it’s taking a lot of time and sometimes I got windows suggestions to close this app or wait for response...
I’m don’t know how to proceed to fix it. I thought of trying to scan all library at startup... what do you think I should do?
I'm lost.
Why are you trying to view advancedsettings.xml inside kodi?
It's a file you make in a text editor and place in kodi's userdata folder.
To edit it you go back to the folder, open it in your text editor (notepad++ for me) make changes and save.
The file is loaded when kodi starts (or on switching profiles).

So have you made an advancedsettings.xml file with a text editor?
If so can you go back to that file and open it in the same program?
That’s it. I can’t edit the file. I thought it’s something because it’s win store application. I’m also using notepad++ and when I try to open it I’m getting error “the file cannot be accessed by the system” or “can not open file”
Where is the file you're trying to open?
ie browse to it in explorer, right click and select properties, then copy and paste the location here.
It’s located in C:\Users\LIS517\AppData\Local\Packages\XBMCFoundation.Kodi_4n2hpmxwrvr6p\LocalCache\Roming\Kodi\userdata\

I did edit advancedsettings.xml on C:\Users\LIS517\AppData\Roaming\Kodi\user-data
But it hasn’t effected...
One moment... it’s working well now loading fast!

I guess that the cache was what I tried to update... I thought that the second location above was an old installation since it isn’t effective.
What I did after setting static IPs was to try exporting the library and re-scan on startup. Also I removed dead sources paths.

Thanks for your persist helping !!
Thread marked solved.
The reason I thought the “local” cached folder was the real one is because the kodi.log file on the same path under \kodi folder is the only one that updated during each run. It’s making sense as a cached file but on the “roaming” path the log file last updated date is somewhere in 2018... I cannot tell what was the event that stopped this log from being updated since then.