Kodi Community Forum

Full Version: Issues playing videos within Kodi 18.2
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi all, i am having a rather strange issue i hope i might be able to figure out with some help. 

I have a 6Tb NAS that i use to stream my ripped dvd's/blurays to various rooms around the house. I use Kodi as the front end/player for this.

In most rooms i run Kodi on an external Android box but in my living room i run it on a 4k Sony Bravia Android TV directly.

For the most part it works fine and i've had no issues for years. More recently though i have a strange issues with some videos.

What happens is i get a spinning circle in the bottom right corner saying working but in the left corner i see the title of the video and the play symbol along with the timer indicated how long has played and total time of the video. There is no Audio either. 

These videos play fine on all other kodi setups around the house, it is only on the Android tv that i have the issue.

I thought it may be something to do with streaming them over the network from my NAS so placed them on a USB drive and plugged it in but i get exactly the same issue. 

Using VLC on the PC to check the codec information i see all of the videos that i have issue with appear to be Xvid MPEG4 Video with MP3 Audio (click link for a screenshot).


Anyone have any tips on what the issue might be and how i might be able to get the files to work or than to try re-encoding them to a different format?