Kodi Community Forum

Full Version: Does not startup on windows 10
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I was trying to startup the applicaiton in windows 10, but only the splash screen is shown.
I wrote the command directly on the console and I am receiving an error about the locale that is set to NULL.
Here you have the output of the execution with the java command instead of javaw.

CompilerOracle: exclude ca/odell/glazedlists/impl/filter/TextMatchers.matches
CompilerOracle: exclude ca/odell/glazedlists/impl/filter/BoyerMooreCaseInsensitiveTextSearchStrategy.indexOf
2019-05-17 21:29:19,673 INFO  [main] org.tinymediamanager.TinyMediaManager:148 - =====================================================
2019-05-17 21:29:19,676 INFO  [main] org.tinymediamanager.TinyMediaManager:149 - === tinyMediaManager © 2012-2019 Manuel Laggner ===
2019-05-17 21:29:19,678 INFO  [main] org.tinymediamanager.TinyMediaManager:150 - =====================================================
2019-05-17 21:29:19,688 INFO  [main] org.tinymediamanager.TinyMediaManager:151 - tmm.version      : 2.9.17
2019-05-17 21:29:19,984 DEBUG [main] org.tinymediamanager.core.Settings:260 - Loading settings from data/config.xml
2019-05-17 21:29:20,382 INFO  [main] org.tinymediamanager.TinyMediaManager:157 - os.name          : Windows 10
2019-05-17 21:29:20,382 INFO  [main] org.tinymediamanager.TinyMediaManager:158 - os.version       : 10.0
2019-05-17 21:29:20,384 INFO  [main] org.tinymediamanager.TinyMediaManager:159 - os.arch          : amd64
2019-05-17 21:29:20,405 INFO  [main] org.tinymediamanager.TinyMediaManager:161 - java.version     : 1.8.0_211
2019-05-17 21:29:20,405 INFO  [main] org.tinymediamanager.TinyMediaManager:577 - current encoding : UTF-8 | UTF8 | UTF-8
Exception in thread "main" java.lang.NullPointerException: Can't set default locale to NULL
        at java.util.Locale.setDefault(Unknown Source)
        at java.util.Locale.setDefault(Unknown Source)
        at org.tinymediamanager.TinyMediaManager.main(TinyMediaManager.java:177)

Does anyone know how to solve it? (it happens to me in the versions  I tried: 2.9.17 and prerelease 3.0)
What language/country do you have set in your windows / where are you from?
(PN me if you do not want to expose public)

There seems some error in setting the UI language...
with recent release, does it now start?
(execute the updater directly to get the version - or download fresh)
(2019-05-22, 09:24)myron Wrote: [ -> ]with recent release, does it now start?
(execute the updater directly to get the version - or download fresh)
With the version 3.0.1 it is solved.

Thanks a lot.

PS: My language setup is Galician