Kodi Community Forum

Full Version: TheMovieDB movie scraper - PYTHON version
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12
I can confirm that there were no problems with the "old" scraper. For about 2-3 weeks there have been problems that English covers are loaded instead of German ones.
This is particularly noticeable when building a new database.
@Mister XY
@Allstar007

The issue has been fixed. Keep an eye out for an update to v1.3.1... https://github.com/xbmc/metadata.themovi...on/pull/60
(2020-11-03, 03:54)Karellen Wrote: [ -> ]
(2020-11-03, 03:14)Allstar007 Wrote: [ -> ]with the old TMDB scraper there were no problems.
Help me understand. If there were no problems with the old scraper, presumably you have your library already created. So did you suddenly come by 900 movies that you have to scrape? or is it fair to say that your 900 movies are all ok, and you only have a couple of new movies affected?
(2020-11-03, 03:14)Allstar007 Wrote: [ -> ]Among other things, this film Zodiac is not recognized by Kodi. 
https://www.themoviedb.org/movie/1949-zo...uage=de-DE
I had no problem scraping that movie. Provide a Debug Log and I might be able to see why you are having issues with it.

I had accidentally deleted the movies while cleaning up the database, then I tried to add everything again. And then I noticed that the new TMDB scraper was selected. How do I create the log file?
(2020-11-03, 08:35)Karellen Wrote: [ -> ]@Mister XY
@Allstar007

The issue has been fixed. Keep an eye out for an update to v1.3.1... https://github.com/xbmc/metadata.themovi...on/pull/60

Under Addons the 1.3.1 is not shown, where can I find it?
Yes, the scraper runs also very good. I can also used it again.
(2020-11-03, 15:54)Allstar007 Wrote: [ -> ]Under Addons the 1.3.1 is not shown, where can I find it?
You will need to wait until it is checked and submitted. It may take another day. When you have 1.3.1 installed, then you know you have the fix.

(2020-11-03, 19:48)Mister XY Wrote: [ -> ]OK, i see, if the scraper not found a german poster or a english poster, he didi not load any poster.
Same for you.
I have the new scraper code installed.
(2020-11-03, 19:48)Mister XY Wrote: [ -> ]OK, i see, if the scraper not found a german poster or a english poster, he didi not load any poster.
https://www.themoviedb.org/movie/28610-p...n-lillifee
https://www.themoviedb.org/movie/52611-el-rat-n-p-rez-2
https://www.themoviedb.org/movie/36617-p...tus-sue-os
I don't think there is anything we can do about that. It checks for posters in your selected language, then checks for English posters, then checks for primary poster.

The first two are not available, and there is no Primary poster set for the show, so you end up with nothing.

@rmrector
I also have issues with posters and languages, but a different one it seems. I just switched to this scraper from the old TheMovieDb scraper, and I'm using the latest released version 1.3.1.

For example, for this movie: https://www.themoviedb.org/movie/107287-ana-y-los-lobos it does not find a poster, instead of the poster it shows some other artwork. The movie file name is "Ana y los lobos (1973) [720p].mkv"

My scraper is set to prefer English* . Same thing with some other movies that are not in English (some of them have English file names, some have non-English). I previously had posters for all of these (including Ana y los lobos) with the old scraper, and I can confirm at least for Ana y los lobos, the old scraper gets the poster.

Some other examples where poster is not provided: But it's not for all non-English films, for most there are posters.

* side note: ideally I would like to say in settings: "Keep original title for <Spanish, Estonian> (e.g. selecting languages I speak), otherwise show <English> title".
[deleted] Had some issues with not matched movies, but it was fully my problem because I had the wrong years on the movie files. It's good that the missed matches appear in Event Log!
Hmm... Some of the missing poster issues seem to be related to this: https://community.firecore.com/t/tmdb-is...ters/19651 (apparently massive deletion of movie posters by TMDb bot).
(2020-11-13, 21:05)T4ffer Wrote: [ -> ]Hmm... Some of the missing poster issues seem to be related to this: https://community.firecore.com/t/tmdb-is...ters/19651 (apparently massive deletion of movie posters by TMDb bot).
Yes, we have a thread on it as well... https://forum.kodi.tv/showthread.php?tid=353489
Hi!  Using this with Matrix alpha 3.  Is there anyway to get the scraper to download more poster options from the fanart.tv website?
I recently gave this scraper a try and didn't notice the option to create tags from keywords. As a result, my tag list got completely bloated with a ton of garbage tags which I then had to remove by hand, which was horrible. I absolutely believe this option should be disabled by default and if the user decides to enable it, he should be given a warning that it could grow/bloat the tag list very quickly.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12