Kodi Community Forum

Full Version: Philips Hue Service & Ambilight
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13
(2019-10-14, 20:38)Snapcase Wrote: [ -> ]Hi

Yeah, try lowering the capture size in the ambilight section. Just under it it will also tell you how long it takes to calculate one image in milliseconds. 500 is half a second, 1000 is one second. That should give you an idea how long it takes to calculate the colours.

Ok i will try thabk you!!
Hi snapcase,
Its strange...this evening seems that is not working properly...lights doesnt change, also i can see hue disconnection pop up very often...
No way...it remains white...no change color...how can i export log to show you?
Hi,

The instructions to gather Kodi logs are here: Log_file/Easy (wiki)

If you're getting the disconnection message maybe you have a network problem, it's pretty much the only time that would happen. If it has trouble connecting to your bridge it's not surprising that it's unreliable. If it's an intermittent problem it's possible you don't notice it in normal use but since this script sends traffic very often to the bridge while you're watching something it's going to be more sensitive to network problems than if you're just turning on the lights once.
(2019-10-14, 16:12)Snapcase Wrote: [ -> ]Actually could you also visit this address from your network and see if your Hue bridge shows up? Aside from having the same IP, it's the fastest method but needs your bridge to talk to Hue's servers and not be blocked.
It pops right up, listing my IP address. I’ll work on getting some logs posted.
Hi snapcase...i made some test and here what i can tell you for sure.
I have both pi3 and pi4.
I installed the addon at this link
https://hotstickybun.com/hardware/how-to...with-kodi/
On pi3 and its pretty perfect! Whitout any settings, light change as i have a real philips tv.
If i jnstalled that addon on pi4, the light stuck on green blue and red, and there is no way to make it work.
So i installed your plugin that seems work, but i have disconnection issue and color changing doesnt seems realistic as the previous addos...so what im asking you is...is possible for you try to copy the settings from the first plugin and make it working in pi4? It would be amazing...thanks for all!!
I'm familiar with the old add-on but had to rewrite it. That said there's some options like saturation and interval that you can adjust in the settings to change the effect. Play around with the settings and see what you like.

It should work the same on RPi3 or 4, what's more important is the version of Kodi you're using. Are you sure it's the same on both of them?
Yes its 18.4 leia.
But if you try that script i posted, you can see that works in a perfect way
No change to make, no disconnection. And pretty realistic effect
Trust me...i just dont know why it stucked in those 3 color on pi4.
I read that the older script is not compatible with some kind of hardware acceleration...maybe on pi4 that acceleration is turned on by default and there is no way to disable it (only mma acceleration is available in the options settings)
I used the older script for years, I know how it works. I can't help you get it working, I rewrote it for a reason. I believe there's another thread for it.

If you need help with getting my script working, please provide logs and a better description of the issue.
Would we be able to have a "Only trigger lights that are on when the movie starts" option please?
Hi @c3pu 

Are you referring to ambilight or the scenes? For ambilight you can turn off "force on". For the scenes, we're limited by how the scenes work. With scenes you can set lights to either on or off, but I can't find a  "previous setting" option or anything like that.
(2019-10-20, 19:53)Snapcase Wrote: [ -> ]Hi @c3pu 

Are you referring to ambilight or the scenes? For ambilight you can turn off "force on". For the scenes, we're limited by how the scenes work. With scenes you can set lights to either on or off, but I can't find a  "previous setting" option or anything like that.

Yes I was referring to the scenes - I basically use it to dim the lights when playback starts, and turn them back to full brightness when finished. The schedule/sunset options go some way to solving my issue, but it's kinda annoying when it turns the lights on when I want them off etc.

There's an option for "Only trigger lights that are on when the movie starts in room 1" in the HelloHue plugin for Plex which does much the same job as the Hue Service addon, which is what led me to ask!
Yeah, I had looked into doing it without the scenes but it turned out that using the scenes allowed it to be much more flexible than having preset behaviours.

I know what you mean though. Even with the schedule when it's a rainy day and darker than usual or something, it doesn't necessarily behave like I want that particular day. Eventually I want to look into some way to have shortcuts or keyboard commands to allow you to enable, disable, force on, and force off easily when watching a video. I haven't found the best way to do it yet but hopefully I will eventually!
Hmmm... Regarding the "only triggering lights that are on" question, would it be possible to achieve this by creating a variable and set it to 1 when lights are on, 0 when off, and then checking against the variable?

I'm no developer so please forgive me if it's a stupid idea/doesn't work like that!
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13