Kodi Community Forum

Full Version: Font Issue - Menu Name Not Displaying
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi all. 

I am fairly new to Kodi, having moved across from MediaPortal a while back (although I am still using the MediaPortal back-end). 

I am using LibreELEC X86 version of Kodi but am having some issues with the menu screen in Confluence. Essentially, I always get blank areas where the menu titles should be on the home screen, which makes system navigation really difficult. See screenshot below:

Image

If I then go the the "System -> Settings -> Interface -> Skin -> Fonts" I get the following screen, with a number of font options missing (see below). If I select any option, even a blank one, the menu titles then display correctly and the font list repairs itself, now giving "Skin defailt", "Larger font size", "Skin default with no caps" and "Arial based".

Image

My logs are posted here: 

@Karellen-Logs removed

Can anyone give me a steer as to how to fix this. It happens with all system users, and not just one, so is a global issue with the installation.

Thanks

Robbo
(2019-07-08, 19:56)robbo1001 Wrote: [ -> ]It happens with all system users

Do I understand it correctly. Are you using multiple profiles? If so, that's a know issue while using profiles and we have a workaround for that:

https://kodi.wiki/view/Profiles#Missing_...g_profiles
(2019-07-08, 23:05)DaVu Wrote: [ -> ]Do I understand it correctly. Are you using multiple profiles? If so, that's a know issue while using profiles and we have a workaround for that:

Nice one. Thanks (and sorry for the slow reply). 

I have created that file and put it in one of the profile directories. Interestingly although I have two profiles ("Parents" and "Kids"), there was only on user profile available ( the "Kids" profile) along with another folder called CDM. 

I have put the autoexec.py file in the kids profile folder and the Kids profile seems to display things correctly (so far). The Parents profile still shows without any menu titles though.

Any idea why I don't have a second profile directory showing? The /userdata/profiles.xml lists them both, but no directory. 

Thanks

Robbo1001
Ah, I put a copy of autoexec.py in the root of userdata (rather than in a profile) and this might have worked - maybe more luck than judgement?
Quote:Other: I don't know how to edit this post. The hastebin post has inadvertently brought across a password and I would like to delete the link to the hastebin links. Please can you edit the post for me to remove these links.

@robbo1001
I have removed them for you.
Thanks
@robbo1001 

the master profile (the intial profile which exists by default) is always the '.kodi/userdata' folder. Every profile which will be created additionally will have it's own userdata under '.kodi/userdata/profiles/<profilename>'

Even if you rename the master profile to something else it will still be the default/inital/first profile and there doesn't exist an extra profilname-folder for that.

hope it makes sense to you and glad this solved your problem.