Kodi Community Forum

Full Version: Kodi Recordings Playback Issues
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi All

This is a bit frustrating.  I am running Kodi Version 18.3. (20190619-89472b7d69) on both a Raspberry Pi on Librelec 9.0 and an iMac running macOS High Sierra version 10.13.6 (17G7024).  The machines access a VBox that distributes live TV over my network that is mainly (good quality) wifi. I can watch live TV without a problem.

I recorded a programme through the Kodi interface and it recorded correctly (Cricket on 5 HD) and when I tried to play it back over wifi on the RPi it did not want to start unless I paused it then restarted it.  Once running it plays for about a minute then stops on a frozen frame.  Eventually it restarts first with a buffer icon that reads 1 and nothing else and then it gives me a message that says “Source too slow.  Read rate is too low for continuous playback.”

So I came to the main machine (the iMac) which has a USB direct connection to the drive on which all my media is stored (including my VBox recordings) on the assumption that the hardwired connection would resolve the problem but it did not.  Something is not right.  If, as soon as the playback stops, I hit pause and then play, it begins to play again immediately but only for a few seconds before it stops again so I think this may be some form of buffering problem (an amateur guess!).

I do not think the HD nature of the recording is the issue as even non HD recordings do that same and it is not a network issue as it does the same with the hardwired connection.  So I have to reluctantly assume it is the Kodi software or the PVR add-on from Sam Stenwall that is causing the problem.  The message that comes up is from the PVR add-on and not from Kodi per se.

When I play the file direct from the folder on my media drive on the iMac using Quicktime, the playback is continuous (no audio as its is HD but that is another [apple] problem outside the scope of this one).  Consequently it is not my equipment causing the delay but a software glitch somewhere.

As Ares Wizard is no longer available I have installed EZ Maintenance, cleared cache etc, and set an optimal buffering size and this appears to have considerably improved the situation but not overcome it.  It now runs for longer before pausing but is paused for longer with the buffer icon getting (very slowly) to 10 before starting!  It appears to be downloading or transferring the file content from my drive to Kodi before playing. Watching the timeline on the bottom of the screen I can see the progress as it plays and also the buffering of the file ready to be played.  It is much better until it eventually catches up with the transferring file (8 minutes of play) it then starts the buffering process again with the icon running from 1 to 10 then playing (about 5 minutes).  It should be doing this buffering continuously in the background to keep the playing continuous but it is not.

Is anyone else experiencing this?  Is there a known fix?  Or do I need to post some error logs to see if someone can help me?


FYI... Usage of banned add-ons/repositories,wizards or 'builds' (or tools linked directly thereto) will get you no support here as per Kodi's forum rules (wiki).
(2019-07-27, 01:47)Klojum Wrote: [ -> ]FYI... Usage of banned add-ons/repositories,wizards or 'builds' (or tools linked directly thereto) will get you no support here as per Kodi's forum rules (wiki).

Thank you. I did not realise the EZ Maintenance was not an approved item. As I said, I have only used it to test whether the cache clearing and optimum buffering size would work but it does not. I will remove it and go back to my vanilla installation. BTW, it was only installed on the Mac, not the RPi so someone should still be willing to help me (I hope!).

To be clear, I do not use third party addons on my system and only tried this as a measure of desperation.

How do I adjust the buffer size through the vanilla installation?

What other acceptable steps can I take to resolve this issue?

(2019-07-27, 09:19)GeoffatMM Wrote: [ -> ]How do I adjust the buffer size through the vanilla installation?
What other acceptable steps can I take to resolve this issue?

Thanks Black Eagle.

I have read through the wiki and inserted this to my iMac


and this to my RPi


It has changed but not really improved the situation.

For some reason, on both machines, no matter what recording I start, Kodi plays exactly 4 seconds and then stops.  No matter how long I leave it it does not advance.  I have to manually pause and restart it then it works again.  However it is running for only a short time before it once more paused and (I assume) starts buffering with the buffering icon very slowly rising to ?? on the RPi before it starts again.  While it is buffering I can see the buffering file data increasing (the grey section) on the video timeline.  I can manually restart the recording by pausing it (even though it is doing nothing) then restarting it.  The ?? in the sentence above is because after twenty minutes I got fed up and restarted it manually but I suspect if I had left it, it would keep going until it loaded the whole file than played which is not of any value to me.  I would just like it to play immediately!

I let it run up to 31 before restarting and the grey section of the time line looked to be about 25% of the programme or about the equivalent of the amount of time it was buffering.  i.e. it is simply buffering in real time and not playing.  I suspect I need to adjust the readfactor but could you confirm?  Why does it not play while it continues to buffer in the background?  Is there an advance setting I can adjust to make this happen (I have read through the Wiki but could not find anything that looked like it would control that aspect but I am not a video expert).

Eventually paused it and took the dogs out.  When I got back the grey line was complete and I was able to watch the programme without interruption.  How do I get this to work quicker?  Would any log files help?

BTW, just so you know, I am overcoming the issue by reprocessing all my HD recordings through Handbrake so I can then view them with audio via quicktime.  No idea why quicktime does not output the audio from the original file but it does not.  So to record and watch a programme, I have to plan it, record it, access the iMac and process the recording file through Handbrake (takes as long as the video runs usually) and only then can I watch it in quicktime either on the iMac or over the wifi on another Mac.  Phew!  Please help me!

Hello, can anyone help me with this please?

Bumpity bump bump?
Can you try the latest addon builds from this github issue And see if there is a difference?

From this version the video will be played via the same mechanism as the stream is played so there should not be a difference in playback.
(2019-10-20, 22:36)phunkyfish Wrote: [ -> ]From this version the video will be played via the same mechanism as the stream is played so there should not be a difference in playback.


As per my other post I can confirm it is now working better on my iMac.  I will try the RPi tomorrow and let you know if that is also cured.  I see I can now update the add-on directly as it has been released so will do that and then try.

Fingers crossed.
@GeoffatMM does recording playback now also work on your RPi?
Sorry, busy renovating a building so have not had time yet to try.  I will post when it is checked.
OK, so a few things to report.

Starting with the RPi.  As it is Librelec the versioning of the PVR is different so it is running version which is the latest version.  I have turned auto updates off for now (see later).  The recordings are now playing better and I suspect it was a network issue on this machine.  However, the timeline is there for recordings but not for TV.  I assume it will have to wait until an update is available for the Librelec version of Kodi before it gets sorted.

I went to watch the TV last night and once again got the message that my PVR was incompatible with my 18.3 Leia.  It had been disabled and I cannot now enable it.  I checked the network settings and all was fine then I noticed that the version had changed automatically from 4.5.0 to 5.3.0.  I assume this is why it was incompatible.  I then opened my 19.0 alpha and it worked OK so I have had to move to that version for now.

I suspect you already know this as today, although it is running 5.3.0 a manual update request shows the latest version (for 18.3) as 4.7.0 and I am now going to downgrade to that to see if it works.  

Yes it does and it has also fixed another issue I was going to raise.  I have my PVR set to 8 days forward and 1 day back but recently the 1 day back had not been working.  It is on this version of 4.7.0.  (However it is not working on the version on the RPi).

Shutting 18.3 and opening 19.0 this morning, 19.0 seems to have auto updated to 4.7.0 now!   Wierd.  It says this is incompatible with this version.  I have now turned off the auto update on this machine and tried a manual and it is again offering 5.5.0.  Adding 5.5.0 to the 19.0 alpha makes it work again.  However, the 1 day back function does not seem to be working on this arrangement (5.5.0 + 19.0).

Back to 18.3.  Incompatible.  So the updating of the PVR must be cached in the preferences for what ever version of Kodi is used as it had moved back to 5.5.0.  Changing it back to 4.7.0 resolved it again.  Currently, to check 19.0 alpha on a machine running 18.3 I will have to adjust the PVR software each time.

So the 1 day back is now only working on the 18.3 + 4.7.0 version of my machines.

I am not a coder but am more than happy to help by running tests such as these if it is useful in order to contribute to software that I am dependant on in my house!  If I wanted to help, how do I go about it?  I am retired but busy (rebuilding the barn into a house) but am happy to find time to help if it is wanted.

Hope all this is useful.

Yes, you will need to wait for the next version of libreElec before you get the new update for the RPi. LibreElec ships with the addons built in so updates are not possible.

On the other issue are you running both kodi 18 and 19 on the one machine?

If so this will be causing your versioning problems. You need to completely uninstall any addons that are the wrong version and reinstall them.

This is because kodi does not support multiple versions running on one host so you have v18 picking up v19 state and vice versa.
Pages: 1 2