Kodi Community Forum

Full Version: Unable to setup IAGL with Retroarch
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm using Kodi 18.3 on Android on China TV Box (Amlogic s912-Android Nougat based). I was trying to setup IAGL to use Retroarch for NES using Nestopia UE core (I already have BIOS and XML in system folder). 

I got the configuration done as per Wiki, however I'm unable to launch games through RetroArch. Whenever I click on Launch game, screen goes blank for less than a second and I return back to list in Kodi. I tried the workarounds mentioned in Wiki like update command for specific list to use Retroarch Nestopia Core, as well as trying to launch the game in temp_IAGL folder directly through Retroarch which was successful.

Below is link to my kodi.log file. First i tried without updating command (Super Mario Bros 3), secondly I tried after setting the core (River City Ransom). 

Can anybody point me, what I'm doing wrong here. I've spent more than a day trying to figure it out.
(2019-07-30, 19:35)abe786 Wrote: [ -> ] 

BTW I tried to run the command generated in log file when nestopia core was set via terminal emulator/system/bin/am start --user 0 -a android.intent.action.MAIN -c android.intent.category.LAUNCHER -n com.retroarch/.browser.retroactivity.RetroActivityFuture --es "LIBRETRO" "/data/data/com.retroarch/cores/nestopia_libretro_android.so" --es "CONFIGFILE" "sdcard/Android/data/com.retroarch/files/retroarch.cfg" --es "ROM" "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/userdata/addon_data/plugin.program.iagl/temp_iagl/River City Ransom (USA).nes" --es "IME" com.android.inputmethod.latin/.LatinIME

It launched retroarch and the game just fine..