Kodi Community Forum

Full Version: Xonfluence (Leia v18.x & Matrix v19.x) (Krypton 17 = deprecated)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Is xonfluence able to use library nodes created with library nodes editor as main menu entries?

I don't want to use smart playlists or favorites.

I've created 2 nodes (adult, kids) with all subnodes the movie node has (actors, genre, etc).

How would I set my own node as main menu entry?
Update: This was solved by Hitcher so thanks to him, solution at the bottom if anyone wants to do the same.

Hi,

Can someone please tell me where and what to edit in the xml to change the (season - episode) to uppercase e.g. from s01e01 to S01E01.

I think it's under IncludesHomeWidget.xml but I have no idea.

Image

Thanks in advance.

Gaz

Solution:

Amend code lines 3446-3639 in IncludesHomeWidget.xml to include an [UPPERCASE][/UPPERCASE] wrapper around $INFO[Window(Home).Property(RecentEpisode.#.EpisodeNo)]

I don't know if Helly can/will make this an option or by default as I suspect some people prefer it lowercase but if he can that would be much appreciated as always.

Hastebin Link - https://hastebin.com/elepaxehec.xml

Code - 
Removed by MOD (use link posted above for content)
Please do not post code or log directly onto this site. It wreaks havoc with the search functions of the site.
Thanks
Does Openinfo not work with this skin?
Everytime I long press on a film or tv prog to add it to my Library via Openinfo I get a message
that it cannot be found.
I've noticed that some live TV addons don't enable the Xonfluence Media Info 1, 2 & 3 views that display EPG program details. If I switch to the default Estuary skin, program details are displayed in the left panel by the default in 'Viewtype: WideList' for all addons. Have I missed something in Xoncfluence settings or searching this thread that address this?
Hi there, wondering if anyone can help me. 

I've been using the <setting id="SkinHelper.AutoCloseVideoOSD" type="string">5</setting> from 'skin helper service' to autohide the video OSD (on screen controls, not just the seekbar) after 5 seconds during playback (using remote or keyboard) and it's worked great for a couple of years. 
However, recently I added touchscreen and gamepad keymaps for playback control and for whatever reason, having any number value in the above code causes the video osd to close within a half second of being opened (instead of the usual 5 seconds I specified). 
What's really odd is, it still works fine if I use a keyboard or remote, but the moment I use gamepad or touchscreen, it closes immediately. This behavior happens on my PC, Nvidia Shield AND mobile phone, it also happens on both Krypton and Leia.

Anyone know what could be causing this? Or is there a way to modify the videoOSD to autohide during playback without using skinhelper service?

Any help would be greatly appreciated.
HI , I have Xonfluence skin v 4.0.10 installed using Kodi v 18.5 , Is the Xonfluence skin compable using Artist slideshow v3.1.0 , Having proplems getting Artist Slideshow to work Thanks..
Recently, this "Xonfluence" skin decided to auto-update itself... upon which I lost EVERYTHING I had worked so hard to configure for weeks & months! Very discouraging, but fortunately, I had an older backup of the SETTINGS.XML file from the Xonfluence folder in USERDATA. But just to add to my grief, this version of Xonfluence (4.0.10, on Leia 18.4), is NOT ALLOWING ME TO OVERRIDE THE DEFAULT SETTINGS.XML FILE!! I tried deleting its default SETTINGS.XML, then copying my backup SETTINGS.XML. But no matter what i do, whether I exit KODI properly, or switch skins then revert back to Xonfluence, or save the skin settings in the skin settings panel, it somehow does away with my own SETTINGS.XML, and goes back to its default! If I manually change a setting, then it will retain that setting (reflected in the SETTINGS.XML in the USERDATA folder). But as soon as I change any setting after copying over my backup, it will revert to a copy of its default SETTINGS.XML.

I can't even install a previous version of Xonfluence, because that gives error. What is going on here??
Can i add time remaining to the OSD? I found this https://kodi.wiki/view/HOW-TO:Add_Time_R...Confluence to add it to the confluence skin, but i can't find the xml files in the xonfluence subfolder.
(2020-02-29, 10:44)bunter fisch Wrote: [ -> ]Can i add time remaining to the OSD? I found this https://kodi.wiki/view/HOW-TO:Add_Time_R...Confluence to add it to the confluence skin, but i can't find the xml files in the xonfluence subfolder.
yet it works.
edit the skin.xonfluence\xml\VideoFullScreen.xml file
(2020-02-29, 10:44)bunter fisch Wrote: [ -> ]Can i add time remaining to the OSD? I found this https://kodi.wiki/view/HOW-TO:Add_Time_R...Confluence to add it to the confluence skin, but i can't find the xml files in the xonfluence subfolder.

Here's my already modified VideoFullScreen.xml. I've done it a bit differently than the confluence modification. Rename it and give it a try. Diff it with the original to get the differences so you can migrate it to the next release. I wish they would put this or something similar in the skin permanently. It's such a pain to have to think it ends at 12:22 which is in 37 minutes when all I need is the 37 minutes.

https://hastebin.com/amasacehac.xml
Your file don't work in my system but i could realize that manually. This will be overwriten with every update of the skin plugin? I had problems with skin updates before so i have disable updates a few month ago.
(2020-03-01, 14:17)bunter fisch Wrote: [ -> ]Your file don't work in my system but i could realize that manually. This will be overwriten with every update of the skin plugin? I had problems with skin updates before so i have disable updates a few month ago.

Yes, every time the skin is updated all the skin files will be overwritten and the changes will need to be propagated to the new version.

You have to restart kodi after placing the renamed file. Maybe that's why it didn't work.
Has anyone found a way to update Xonfluence to have better organized search results?  I really miss regular the nice results the old Confluence had under the previous search engine.  Xonfluence has a list and even the pictures for the results are somehow "blocked" on the right by a blackout cover (you can just see that they are underneath it), let alone neatly organized with their thumbnails like the old results had.  I need to update for no visible messages when running Cinemavision as well (that I know how to fix myself as I had to do it for Confluence every new version as it was too much work for the author to add one or two lines of code that never change to accommodate that add-on).
Wondering if anyone has any suggestions...

I compiled my own build of Kodi (18.6 Leia) for Windows x64, and changed the default skin to Xonfluence, and included various addon's into the source.
The problem i have is that when it built the project, for some reason it skipped the 'media' folder for the skin - i discovered this by adding the advancedsettings.xml to enable debugging when running;

I then confirmed this by going into the folder 'Program files\kodi\addons\skin.xonfluence... and sure enough no media folder;
But if i go back to my source it was compiled from, the media folder exists within the xonfluence skin folder.

Obviously i added addons/skin.xonfluence/* into the \cmake\installdata\common\addons.txt
I added <addon>skin.xonfluence</addon> into the \system\addon-manifest.xml
And i changed \system\settings\settings.xml to have this...

<setting id="lookandfeel.skin" type="addon" label="166" help="36103">
          <level>0</level>
          <default>skin.xonfluence</default>
          <constraints>
            <addontype>xbmc.gui.skin</addontype>
          </constraints>
          <control type="button" format="addon">
            <show more="true" details="true">installed</show>
          </control>
        </setting>

Did i need to add more into the settings.xml, or was it possibly unhappy as the media folder has been prebuilt with texture packer?
If it was due to the folder being prebuilt - is it possible to get the folder which hasn't been compiled with texture packer - as it doesn't seem to exist in the Git repo?
(2020-03-08, 08:36)BlissSol Wrote: [ -> ]I Wondering if anyone has any suggestions...

I compiled my own build of Kodi (18.6 Leia) for Windows x64, and changed the default skin to Xonfluence, and included various addon's into the source.
The problem i have is that when it built the project, for some reason it skipped the 'media' folder for the skin - i discovered this by adding the advancedsettings.xml to enable debugging when running;

I then confirmed this by going into the folder 'Program files\kodi\addons\skin.xonfluence... and sure enough no media folder;
But if i go back to my source it was compiled from, the media folder exists within the xonfluence skin folder.

Obviously i added addons/skin.xonfluence/* into the \cmake\installdata\common\addons.txt
I added <addon>skin.xonfluence</addon> into the \system\addon-manifest.xml
And i changed \system\settings\settings.xml to have this...

<setting id="lookandfeel.skin" type="addon" label="166" help="36103">
          <level>0</level>
          <default>skin.xonfluence</default>
          <constraints>
            <addontype>xbmc.gui.skin</addontype>
          </constraints>
          <control type="button" format="addon">
            <show more="true" details="true">installed</show>
          </control>
        </setting>

Did i need to add more into the settings.xml, or was it possibly unhappy as the media folder has been prebuilt with texture packer?
If it was due to the folder being prebuilt - is it possible to get the folder which hasn't been compiled with texture packer - as it doesn't seem to exist in the Git repo?
I solved my own issue;
By unpacking the XBT files in the media folder to the base images using the Kodi Texture Tool, I was able to successfully build Kodi & have xonfluence working properly as the default skin.
Interestingly enough, the build process didn't repack all the images back into an xbt file - and my kodi runs without any images packed (thus no xbt files).

It may be that the build process will only pack\build images for the 2 usual default skins (thus it didn't pack\build an xbt file for xonfluence) - but i have bothered to dig that far into it.

Here's the Kodi Texture Tool, for unpacking or repacking XBT files;
https://forum.kodi.tv/showthread.php?tid=201883