Kodi Community Forum

Full Version: Xonfluence (Leia v18.x & Matrix v19.x) (Krypton 17 = deprecated)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2016-03-23, 18:06)trogggy Wrote: [ -> ]
(2016-03-23, 17:58)gshodg Wrote: [ -> ]I can't get my skin settings to save.

For example I change Home Menu > Menu Items 2 (Movies) > Widget set - to NONE (and did same for Menu Item 3 TV SHOWS).

But when I reboot, the settings are gone and "Recent Movies" and "Recent TV Shows" widgets are back.
If you can do a debug log it might show up the problem - at a wild guess kodi's not shutting down properly.
What happens if you make your changes, switch to confluence (or any other skin), switch back to xconfluence and then re-boot. Do you still lose your changes?

I've been getting frequent crashing with OE 6.95.1 /XOnfluence - when browsing movie lists, tv show lists, starting movie or TV shows.

After a day of frustration I did a HARD RESET of all OE settings, and started rebuilding....I Installed Xonfluence skin, did some skin settings, Imported my TV Shows (held on NAS).

I was browsing TV Shows List and watching the episodes get populated with SD or HD labels and it crashed. I then turned on the debug long, and browsed around the TV shows episodes listing a bit, tried to play a TV show and it crashed (it completely freezes). I don't know if all this is OpenELEC or Xonfluence...here's the log:

http://sprunge.us/iTAT

The last line of that log seems to be skin related:
Quote:20:02:57 T:139625477359360 DEBUG: Skin Widgets: Total time needed to request random queries: 0:00:00.143294

and other, crashed when trying play a TV show...

http://sprunge.us/ZAMi

Then I imported my movies. Did a reboot. Turned on logging, did another reboot to get the start-up data, then did a couple of skin settings - position of movie menu, then went to view movies in list view. Only one had the 'HD" icon next to it yet, and I click on one to play it, and again it crashed (froze completely). Here's this log...

http://sprunge.us/aWdL
(2016-03-18, 05:02)lobsta Wrote: [ -> ]Is there a way to make the settings.xml file group setting id's? I like to edit it myself but with all the settings mixed up randomly it makes it difficult. Here's a rough example.

Instead of this ....
<setting id="UserSubOne.5.Path" type="string"></setting>
<setting id="UserSubThree.5.Path" type="string"></setting>
<setting id="UserSubThree.3.Label" type="string"></setting>
<setting id="UserSubThree.8.Path" type="string"></setting>
<setting id="UserSubOne.9.Label" type="string"></setting>
<setting id="UserSubOne.5.Label" type="string"></setting>
<setting id="UserSubThree.8.Label" type="string"></setting>
<setting id="UserSubThree.2.Label" type="string"></setting>
<setting id="UserSubThree.1.Label" type="string"></setting>


This would be much better.
<setting id="UserSubOne.9.Label" type="string"></setting>
<setting id="UserSubOne.9.Path" type="string"></setting>
<setting id="UserSubThree.1.Label" type="string"></setting>
<setting id="UserSubThree.1.Path" type="string"></setting>
<setting id="UserSubThree.2.Label" type="string"></setting>
<setting id="UserSubThree.2.Path" type="string"></setting>
<setting id="UserSubThree.3.Label" type="string"></setting>
<setting id="UserSubThree.3.Path" type="string"></setting>
<setting id="UserSubThree.4.Label" type="string"></setting>
<setting id="UserSubThree.4.Path" type="string"></setting>

I'm new here, but I know XML, Skins, and Wizards.

Anyways, I wrote a XSLT to resort this in the proper order.

<xslConfusedtylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0">
<xsl:output method="xml" version="1.0" encoding="UTF-8" indent="no" omit-xml-declaration="yes"/>
<xslConfusedtrip-space elements="*"/>
<xsl:template match="setting">
<xsl:copy-of select="."/>
</xsl:template>
<!--#1 -->
<xsl:template match="skin">
<assembly>
<xsl:apply-templates select="setting">
<xslConfusedort select="@id" order="ascending" data-type="text"/>
</xsl:apply-templates>
</assembly>
</xsl:template>
</xslConfusedtylesheet>

Download a free XSLT editor to run it on your source file. (settings.xml), let me know your results, I do not have a settings.xml to test it.

-Lord
Thanks. I didn't try it however I have found it's only on a Win10 system running Jarvis and Xonfluence that the xml gets garbled like that. I have since switched the box over to Xubuntu and the xml is properly organized now. Maybe some kind of Win10 issue I dunno but I like Linux better anyways so problem solved for me at least.
Hi,

Noobie looking for help/assistance

Using Xonfluence with Jarvis. I've created shortcuts to addon video nodes, but the nodes don't seem to refresh. I.e. when selecting a shortcut it takes me to the correct node, but the directory list will be 2-3 days old. If I select directory up level (..) Then select the directory again the list is refreshed.

Any help appreciated, I've even tried a clean install, with no success



Thanks
(2016-01-10, 09:35)Helly1206 Wrote: [ -> ]
(2016-01-10, 02:08)wongnog Wrote: [ -> ]I noticed that when I pause a movie, sometimes on the left there is a movie poster that covers up the fanart banner. How can I fix this?
Image

You first issue is fixed from version 3.2.0 on

Hi Helly,

Is this something I can fix myself via Telnet/SSH into Kodi? I'm still on Isengard v15 so on Xonfluence v3.1.6, due to a bug with video thumbnails I encounter on Jarvis v16. Thanks!
(2016-03-25, 19:12)wongnog Wrote: [ -> ]
(2016-01-10, 09:35)Helly1206 Wrote: [ -> ]
(2016-01-10, 02:08)wongnog Wrote: [ -> ]I noticed that when I pause a movie, sometimes on the left there is a movie poster that covers up the fanart banner. How can I fix this?
Image

You first issue is fixed from version 3.2.0 on

Hi Helly,

Is this something I can fix myself via Telnet/SSH into Kodi? I'm still on Isengard v15 so on Xonfluence v3.1.6, due to a bug with video thumbnails I encounter on Jarvis v16. Thanks!

You can try this one on your own risk (make a backup first). open IncludesOnScreenDisplay.xml,

Exchange lines 94-125 by:
Code:
<control type="image" id="1">
                <description>Movie cover image</description>
                <left>20</left>
                <top>350r</top>
                <width>300</width>
                <height>330</height>
                <texture fallback="DefaultVideoCover.png">$INFO[Player.Art(thumb)]</texture>
                <aspectratio aligny="bottom">keep</aspectratio>
                <bordertexture border="8">ThumbShadow.png</bordertexture>
                <bordersize>8</bordersize>
                <visible>!Skin.HasSetting(EnableDVDCases)</visible>
                <visible>[Skin.HasSetting(DisableClearArt) | IsEmpty(Player.Art(clearart))] + [IsEmpty(Player.Art(clearlogo)) | Skin.HasSetting(DisableLogoArt)]</visible>
            </control>
            <control type="image" id="1">
                <left>30</left>
                <top>350r</top>
                <width>255</width>
                <height>345</height>
                <aspectratio>stretch</aspectratio>
                <texture>$VAR[VideoPlayerCase,ClearCase/,.png]</texture>
                <visible>!Player.IsInternetStream + [Skin.HasSetting(DisableClearArt) | IsEmpty(Player.Art(clearart))] + [IsEmpty(Player.Art(clearlogo)) | Skin.HasSetting(DisableLogoArt) + IsEmpty(Player.Art(thumb))]</visible>
                <visible>Skin.HasSetting(EnableDVDCases)</visible>
            </control>
            <control type="image" id="1">
                <description>clearart image</description>
                <left>10</left>
                <top>235r</top>
                <width>300</width>
                <height>230</height>
                <texture>$VAR[StreamingVideoIcon]</texture>
                <aspectratio aligny="bottom">keep</aspectratio>
                <visible>Player.IsInternetStream + [Skin.HasSetting(DisableClearArt) | IsEmpty(Player.Art(clearart))] + [IsEmpty(Player.Art(clearlogo)) | Skin.HasSetting(DisableLogoArt) + IsEmpty(Player.Art(poster)) + IsEmpty(Player.Art(thumb))]</visible>
            </control>

Helly.
I know, still on a break but just some minor updates.

I plan not to add any new features for Jarvis, only bug fixing (or you should come up with something really cool).

I plan to start working on Krypton after beta release. Need to have some some stability and a version that is not prone to so many changes to start working on it.

Enjoy,
Helly.

3.2.10
- Moved Page Count info on the Weather screen to prevent overlap with Home/Back/Volume floor buttons. #841
- Updated images for sideblade label #863
- First focus to home button when entering floor buttons #883
(2016-03-25, 20:59)Helly1206 Wrote: [ -> ]I know, still on a break but just some minor updates.

3.2.10
- Moved Page Count info on the Weather screen to prevent overlap with Home/Back/Volume floor buttons. #841
- Updated images for sideblade label #863
- First focus to home button when entering floor buttons #883

THANKS Helly, much appreciated Nod
(2016-03-25, 20:50)Helly1206 Wrote: [ -> ]You can try this one on your own risk (make a backup first). open IncludesOnScreenDisplay.xml,

Exchange lines 94-125 by:
[...]

Yes! Worked like a charm!!!! Thanks! SmileSmile
(2016-01-10, 09:35)Helly1206 Wrote: [ -> ]
(2016-01-10, 02:08)wongnog Wrote: [ -> ]Also, how do I change the font color for Program Add-Ons on the main screen? I prefer if it was white:
Image

The second one is also fixed version v 3.2.0. The focused color is white as the unfocused color is still grey.

Is this something else I can modify myself via an .XML file? I would like to make the focused color white with black shadow and the unfocused color grey with blank shadow (similar to how the film title and studio are shown in the OSD when pausing a movie). Thanks again!
I love the Xonfluence skin and all the settings you can tweak.

I was wondering if it is possible to get the Artist Slideshow to work when playing music.
The addon is installed but it does not show any fanart.
Ofcourse I searched this topic, but could not find an answer.

I hope someone can put me in the right direction.
Thanks in advance.
hey i was wondering how to make the raw master file into a zip file that can be installed into kodi just for a back up in case repo goes down i really love your skin and would love to always have a back up zip file? Really love what you have done
When you install or update from the repo the downloaded zip ends up in your addons/packages folder. So you already have a backup.
hi how do i manually add a XBMC.System.Exec command to the settings.xml ?

thanks
anybody Huh