Kodi Community Forum

Full Version: install from repository missing
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am running Kodi 18.3 on my Sony Bravia 830c TV(Android 7 OS). When I first installed Kodi there about a month ago(whatever the latest version was out at that time), I setup everything without problems. However now three problems have started occurring:

1. All of my add-ons have disappeared.
2. The "Install from Repository" option is missing from the Add-on browser. I went to System | Add-ons | Add-on browser and all I see is "My add-ons" which is empty, "Install from zip file", and "Search". "Install from Repository" is not there.
3. None of my videos display the "Watched" status indicator. I play a file from start to finish, exit the player, and Kodi doesn't show the video as watched. Same problem with partially watching a file, no status change. All files just display the unwatched status.

I tried uninstalling and reinstalling 18.3 from google store but the problems remain. Any suggestions?
Here's my debug log:

Debug log:
http://s000.tinyupload.com/download.php?...6956588664

I copied a few lines that might be relevant. Seems like some DB errors:
2019-08-31 08:09:20.314 T:12270   ERROR: Unable to create new database
2019-08-31 08:09:20.318 T:12270   FATAL: ADDONS: Failed to open database
...
T:12270   DEBUG:   ParentPath = [addons://]
2019-08-31 09:29:49.029 T:18273   DEBUG: Thread waiting start, auto delete: false
2019-08-31 09:29:49.035 T:18273   ERROR: GetDirectory - Error getting addons://search/
..
2019-08-31 09:30:31.631 T:18312 WARNING: DoWork - Unable to open video database. Can not save file state!
I fixed it. I uninstalled Kodi, reset the TV, reinstalled Kodi, and everything is was working normally again. The uninstall/reinstall of Kodi might be unnecessary but I am going to list the steps I did in order just in case:

1. Uninstall Kodi.
2. Reset TV. I used the instructions here: https://www.sony-mea.com/en/electronics/...s/00114591
3. Reinstall Kodi.

If you run into this problem, I recommend trying to reset the TV first and see if that solves the problem. If not, go through the whole process. Not sure what caused the original problem. Some other app running in the background I guess.