Kodi Community Forum

Full Version: UI Missalignment with AMLogic Leia 18 build
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi everyone

I'm running kodi on my odroid c2 with archlinux. archlinux has only Kodi 17 available so I tried compiling the code myself. The compilation worked fine. However the user interface is somehow missaligned. It is offset by half the height of the screen.
Image

I noticed that the behavior of the UI depends on my modeline setting in /boot/boot.ini. When I set the mode to 720p 50Hz (spec of the screen) then I get the result in the picture. If a use 1080p 50Hz then the UI origin seems correct but everything is way too large and I see only part of the UI (the center). With certain settings no UI is shown at all.

I know that the UI engine underwent a major overhaul. So I think some changes cause this bahavior because kodi 17 does not have this problem.

I suspect that some OpenGL/EGL setting might be incorrect. The image shows that the hardware decoding works as expected (Warner Logo is correct). When I turn of the hardware decoding the output is also offset just as the UI. 

One more important information is also that I'm running kodi in framebuffer mode, so no X11 nor wayland.

I'm running out of ideas what I could do to get the alignment working. Apart from this issue everything works fine: Hardware decoding, audio, remote control,... 

The following like shows the kodi.log output. Or at least the first part which seemed relevant. 

iqokohewex.kodi (paste)

Any hint is appreciated. 

Thanks