Kodi Community Forum

Full Version: kodi Leia mesa 19.2 crash
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,
I use kodi Leia on archlinux.
With latest mesa 19.2, kodi crashes at startup :
Code:
mesa: for the -simplifycfg-sink-common option: may only occur zero or one times!
mesa: for the -global-isel-abort option: may only occur zero or one times!
/usr/local/bin/kodi : ligne 219 : 6328 Erreur de segmentation (core dumped)${KODI_BINARY} $SAVED_ARGS
Crash report available at /home/bibi/kodi_crashlog-20191005_084046.log

Log https://pastebin.com/cQMFYaFD
I tried to compil kodi from source against mesa 19.2 according wiki, and it crashe the same.

I think the issue is coming from mesa 19.2 in arch.
Any idéa or people Who get the same issue ?

Bibi
Known: #0  0x00007fe4815e1b41 in ?? () from /usr/lib/dri/radeonsi_drv_video.so

Upgrade mesa
Thats what i did :
Kodi Leia (package or compiled)+mesa 19.2 crashes
Kodi (package or compiled)+mesa 19.1 works

You mean to try mesa-git?
Something strange is that kodi works in root ^^.
I tried again to upgrade, no luck and i dont anything in the log which points to the real issue.
Check your permissions, make sure you are member of each relevant group (video, audio, etc.) and - you should know that by now - "me too" posts without and Debug Log, crashlogs is not helpful on this forum.
It works if i start kodi with root Huh
And it works with mesa-git.
Definitively a mesa build issue.
Will report back on archlinux forum.

Bibi