Kodi Community Forum

Full Version: An other movie screaping issue post....sorry
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
So like many others, I am experiencing scarping issues when trying to add new movies to my Kodi collection...this has been the case for a few weeks now and I have tried quite a few things but nothing has fixed things...let me give some system details

Kodi 18.4 - MQ8 skin
Windows 10
movie/tv database stored in MySQL database feeding multiple machines
all movies stored in directories with multiple files inside  eg DVD folder contains DVD rips and so on
file name convention as follows   Movie Filename (2019).bluray.mkv
option D (use video tags) turned off

This happens on multiple machines that all have an identical setup/GUI..three of the machines are Windows 10 machines, then there are a few Andoird boxes as well...all thaev the same issue

I should start by saying, apart from the crash that was caused by the TV scraping issue that affected most of us a few months ago, everything has been working absolutely brilliantly for years....after each update and every new skin added...really couldn't be happier with the system in general and that why I so rarely post as it just works perfectly

So, he is the crux of it.

When I scan for new content, the TV shows scrape first and work without issue...every new episode always scans the first time.

Movies can be very hit and miss.

Usually, on the first pass, it will get nothing....you can see it sometimes picks up a new item as can be seen in the bar at the top of the screen, but it will give the name of a missing item and a few seconds later just move onto the next file to be scarped or it finishes if nothing else is found.

When returning to the main menu...no new movies are shown...and when going to the missing movies add on, it shows all of the new files I expected to be scraped

Now at this point, I can press (I) for each individual movie and it will give me the option to scan, and when I do so it finds a list of matching titles, I select the one I want and the film gets correctly scraped and gets added to my library...this works for pretty much all of the films that didn't scrape automatically.

I do then have a handful of films that will not scrape at all (these tend to be the very popular movies, one example was Avengers Endgame)...pressing information will bring up the same list of possible matches, but when I select the movie I want...it thinks about it and the returns "no information"  Now I should state.  these particular films are ones that I already have copies of in my library...but they have a slightly different filename as they are either a different copy because of format or version. 

For clarity, I have tried a number of different scrapers including the (normal) Movie Database, Movie Database Python, Universal Movie Scraper and each one give the same result.

I have of course scanned through the forum and seen there appear to be some issues with MySQL libraries...is this an across the board thing on all films....and if so why would it not catch them on a normal scan but when individually scarping each movie it works fine.

I was able to fix the issue with a file previously by using a piece of software that was able to create an NFO for the offending file but didn't want to go down this route every time an issue crops up (which is currently every movie). 

I appreciate this has been covered a lot already so apologies for dragging up the same thing yet again