Kodi Community Forum

Full Version: 'Power Options' different in stand-alone mode and desktop mode.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Depending on how I start Kodi I get two different Power Options menus. When I start Kodi in stand-alone mode (my normal use of Kodi) I only get one option:

exit

If I start Kodi from the desktop I get more options:

Exit
Power off system
Custom shutdown timer
Suspend
Reboot


Except for the different starting situations everything else is the same: hardware (Zotac MAG), OS (Ubuntu 18.04.3 LTS) kernel (Linux x86 64-bit version 4.15.0-66-generic), Kodi (18.4 Git:20190831-3ade758)with skin Estuary, user (bent), etc. So it must be something in Kodi, either programs or configuration. But what?

As an aside it would actually be better the other way around - that you get the fewest options in desktop mode, because you should not be able to shut the OS down from an application.

I have uploaded two debug log files to the paste bin: kodi-standalone.log and  kodi-desktop.log
From what I've read you need to use polkit to enable Kodi as a standalone service to administer shutdown commands

231955

The thread above from fritsch seems to be the best guide.
(2019-11-04, 21:25)jlivin25 Wrote: [ -> ]From what I've read you need to use polkit to enable Kodi as a standalone service to administer shutdown commands

231955

The thread above from fritsch seems to be the best guide.


I've also found that dependant on your needs you can either hide the 'exit' option from the menu (which I've done) or remove other items by altering the skin (I've not tested)
(2019-11-04, 21:27)jlivin25 Wrote: [ -> ]
(2019-11-04, 21:25)jlivin25 Wrote: [ -> ]From what I've read you need to use polkit to enable Kodi as a standalone service to administer shutdown commands

231955

The thread above from fritsch seems to be the best guide.
Thanks a lot for the quick answer. It did the trick. Simply adding the file 'custom-actions.pkla' to /etc/polkit-1/localauthority/50-local.d/ as described in fritsch's post and rebooting the system made a options appear in the Power Options menu.