Kodi Community Forum

Full Version: Problem with Artist Information as Network Share
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have installed LibreELEC Kodi on a RPi 4 and everything works well on the Host. I am using the MariaDB/MySQL server add-on to store the Music Library. The main reason for this is so that the information can be shared by an Amazon Fire TV Stick connected to my television.

After considerable helpful advice from Forum Members (see my previous Post "Newbie's First Kodi System"): I have managed to navigate the Library on my TV, listen to music files, and view text contained in artists' NFO files.  Unfortunately, no associated artwork appears.

I have Samba shares for two Music sources : 'Artist Music' and 'Compilations' on the RPi 4. These are accessible from Windows Explorer on my Windows 10 desktop computer. MySQL Workbench is able to examine the MariaDB data tables. Here are a few edited lines from the 'art' table:

Network Share
'album', 'thumb', 'smb://192.168.0.16/Maxtor 1/Artist Music/Christopher Hogwood/Clarinet Concerto Oboe Concerto/folder.jpg'
'album', 'thumb', 'smb://192.168.0.16/Maxtor 1/Artist Music/The Linsdale Singers/40 years in 140 minutes CD1 1977-2001/folder.jpg'
'album', 'thumb', 'smb://192.168.0.16/Maxtor 1/Artist Music/The Linsdale Singers/40 years in 140 minutes CD2 2002-2017/folder.jpg'
 
Local File
'artist', 'thumb', '/var/media/Maxtor 1/Artist Information/Christopher Hogwood/folder.jpg'
'artist', 'fanart', '/var/media/Maxtor 1/Artist Information/Christopher Hogwood/fanart.jpg'

You will see that the Album Art is referenced using smb:// network paths. These allow the Amazon Fire TV Stick to display the artwork (thanks to the advancedsettings.xml file!). The text information for the individual artists is stored in the MariaDB database directly. The Artist Art is, at present, referenced using a local file situated on the same USB 3 drive (Maxtor 1).

I reasoned that if I could reference the Artist Information folder as a shared  folder I should be able to get the artist artwork to appear on the Fire TV Stick.

I have checked that the Artist Information folder is indeed shared correctly. It exists; and is readable/writeable from Windows Explorer and WinSCP. Using PuTTY, I have examined the directory permissions. They are: drwxr-xr-x (755). The owner is 'root'. 

I believe that Music Sources and File Sources are handled separately in Kodi. I used Settings>Music>Artist information folder to browse for the Artist Information folder. The Browse for Folder screen showed the expected local path (see above) , namely, /var/media/Maxtor 1/Artist Information.

However, I wished to use a networked path, so I selected the New folder option and entered 'smb://192.168.0.16/Maxtor 1/Artist Information/'. I obtained the following error message:

"Couldn't create folder. Make sure the selected folder is writeable and that the new folder name is valid''. The folder already exists. Why does Kodi need to create it?

I did, temporarily, try the dreaded 777 permissions; but that made no difference. Could it be an ownership issue or something similar? I am now confused!
Moved to Music
(2019-11-17, 23:41)Karellen Wrote: [ -> ]Moved to Music

Thank you for your prompt reply. Please forgive me for being slow, but I assume that your recommendation is to add the Artist Information folder as a Source for the Music Library?

If I do this, will the Local path that I entered via 'Settings>Music>Artist information folder' cause a problem? It still shows on the Settings screen. When I use the File Manager, there appears to be no simple way to delete the list of old sources, only add a new source.
He said "moved to music" not "move to music" and referred to your post. Is English your native tongue?
OK, so this is probably an smb permissions issue.

Workaround that I know works (if it is)
  • Open Kodi's File manager ( system -> File manager)
  • Click add source
  • Click browse
  • Click Add network location... at the bottom of the list
  • Enter the server name/address and the shared directory
  • Confirm the share has appeared in the list and click to open it
  • Confirm it's the right directory and click OK
  • Click OK

First part done !!

Now navigate to System -> settings -> media -> music and set the artist info folder ( you will have to navigate backwards using the '..' until the source you just added shows in the list and then click on it, followed by OK.

Done !!


Alternatively, you can try dropping the smb protocol in use.  System -> services -> smb client.  Set minimum to 'none, maximum to 'SMBv1' and turn on 'Use legacy security'.  Restart Kodi.
(2019-11-18, 13:27)HeresJohnny Wrote: [ -> ]He said "moved to music" not "move to music" and referred to your post. Is English your native tongue?
English is indeed my native tongue. The statement 'moved to music' could mean that the Artist Information folder is now treated as a Source for the Music Library.
It never crossed my mind that a forum moderator posting "moved to music" on a thread that had been moved from some other part of the forum to the music support subform could be interpreted as anything other than a brief explanation that the thread had been moved. Oh well.

I think @black_eagle is probaby right, it is an Samba issue. Try what he suggests and report back.
(2019-11-18, 19:13)black_eagle Wrote: [ -> ]Alternatively, you can try dropping the smb protocol in use.  System -> services -> smb client.  Set minimum to 'none, maximum to 'SMBv1' and turn on 'Use legacy security'.  Restart Kodi. 
In LibreELEC I don't see an option to set minimum to "None". Maybe that's my problem why I can't access the SMB share??

Regards,

Shedrock
(2019-11-18, 21:05)DaveBlake Wrote: [ -> ]It never crossed my mind that a forum moderator posting "moved to music" on a thread that had been moved from some other part of the forum to the music support subform could be interpreted as anything other than a brief explanation that the thread had been moved. Oh well.

I think @black_eagle is probaby right, it is an Samba issue. Try what he suggests and report back.

My apologies for misinterpreting the  'moved to music' phrase. I didn't realise it was a message from a Moderator! As well as being a Newbie with Kodi, I am only just learning how support Forums work (or should it be Fora?)...
(2019-11-18, 19:13)black_eagle Wrote: [ -> ]OK, so this is probably an smb permissions issue.

Workaround that I know works (if it is)
  • Open Kodi's File manager ( system -> File manager)
  • Click add source
  • Click browse
  • Click Add network location... at the bottom of the list
  • Enter the server name/address and the shared directory
  • Confirm the share has appeared in the list and click to open it
  • Confirm it's the right directory and click OK
  • Click OK

First part done !!

Now navigate to System -> settings -> media -> music and set the artist info folder ( you will have to navigate backwards using the '..' until the source you just added shows in the list and then click on it, followed by OK.

Done !!


Alternatively, you can try dropping the smb protocol in use.  System -> services -> smb client.  Set minimum to 'none, maximum to 'SMBv1' and turn on 'Use legacy security'.  Restart Kodi.  


Once again, Black Eagle, your expertise has solved a problem! Starting from your suggestions, and some luck(!), I managed to get my Artist Information folder shared and accessed correctly by the MariaDB database. Checking with MySQL Workbench showed that  all artwork is now referenced as a share on the RPi 4 local server.

More importantly, this has enabled the Amazon Fire TV Stick to display the artwork correctly. EVERYTHING IS NOW WORKING!!! 

Many thanks to you and all the other forum helpers who have been so supportive. It is much appreciated.
(2019-11-19, 00:37)wyvernuk Wrote: [ -> ]EVERYTHING IS NOW WORKING!!! 

Well, thats great news !!  Glad we got you sorted Smile
(2019-11-18, 22:03)shedrock Wrote: [ -> ]In LibreELEC I don't see an option to set minimum to "None".

Interesting !!  I'll check my copy of libreElec in a while, see if it's there.

EDIT - So I've checked and it's definitely there !  You do need to have your menu level set to at least 'Advanced' to be able to see the SMB Client options though. See https://kodi.wiki/view/Settings/Services/SMB_Client
Thanks @black_eagle for solving this, you are fast becoming the go to music client server/Samba guy Smile

@wyvernuk no need to apologise, we could always do with improving our communication.
(2019-11-19, 11:58)DaveBlake Wrote: [ -> ]you are fast becoming the go to music client server/Samba guy

That's because I have already been there with my own stuff !!  I much prefer NFS as a sharing protocol but there are reasons that I'm using both and every time something changes with either samba or Kodi's implementation of it, I have to figure out why it's suddenly not working and put it right.
(2019-11-19, 11:58)DaveBlake Wrote: [ -> ]@wyvernuk no need to apologise, we could always do with improving our communication.
Perhaps a standard phrase such as "Thread moved to xxxx by Moderator"? I'm sure you guys could set up a script so that a Moderator just had to enter the xxxx destination!