Kodi Community Forum

Full Version: Stutter when playing 23.976 material on Intel NUC8i3BEK
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Problem: When playing back video material encoded in x264 (haven't tested any other), container mkv or mp4 etc. doesn't matter, with 23.976fps and having activated the sync monitor to video option, I get a very short  "jerk" every 4 seconds or so. When I deactivate that option, or playing material with other framerates, everything seems normal (of course 23.976 video doesn't look optimal when that option is deactivated, but at least I don't notice the regular stutter). I use VAAPI but deactivating it doesn't change the behavior.  I have my NUC connected to an A/V receiver via HDMI, having it connected directly to my TV also doesn't change anything. I updated the NUC's BIOS to the latest version 0077 from November 27th of this year, no change. There exists a HDMI Firmware Update Tool from Intel which only runs on windows. Since I don't have that installed I'm out of luck here, but I'm not convinced it might change anything because I think the problem is elsewhere see my musings below.

My setup:
  • Intel NUC8i3BEK, which is:
  • Intel Core i3-8109U @ 3.00GHz
  • 8GB RAM
  • Intel HD Graphics GPU (Coffeelake 3x8 GT3), according to kodi info using Mesa 19.0.8 driver
  • Running Kodi v18.5
  • on (L)ubuntu 19.04 Linux 5.0.0-37-generic x86_64

Suggestion:
After creating the kodi debug log I notice the following section which concerns the start of playback:

2019-12-26 17:47:17.506 T:139740522085056   DEBUG: ------ Window Init (VideoFullScreen.xml) ------
2019-12-26 17:47:17.506 T:139740522085056    INFO: Loading skin file: VideoFullScreen.xml, load type: KEEP_IN_MEMORY
2019-12-26 17:47:17.510 T:139740522085056  NOTICE: Whitelist search for: width: 720, height: 544, fps: 23.976, 3D: false
2019-12-26 17:47:17.510 T:139740522085056   DEBUG: Trying to find exact refresh rate
2019-12-26 17:47:17.511 T:139740522085056   DEBUG: No exact whitelisted resolution matched, trying double refresh rate
2019-12-26 17:47:17.511 T:139740522085056   DEBUG: No double whitelisted resolution matched, trying 3:2 pullback
2019-12-26 17:47:17.511 T:139740522085056   DEBUG: No 3:2 pullback refresh rate whitelisted resolution matched, trying current resolution
2019-12-26 17:47:17.511 T:139740522085056   DEBUG: Matched current Resolution DP-1: 1920x1080 @ 23.98Hz (21)
2019-12-26 17:47:17.511 T:139740522085056  NOTICE: Display resolution ADJUST : DP-1: 1920x1080 @ 23.98Hz (21) (weight: 423625307979776.000)

So kodi chooses 23.98, which is not exactly 23.976, maybe that's what's causing the hiccups? I remember way back in the early days of kodi and of course with another hardware setup, having to edit some X config file to add a line to get real 23.976 output to my TV but I forgot what and where, maybe that would help?

debug.log: yirovecobi.kodi (paste)
Please post your Xorg.0.log - kodi's log does not show anything about a stutter.
(2019-12-26, 21:15)fritsch Wrote: [ -> ]Please post your Xorg.0.log - kodi's log does not show anything about a stutter.

Xorg.0.log
I don't understand why you have to enable the sync option. Your hardware is perfectly capable of outputting the "real" 23.976Hz.
Quote:[    13.189] (II) LoadModule: "modesetting"
[    13.189] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    13.190] (II) Module modesetting: vendor="X.Org Foundation"
[    13.190]     compiled for 1.20.4, module version = 1.20.4

Please switch to the intel xorg driver. You can find in the VAAPI howto, on how to do that.
(2019-12-27, 11:45)fritsch Wrote: [ -> ]
Quote:[    13.189] (II) LoadModule: "modesetting"
[    13.189] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    13.190] (II) Module modesetting: vendor="X.Org Foundation"
[    13.190]     compiled for 1.20.4, module version = 1.20.4

Please switch to the intel xorg driver. You can find in the VAAPI howto, on how to do that. 

YES, that did it! Thank you very much. You guys rock.
And if you have the time. File a bug for the modesetting driver with the kernel people.
(2019-12-27, 13:34)gokudo Wrote: [ -> ]
(2019-12-27, 11:45)fritsch Wrote: [ -> ]
Quote:[    13.189] (II) LoadModule: "modesetting"
[    13.189] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    13.190] (II) Module modesetting: vendor="X.Org Foundation"
[    13.190]     compiled for 1.20.4, module version = 1.20.4

Please switch to the intel xorg driver. You can find in the VAAPI howto, on how to do that.  

YES, that did it! Thank you very much. You guys rock. 
Can you tell me where you found the VAAPI howto that shows how to switch to the intel xorg driver?

Thanks, UbuntuUser
(2020-01-05, 02:01)UbuntuUser Wrote: [ -> ]
(2019-12-27, 13:34)gokudo Wrote: [ -> ]
(2019-12-27, 11:45)fritsch Wrote: [ -> ]Please switch to the intel xorg driver. You can find in the VAAPI howto, on how to do that.  

YES, that did it! Thank you very much. You guys rock.    
Can you tell me where you found the VAAPI howto that shows how to switch to the intel xorg driver?

Thanks, UbuntuUser   
231955 (thread)

Important part is:
Code:
cd /etc/X11/xorg.conf.d/
sudo ln -s /usr/share/doc/xserver-xorg-video-intel/xorg.conf 10-intel.conf