Kodi Community Forum

Full Version: [LINUX] XBMC for Linux port to ARM architecture CPU and SoC chips?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48
I use the mainstream XBMC which bitbake from the Angstrom/OE repo.

What you said is make sense to explain what I met, but still a bit confuse maybe off topic, why the mplayer perform very well in the same system environment, does the mplayer doesn't use the gles and shader to do presentation or yuv-rgb conversion?


BTW I have try several times to get your branch by below command

#git clone
git://xbmc.git.sourceforge.net/gitroot/xbmc/xbmc;protocol=git;branch=gsoc-2010-beagleboard

but all failed it seems the branch gsoc-2010-beagleboard does't exist this moment, any shortcut for this?
The specify XBMC I used is like below (which I got from the bitbake recipe)

SRCREV = "e2ab481ebe964321c358ab9d6402088c714adcbe"

PV = "10.05"
PR = "r11"
PR_append = "+gitr${SRCPV}"

SRC_URI = "git://xbmc.git.sourceforge.net/gitroot/xbmc/xbmc;protocol=git;branch=master \
file://0001-Only-check-for-nasm-on-i686-it-is-bogus-on-ARM-which.patch \
file://0002-Exclude-gnu-configize-for-ngstr-m-Thanks-koen.patch \
file://0003-Workaround-to-compile-python-on-ngstr-m-with-Python-.patch \
file://0004-Don-t-use-sudo-in-install-of-xbmc.bin-not-all-distri.patch \
file://0005-Hardcode-arm7-for-now.patch \
file://0006-Hardcode-python2.6-for-now.patch \
file://0007-No-need-for-FEH-on-embedded-need-a-better-way-to-not.patch \
file://0008-configure.in-also-pass-down-target-when-using-host-a.patch \
file://0009-Added-a-configure-option-disable-optical-drive.patch \
file://0010-Fixed-so-compile-worked-when-disabling-optical.patch \
file://0011-reverted-so-normal-bootstrap-doesn-t-exclude-gnu-con.patch \
file://0012-fix-lzo-things.patch \

I don't know whether this repo contain what topfs's optimization patch/
Nope it doesn't. The optimizations haven't been migrated to git actually.

I'll have to take some time and push it to my repo and then start a pull request, it really have no reason why its not in the main. I'll try to do that ASAP.
The XBMC has two repo host one is

git://xbmc.git.sourceforge.net/gitroot/xbmc/xbmc

another locate at https://github.com/xbmc/xbmc.git

It seems the second hot update more quickly than the first one. do anyone what the relationship or different between these two repo.

BTW, when I try to get the gsoc-2010-beagleboard branch by

#git clone git://xbmc.git.sourceforge.net/gitroot/xbmc/xbmc

It always get error after pull some of it, do any people experience with this. Thnaks.
http://xbmc.org/theuni/2011/01/02/xbmc-moves-to-git/

the sourceforge one is not valid anymore
As the link said, all code has been moved to github

but it seems the github has no branch gsoc-2010-beagleboard. so if I wander to try the gsoc-2010-beagleboard, where can I pull it?
The link (IIRC, did not read it now) says some code have been moved. Many branches have been left out, mostly because we wanted to keep the mainline git repo down in size. As I said I'll try to get the overlay patches into my repo ASAP, after that I'll try to get my repo to have the gsoc. I should have done this long time ago but my life is quite hectic atm (lots in school).

IIRC the source should still be on sourceforge, pretty sure we never took that away. If you prefer git check out xbmc-antiquated which most likely hold the code aswell.
Hi topfs2,

will your code update also include the modifications for the Pandaboard or is that code directly going to the main line? As I received my board in mid February and now have vacation so I could at least take a look.
Many thanks in advance.
I have try to download the xbmc-gsoc-2010-beagleboard snapshot from the link
http://xbmc.git.sourceforge.net/git/gitw...eagleboard to local directory /XXX/xbmc-17021a9

which the revision ID is 17021a9d3e7661afd358a583ad747839497d3f42 the commit is
2010-08-16 topfs2 Moved to JPG instead of BMP

Then I modification the angstrom's distribution XBMC recipe xbmc_svn.bb file like below:

PV = "gsoc-2010-beagleboard"
S = "/XXX/xbmc-17021a9"


Then I try to run the recipe by :
MACHINE=beagleboard bitbake -b xbmc_svn.bb


But it report error like below:
Build Configuration:
BB_VERSION = "1.10.2"
METADATA_BRANCH = "org.openembedded.dev"
METADATA_REVISION = "3a7b93a"
TARGET_ARCH = "arm"
TARGET_OS = "linux-gnueabi"
MACHINE = "beagleboard"
DISTRO = "angstrom"
DISTRO_VERSION = "2010.7-test-20110319"
TARGET_FPU = "hard"

NOTE: Preparing runqueue
NOTE: Executing runqueue
NOTE: Running task 7 of 19 (ID: 13, /XXX/angstrom/angstrom-setup-scripts/sources/openembedded/recipes/xbmc/xbmc_svn.bb, do_compile)
NOTE: package xbmc-gsoc-2010-beagleboard-r0: task do_compile: Started
ERROR: TaskFailed event exception, aborting
ERROR: Build of /XXX/angstrom/angstrom-setup-scripts/sources/openembedded/recipes/xbmc/xbmc_svn.bb do_compile failed
ERROR: Task 13 (/XXX/angstrom/angstrom-setup-scripts/sources/openembedded/recipes/xbmc/xbmc_svn.bb, do_compile) failed with exit code 1
ERROR: '/XXX/angstrom/angstrom-setup-scripts/sources/openembedded/recipes/xbmc/xbmc_svn.bb' failed
ERROR: Function do_compile failed
NOTE: Task failed: ('function do_compile failed', '/XXX/angstrom/angstrom-setup-scripts/build/tmp-angstrom_2008_1/work/armv7a-angstrom-linux-gnueabi/xbmc-gsoc-2010-beagleboard-r0/temp/log.do_compile.14895')
ERROR: Logfile of failure stored in: /XXX/angstrom/angstrom-setup-scripts/build/tmp-angstrom_2008_1/work/armv7a-angstrom-linux-gnueabi/xbmc-gsoc-2010-beagleboard-r0/temp/log.do_compile.14895
Log data follows:
| sed: can't read /XXX/xbmc-17021a9/Makefile: No such file or directory
| ERROR: Function do_compile failed
NOTE: package xbmc-gsoc-2010-beagleboard-r0: task do_compile: Failed
ERROR: TaskFailed event exception, aborting
ERROR: Build of /XXX/angstrom/angstrom-setup-scripts/sources/openembedded/recipes/xbmc/xbmc_svn.bb do_compile failed
ERROR: Task 13 (/XXX/angstrom/angstrom-setup-scripts/sources/openembedded/recipes/xbmc/xbmc_svn.bb, do_compile) failed with exit code 1
ERROR: '/XXX/angstrom/angstrom-setup-scripts/sources/openembedded/recipes/xbmc/xbmc_svn.bb' failed

When I open the log file /XXX/angstrom/angstrom-setup-scripts/build/tmp-angstrom_2008_1/work/armv7a-angstrom-linux-gnueabi/xbmc-gsoc-2010-beagleboard-r0/temp/log.do_compile.14895
It show below:

sed: can't read /XXX/xbmc-17021a9/Makefile: No such file or directory
ERROR: Function do_compile failed


So it seems the Makefile is missing, do we need generated the Makefile by manuel, IIRC the Makfile will be generated automatics, is it?
Hi XBMC experts.

See a lot discussions here for panda and beagle, instead, I'm using tg2(Nvidia's Tegra2).

If you already have beagle-xm or panda running xbmc, could you please advice whether the addon works?

On my tg2, xbmc(lastest master branch compiled with gcc-4.4.5) can be launched and runs... when I try the xbmc addon on tg2, seams there is no response after I click on the item(for example picture->picaso). Below is the log, the key message is "reason: /usr/local/share/xbmc/system/python/python26-arm.so: cannot open shared object file: No such file or directory". did a search and file the file at "/usr/local/lib/xbmc/system/python/python26-arm.so". create a softlink and try again, get "WARNING: Unable to resolve: python26-arm.so PyEval_ReleaseLock, reason: /usr/local/share/xbmc/system/python/python26-arm.so: undefined symbol: PyEval_ReleaseLock". Anyone has any idea about how to make the addon working on ARM- tg2?

19:04:03 T:1295684640 M:853434368 DEBUG: thread start, auto delete: 1
19:04:05 T:1106141840 M:853118976 DEBUG: CGUIMediaWindow::GetDirectory (plugin://plugin.image.picasa/)
19:04:05 T:1106141840 M:853118976 DEBUG: ParentPath = [addons://sources/image/]
19:04:05 T:1295684640 M:853118976 DEBUG: StartScript - calling plugin Picasa('plugin://plugin.image.picasa/','0','')
19:04:05 T:1295684640 M:853118976 INFO: initializing python engine.
19:04:05 T:1295684640 M:853118976 DEBUG: Loading: /usr/local/share/xbmc/system/python/python26-arm.so
19:04:05 T:1295684640 M:853118976 ERROR: Unable to load /usr/local/share/xbmc/system/python/python26-arm.so, reason: /usr/local/share/xbmc/system/python/python26-arm.so: cannot open shared object file: No such file or directory
19:04:05 T:1295684640 M:853118976 FATAL: Python: error loading python24.dll
19:04:05 T:1295684640 M:853118976 ERROR: Unable to run plugin Picasa
19:04:05 T:1106141840 M:853118976 ERROR: GetDirectory - Error getting plugin://plugin.image.picasa/
19:04:05 T:1106141840 M:853118976 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.image.picasa/) failed
19:04:05 T:1106141840 M:853118976 DEBUG: CGUIMediaWindow::GetDirectory (addons://sources/image/)
19:04:05 T:1106141840 M:853118976 DEBUG: ParentPath = []
Your missing python, which is why it fails
Your system is missing python.

You are (You're) missing python.
python is there, I already re-build Python-2.6.6 on tg2, please see below python launch info. Which version external python do you use 2.5.5/2.7.1/3.x?
[email protected]:~$ python
Python 2.6.6 (r266:84292, Mar 24 2011, 15:01:44)
[GCC 4.4.5] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>>

Are the following related to this issue? does these 2 "make" have to be run before "make install"?
make -C lib/addons/script.module.pil
make -C lib/addons/script.module.pysqlite
(real location) -> /usr/local/lib/xbmc/system/python

vs

(xbmc is looking for it at ) -> /usr/local/share/xbmc/system/python

try symlinking the python and no just python26-arm.so
darkscout Wrote:Your system is missing python.

You are (You're) missing python.

Blush

English is my second language and I wrote without thinking enough :p
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48