Kodi Community Forum

Full Version: [LINUX] XBMC for Linux port to ARM architecture CPU and SoC chips?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48
This is great.
I am working on Planet ITB-3001 Set Top Box using RTD1073


This STB has basic interface and VLC experimental port, It is low priced STB and I am trying to port XBMC on it. I'll be obliged if I can get any help from you or anyone who is on your forum.

Amjad Alvi.
(2012-03-23, 08:27)amjadalvi Wrote: [ -> ]This is great.
I am working on Planet ITB-3001 Set Top Box using RTD1073


This STB has basic interface and VLC experimental port, It is low priced STB and I am trying to port XBMC on it. I'll be obliged if I can get any help from you or anyone who is on your forum.

Amjad Alvi.

The Realtek RTD1073 doesn't have an OpenGL-ES GPU so I would suspect it is unlikely XBMC would ever run on it even if you could port it. You might want to try the newer RTD1186 (various 1186 players) they have a OpenGL-ES 2.0 GPU built in. The 1186 are dual boot players the linux OS Realtek supply and their own custom build of Android but from what I've heard the GPU isn't used at all in the linux OS part, which is astonishing as the GUI Realtek supply is really bad. You'd think they would create something better now they have the hardware or port XBMC themselves like Sigma Designs are doing.
(2012-03-22, 23:29)pfbach Wrote: [ -> ]
(2012-02-21, 09:14)solmis Wrote: [ -> ]I got the Linaro XBMC working for a while, but after some package update I started getting green lines all over the screen and playback is now choppy. Any idea what causes this and how to fix it?

xbmc on pandaboard has been working for me for a few weeks now, but yesterday I somehow I have gotten this strange tearing in the video with mostly white and green lines. Video and audio is no longer in sync either.

Yesterday I added the repo ppa:tiomap-dev/release and upgraded quite a few packages from there.
Until yesterday I only used packages from ppa:linaro-maintainers/overlay

I tried to remove all packages and reinstall with only the packages from linaro-maintainers, but without luck.

Today I tried to install a clean copy of ubuntu linaro (12.02) on a new SD-card but now I get video-tearing there as well with only packages from ppa:linaro-maintainers/overlay installed.

What package is causing this?

It means you don't have video acceleration working. Did you remember to install ubuntu-omap-extras?

I had the same problem before. After it broke I couldn't get it working no matter what I did.

Too bad the hdmi sound is broken and I think the whole alsa is somehow messed up because external 7.1 card had same issues. Everything is "analog" and only outputs stereo.
OK, I have found myself a nice and neat project to get myself into touch with ARM and SoC, but thought it would be good to place it here as well. A lot of you guys are far ahead of me and can do whatever I want to do in a lot less time. (I am still doing it for me anyway, as I always need something to play with and learn from Big Grin )

Most of you know the Raspberry, some of you know the Rhombus-tech EOMA-68 project. (which looks like to fly soon as well)


Allwinner the manufacturer of the Allwinner A1X SoC decided to go fully opensource / GPL compliant. For the people who don't want to wait for the EOMA-68 board (or raspbery-pi for that matter) there is now a STB box made with the same hardware.

The drivers for the MALI-400 are reversed engineerd, so will be in the end open source as well. And if I read the documentation (user manual) on the following github;

We will have full hardware decode of all major formats any time soon as well.

Anyway, more info on the OE thread as that is my initial plan. I will start leaning / playing around with the u-boot kernel first (has been a while since my last kernel hacking projects. 2.4.x )

So if anybody of you want a cheap ARM-SoC develepment board which is *unbrickable*. Buy a Mele A1000. (Check the mailing list, Tom from China will shortly open up his alieexpress shop again where you can buy them at $65,-)
Hi everybody,

I'm currently working on a port of xbmc (11.0-rc1) to EfikaMX or better to Freescale's ARM SoC i.MX51. I got so far to get the video stream decoded by its VPU to a YV12 image. The VPU supports all major formats - at least all I need Wink All is done by the new DVDVideoCodec derived class called DVDVideoCodecVPU.

My problem now is to get the YV12 image to screen. If I set the format in DVDVideoPicture to FMT_YUV420P I get a stripped image completely colored in pink. In other words: You cannot watch any video Sad

Yesterday I tried a second approach. This time I merged the EGL renderer from robclark's gstreamer branch to my code base. In my tests I got all well colored image but still with stripes and today the screen keeps black (only audio and overlay rendering works) Sad

In both approachs the stripes are 8 pixels width and are in the following order (G=good pixel, B=bad pixel):

and so on

Now my question is: Does anybody know what causes the stripes? I believe the EGL shaders I merged are the problem. But to be honest I have no knowledge of GLES, EGL and even my knowledge of OpenGL is very limited.

My next idea would be to implement DVP_RENDER_BYPASS which set the RENDER_BYPASS flag in DVDPlayer. This should prevent the GLES renderer to render any video image - in hope I read the code right. I could then open a V4L device (if not in use by X server) to push the decoded directly to screen. Has anybody tried something similar or is it an idea to stop working on?

Even my patches are not working fully I would like to share my code as soon as I learned git again and can push my code to github. I can only clone repositories Wink

Thanks for any ideas
I used to get the same Pink/Black Screen issue with My Apple TV Linux Build(s). It was related to the non standard way some Televisions (Sharp) accepted Component video through the HDMI Port as RGB instead of YV12. If you are using a HDTV as your display try hooking it up to a standard Monitor to see if the problem persists.
Thanks for response. I do not have a HDMI capable TV or monitor. The device is connected with a HDMI-to-DVI cable to a monitor. Also the overlays (e,g. to display progress bar during video playback) are working fine but drop my framerate down to around 5 fps. It looks to me that the monitor isn't the problem :/
Ok, I found my mistake why the screen keeps blank on video playback. When I cleaned up the code I missed a single line which caused to prevent the shaders being loaded and compiled. Now I get pictured displayed without (nearly) any delay and without any stutter. But one problem remains: I still get these stripes. An image of these can be found here: froevel.de/stripes.jpg" target="_blank" rel="noopener" class="mycode_url">http://www.froevel.de/[email protected]froevel.de/stripes.jpg

Does anybody has any idea what causes theses stripes? It must be software related. That's the only thing I'm sure of.

Can I ask what type of video you are testing with? for example, are you trying with an interlaced video file? and if so, does the problem still exist if you try with a non-interlaced video?
@McGeagh: To be honest I don't know and haven't checked it. But I found the cause of the problem. I used the system's version of memcpy to copy the decoded frame into an EGLImage. This function is overriden by preloading /lib/libc-neon.so containing optimized version of some memory modifying functions like memcpy. After turning off preloading this file memcpy works as expected and the stripes are gone. I was too lazy to recompile and packagae this single file so copied it from the pre-installed Ubuntu to my Gentoo system. I think floating point ABI incompatibilities caused memcpy to misbehave. Next step is to try XBMC's fast_memcpy function as every little performance gain should be used Wink

To make a long story short: XBMC is running on my EfikaMX (Freescale i:MX51) Big Grin Now I will port it from my development version (11.0-rc1) to the final version. If someone could help me with the autotool files (configure.ac, Makefile.in and so on) and you're interested in supporting this platform I would like to provide patch file(s) and file an enhancement bug.
Nice work! Please do file a ticket (or a pull request on github) with the changes you have. Someone else may have similar hardware - not sure if we'll want the changes in mainline, but it basically depends on what it touches and what hw is out there to use it, and who we have to maintain it Smile

The bugs are filed Wink

I decided to split it up into two feature request as adding support for rendering using EGLImage is more general and device-independent. It is also used in the video decoder using GStreamer for decoding. The code therefore is from robclark's xbmc branch. A lot of thanks to him Smile


To tell the truth this decoder has still two problems. First one - it isn't lipsync. Video is around half a second behind audio. Does this happen because I do not set the DTS and/or PTS timestamp and let XBMC decide to set the value?

Second problem is that I have problems detecting the initial decoding parameters for h.264 decoded streams. Maybe the problem relies on my test source, Need to test it with "Big Buck Bunny" Wink

That's all for now.

Happy Easter
This may entice some additional developers to join in the development of XBMC for ARM

Mele A1000 is now being sold for $85(US) including shipping as an "unbrickable" hackable/rooted 1080p ARM (Cortex A8) media player with remote control

Quote:I am selling Allwinner chip based products on aliexpress aiming at providing some convenience for western hacker to do some hacking on Allwinner chip based products as well as making little money and for fun.

It's the same product as Mele website, I get the boxes from their factory, the package includes the tv box, remote, cvbs cable.

Powered by Allwinner A10 chip, for more information, please go to
http: //rhombus-tech.net/allwinner_a10/

Some hacking instructions:
http: //rhombus-tech.net/allwinner_a10/hacking_the_mele_a1000/


http: //lists.phcomp.co.uk/pipermail/arm-netbook/


#arm-netbook on irc.freenode.net

Just copied the mail from matt.

The box SPEC.

1. Video output - HDMI, CVBS, VGA .

2. Audio output - R+L, SPDIF

3. Usb host port + SDCard slot.

4. External SATA port (real SATA not from usb)

5. Ethernet.

Internal board has

1. UART port connector.

2. USB device port connector

3. MIC pin

4. CVBS-IN pin.
and the same Mele A1000 players is also being sold with the remote control at DealExtreme.com for $100(US) including shipping
Folks, is there any work being done for the Geniatech Enjoy TV boxes? Like ATV1000, ATV2000, ATV300, ATV310, etc... I think they all use the same Amlogic Cortex A9 chipset + Mali 400 GPU correct? If XBMC could run on those devices that would turn them into HOT hardware for XBMC... The ATV310 for instance, would kick the new Apple TV's but! :-D

Thx for all good work XBMC team! I just LOVE your stuff (and so does all my family!)
yes... but I'd have to...
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48