Kodi Community Forum

Full Version: Ember Media Manager 1.5.x - Download & Discussion Thread
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23
(2020-02-21, 13:37)komplex Wrote: [ -> ]Thanks for the update Smile So does this mean I am able to build from the 1.4.8.0_alpha_24 branch for myself?
Yes Smile
(2020-02-21, 13:57)Cheadstina Wrote: [ -> ]
(2020-02-20, 10:31)DanCooper Wrote: [ -> ]
(2020-02-20, 03:16)zonly1 Wrote: [ -> ]Hi Dan, I upgraded to the new version and found an issue that causes ember to crash with "Object reference not set to an instance of an object" error.
I made some tests with the settings and discovered that if scraping Collection ID in the TMDB scraper is enabled and the movie is not part of a collection, it will crash. If it is part of a collection, it will scrape fine.
Thx, has been fixed, new version 1.4.91.1 is online.  
I still see this error when I have Collection ID enabled for movies (TMDB) - even with 1.4.91.1 installed.
Tried three different movies same error. 
That's strange. The bug was obvious ("If xy Is Nothing Then" instead of "If xy IsNot Nothing Then") and that has been fixed. I tested it and works for me. Please share your error log (:\Ember Media Manager\Logs) on Pastebin.com, so I can see the full error report.
I was getting errors about unable to find tvdbapi so just cloned your fork https://github.com/DanCooper/TheTVDBApi and it builds fine.
(2020-02-21, 14:49)komplex Wrote: [ -> ]I was getting errors about unable to find tvdbapi so just cloned your fork https://github.com/DanCooper/TheTVDBApi and it builds fine.
Oh yes, that should be refered propery to the GitHub project. I have to see how to integrate an external project neatly into another VS project. But you selected the correct build/state.
Many thanks for the new version Blush

I have IMDb as the first scraper and TMDb as the second one. I have some items that don't have a plot or plot outline in IMDb but all the other data is better in my opinion. Now when I scrape, I get the IMDb plot outline displayed with text "Know what this is?" or something like that because IMDb returns only that. I then empty the field and click Next, after which the TMDb plot data appears. However, it is not used when the scraping is finished and I get to preview all the scraped data but the IMDb returned "generic" plot text is there. Is this a bug?
Thanks very much for the update, I get the following error when trying to scrape a movie with a comma in the title.... at least i think that is the issue? i.e. Alexander and the Terrible, Horrible, No Good, Very Bad Day (2014)
​​​​​​​

Image

Any ideas?
The kodi sync is still not working Sad
Quote:2020-02-21 13:47:11.5125,generic.Interface.Kodi.Kodi.APIKodi,generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_55_IsScanningVideo.MoveNext,8,TRACE,[APIKodi][Kodi Headless Docker] IsScanningVideo: True,
2020-02-21 13:47:12.5282,generic.Interface.Kodi.Kodi.APIKodi,generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_55_IsScanningVideo.MoveNext,16,TRACE,[APIKodi][Kodi Headless Docker] IsScanningVideo: True,
2020-02-21 13:47:13.5437,generic.Interface.Kodi.Kodi.APIKodi,generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_55_IsScanningVideo.MoveNext,8,TRACE,[APIKodi][Kodi Headless Docker] IsScanningVideo: True,
2020-02-21 13:47:14.5594,generic.Interface.Kodi.Kodi.APIKodi,generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_55_IsScanningVideo.MoveNext,16,TRACE,[APIKodi][Kodi Headless Docker] IsScanningVideo: True,
2020-02-21 13:47:15.5754,generic.Interface.Kodi.Kodi.APIKodi,generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_55_IsScanningVideo.MoveNext,8,TRACE,[APIKodi][Kodi Headless Docker] IsScanningVideo: False,
2020-02-21 13:47:15.6062,generic.Interface.Kodi.Kodi.APIKodi,generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_32_SearchMovie.MoveNext,16,WARN,"[APIKodi][Kodi Headless Docker][SearchMovie] ""Z:\bollywood\Baazigar.1993.1080p.amazon.webdl.eac3.h264-Telly\Baazigar.1993.1080p.amazon.webdl.eac3.h264-Telly.mkv"" | NOT found in host database!",
2020-02-21 13:47:15.6062,generic.Interface.Kodi.Kodi.APIKodi,generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_39_UpdateInfo_Movie.MoveNext,16,ERROR,"[APIKodi][Kodi Headless Docker] UpdateInfo_Movie: ""Baazigar"" | NOT found on host! Abort!",
2020-02-21 13:47:15.6062,generic.Interface.Kodi.KodiInterface,generic.Interface.Kodi.KodiInterface+VB$StateMachine_74_GenericRunCallBack.MoveNext,16,WARN,[KodiInterface][Kodi Headless Docker][GenericRunCallBack] | Sync Failed:  Baazigar,
2020-02-21 13:47:15.6062,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,16,TRACE,[ModulesManager][RunGeneric][Start] <Notification>,
2020-02-21 13:47:15.6062,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,16,TRACE,[ModulesManager][RunGeneric] Run generic module <Notifications>,
(2020-02-21, 21:57)ping182nz Wrote: [ -> ]Thanks very much for the update, I get the following error when trying to scrape a movie with a comma in the title.... at least i think that is the issue? i.e. Alexander and the Terrible, Horrible, No Good, Very Bad Day (2014)
​​​​​​​
Image

Any ideas?
Error log?
(2020-02-21, 23:46)shwetkprabhat Wrote: [ -> ]The kodi sync is still not working Sad
Quote:2020-02-21 13:47:11.5125,generic.Interface.Kodi.Kodi.APIKodi,generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_55_IsScanningVideo.MoveNext,8,TRACE,[APIKodi][Kodi Headless Docker] IsScanningVideo: True,
2020-02-21 13:47:12.5282,generic.Interface.Kodi.Kodi.APIKodi,generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_55_IsScanningVideo.MoveNext,16,TRACE,[APIKodi][Kodi Headless Docker] IsScanningVideo: True,
2020-02-21 13:47:13.5437,generic.Interface.Kodi.Kodi.APIKodi,generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_55_IsScanningVideo.MoveNext,8,TRACE,[APIKodi][Kodi Headless Docker] IsScanningVideo: True,
2020-02-21 13:47:14.5594,generic.Interface.Kodi.Kodi.APIKodi,generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_55_IsScanningVideo.MoveNext,16,TRACE,[APIKodi][Kodi Headless Docker] IsScanningVideo: True,
2020-02-21 13:47:15.5754,generic.Interface.Kodi.Kodi.APIKodi,generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_55_IsScanningVideo.MoveNext,8,TRACE,[APIKodi][Kodi Headless Docker] IsScanningVideo: False,
2020-02-21 13:47:15.6062,generic.Interface.Kodi.Kodi.APIKodi,generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_32_SearchMovie.MoveNext,16,WARN,"[APIKodi][Kodi Headless Docker][SearchMovie] ""Z:\bollywood\Baazigar.1993.1080p.amazon.webdl.eac3.h264-Telly\Baazigar.1993.1080p.amazon.webdl.eac3.h264-Telly.mkv"" | NOT found in host database!",
2020-02-21 13:47:15.6062,generic.Interface.Kodi.Kodi.APIKodi,generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_39_UpdateInfo_Movie.MoveNext,16,ERROR,"[APIKodi][Kodi Headless Docker] UpdateInfo_Movie: ""Baazigar"" | NOT found on host! Abort!",
2020-02-21 13:47:15.6062,generic.Interface.Kodi.KodiInterface,generic.Interface.Kodi.KodiInterface+VB$StateMachine_74_GenericRunCallBack.MoveNext,16,WARN,[KodiInterface][Kodi Headless Docker][GenericRunCallBack] | Sync Failed:  Baazigar,
2020-02-21 13:47:15.6062,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,16,TRACE,[ModulesManager][RunGeneric][Start] <Notification>,
2020-02-21 13:47:15.6062,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,16,TRACE,[ModulesManager][RunGeneric] Run generic module <Notifications>,
Need the full Kodi Interface part of the log, not only a part of it.
(2020-02-21, 20:49)Boulder Wrote: [ -> ]Many thanks for the new version Blush

I have IMDb as the first scraper and TMDb as the second one. I have some items that don't have a plot or plot outline in IMDb but all the other data is better in my opinion. Now when I scrape, I get the IMDb plot outline displayed with text "Know what this is?" or something like that because IMDb returns only that. I then empty the field and click Next, after which the TMDb plot data appears. However, it is not used when the scraping is finished and I get to preview all the scraped data but the IMDb returned "generic" plot text is there. Is this a bug?
Do you've an example of a movie? Do you use the "Settings => Movies => Data Scraper => Show scraper results in detaild view" or what do you mean with "preview"?
So even with this latest version, TV Movies are still ignored by the scraper?
I'm getting an error citing the inability to load the IMDB API.  I installed the new version on top of my prior version's folder, thinking it would overwrite what was needed.

The error is as follows: "Could not load type 'EmberAPI.IMDb.Scraper' from assembly 'EmberAPI, Version=1.4.91.0, Culture=neutral, PublicKeyToken=null."  The program closes immediately after acknowledging the error pop-up.  

If I need to do a fresh install, what do I need to move over from the old one in order to retain all my custom settings and directories?  

Thanks so much, Dan!
(2020-02-22, 03:25)noonan2678 Wrote: [ -> ]
(2020-02-22, 03:25)noonan2678 Wrote: [ -> ]I'm getting an error citing the inability to load the IMDB API.
Antivirus?

I installed the new version on top of my prior version's folder, thinking it would overwrite what was needed.
That's the best way to do it.

(2020-02-22, 03:25)noonan2678 Wrote: [ -> ]If I need to do a fresh install, what do I need to move over from the old one in order to retain all my custom settings and directories?  
Copy the Profiles folder for all settings and the Temp folder if you want to keep the cached data from scrapers.
(2020-02-22, 03:12)badbob001 Wrote: [ -> ]So even with this latest version, TV Movies are still ignored by the scraper?
You have to enable tv movie scraping in the IMDb scraper settings. I need an example movie title if it does not work.
Thanks, Dan.  I edited my original post above with the specific error.  It happens after clicking "ok" once the image scraping is complete.  I put the Ember install folder in the exceptions my security suite, so not that.  Since it's displaying all the images, maybe the error is based on the trailer scrape?  

I'd much rather just keep the install as-is if the error itself is one you're familiar with and has a fix.

Thank you again!

EDIT - I disabled the IMDb trailer scraper and now get this error once clicking "ok" after the image scraping - "Method not found: 'System.String EmberAPI.HTTP.DownloadData(System.String)"

EDIT 2 - If I disable trailer scraping altogether, it works.  So, this is related to trailers only.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23