Kodi Community Forum

Full Version: Ember Media Manager 1.5.x - Download & Discussion Thread
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23
I've also some issues with season sync. I'll check that today.
(2020-03-16, 21:18)DanCooper Wrote: [ -> ]
(2020-03-16, 20:28)Boulder Wrote: [ -> ]I have a problem with the profiles. I've tried setting two -- the default one named Default, and a second one named TMDb which is a copy of Default but with TMDb being the first scraper followed by IMDb. In Default, it's the other way around. The changes don't seem to apply when I change the profile in EMM, the order stays the same. I've checked that settings.xml does change accordingly, and the profile works if I select it upon startup.

Another thing related to this. There is the option to load the default profile automatically. It seems that it will load whatever profile you chose the last time if that checkbox is enabled, I thought it was supposed to look for the profile named Default.
The checkbox is to mark the default profile. If you want to select a profile to start you just have to select the name. 
That leaves the issue in which changing the profile after EMM has loaded doesn't work. I sometimes have these rare cases where I upload a bunch of stuff on the NAS and one of the items is not found in IMDb, or the data is not good enough and I want to use TMDb instead and a separate profile to use would make that a lot easier.
Hey Dan, 
A few pages back I talked about an issue where EMM doesn't create nfos for the new episodes of TV shows.
They do appear in Kodi once I update the library even though they have no nfos in the season folders.
Now I'm trying to add a new show to my library and it's not working. EMM creates the tvshow.nfo but I can't add it to Kodi.

Here's the nfo for the show, I'd really appreciate if you could have a look. Thanks!

https://pastebin.com/3V18r7Re
(2020-03-18, 21:15)ArieS Wrote: [ -> ]Hey Dan, 
A few pages back I talked about an issue where EMM doesn't create nfos for the new episodes of TV shows.
They do appear in Kodi once I update the library even though they have no nfos in the season folders.
Now I'm trying to add a new show to my library and it's not working. EMM creates the tvshow.nfo but I can't add it to Kodi.

Here's the nfo for the show, I'd really appreciate if you could have a look. Thanks!

https://pastebin.com/3V18r7Re
That nfo looks ok to me.  Compared it to a different one on my system and data fields match etc.

Sorry if teaching you to suck eggs but are you sure in Kodi

A: video source is pointing to look for nfo?
B: video source is set to not search for updates?
C: Is your file/folder structure too deep and Kodi does not look that far down? eg: my structure that works = \\Driveshare\TVShows\TVShowTitle\Season 01

But actaully I also notice in your nfo you have

<id>359569</id>
  <imdb>tt1869454</imdb>
  <tmdb>71915</tmdb>
  <uniqueid type="tvdb" default="true">359569</uniqueid>
  <uniqueid type="imdb" default="false">tt1869454</uniqueid>

...before the <title>Good Omens</title>

Most likely my ember config is different to yours but on mine and after
<?xml version="1.0" encoding="utf-8"?>
<tvshow xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

I have <title>TV SHOW TITLE</title> and I do not have the <uniqueid type fields at all.

Not sure if <title> needs to be closer to the top of the nfo? or how you generated to the <uniqueid fields
Hi, when scraping images for South Park and selection pictures I got .NET error (sorry it's in my native language - Czech). 

Link for the .NET error
Image select
Index is out of the range
:
jomemosesi (paste)

The app stopped at "downloading new images"

In the LOG file, there is only one file, which was not found for download, and some minor errors
idopohomen.kodi (paste)
(2020-03-21, 14:23)czjohny Wrote: [ -> ]Hi, when scraping images for South Park and selection pictures I got .NET error (sorry it's in my native language - Czech). 

Link for the .NET error
Image select
Index is out of the range
:
jomemosesi (paste)

The app stopped at "downloading new images"

In the LOG file, there is only one file, which was not found for download, and some minor errors
idopohomen.kodi (paste)
Teh fanart.tv image server is down/broken. Wait or disable the fanart.tv scrapers.
noticed that since the update, no trailer links are being scraped. would typically get a youtube plugin compatible link that would simply let me click on a movie Information from the kodi gui and a clickable Trailer button would start playing a trailer. not sure if there is another way to do this.
(2020-03-24, 01:10)dr-oopie Wrote: [ -> ]noticed that since the update, no trailer links are being scraped. would typically get a youtube plugin compatible link that would simply let me click on a movie Information from the kodi gui and a clickable Trailer button would start playing a trailer. not sure if there is another way to do this.
Only the TMDb data scraper provides YouTube trailer links. Is that one enabled? If added an "available" check in the latest version and i know that for some videos the check (official YouTube video information) reports a video as "not playable" even the video can be played in browser. ATM i don't know a workaround for that issue.
(2020-03-24, 01:21)DanCooper Wrote: [ -> ]
(2020-03-24, 01:10)dr-oopie Wrote: [ -> ]noticed that since the update, no trailer links are being scraped. would typically get a youtube plugin compatible link that would simply let me click on a movie Information from the kodi gui and a clickable Trailer button would start playing a trailer. not sure if there is another way to do this.
Only the TMDb data scraper provides YouTube trailer links. Is that one enabled? If added an "available" check in the latest version and i know that for some videos the check (official YouTube video information) reports a video as "not playable" even the video can be played in browser. ATM i don't know a workaround for that issue.   

i had IMDB first and TMDb second in the list. i put TMDb and scraped a new movie but it didnt add anything under the trailer field. however, no matter which scraper is your prioraty, you can still manually click the + button  and search for a trailer and pick 1 from the list and add it to nfo. that does add a regular youtube link in the trailer field. doesnt do it automatically when scraping a movie tho.

EDIT: it looks like even tho it adds the a standard link, once you click ok to save the movie scrap info, it does convert the link to youtube plugin -> plugin://plugin.video.youtube/?action=play_video&videoid=

edit 2: with TMDb as prioarty, right clicking on a Movie title and selecting Rescrape single data field and selecting Trailer doesnt add a link anymore.
I think I found a small bug: when I force (Re)Scrapper selected movies -> force best match and none is found Ember crashes.

For example, for sorting I usually put the "the" in the end of the folders name like "39 Steps, The". Ember cannot find movies in this format which is fine, it usually prompts a dialog to correct the name. Now however the app crashes.

Thank you for all your work.
Can you please add Set Info in Movie Edit Window? 

the ideal would be to select the Set that a movie belongs from the Movie Edit Window, but if this is too complex to be implemented then maybe in Movie Edit Window Set Info can be displayed without the option to edit.
(2020-03-24, 20:47)solamnic Wrote: [ -> ]Can you please add Set Info in Movie Edit Window? 

the ideal would be to select the Set that a movie belongs from the Movie Edit Window, but if this is too complex to be implemented then maybe in Movie Edit Window Set Info can be displayed without the option to edit.

Ember 2.x will have a dropdown list to select the movieset and also the "TV Show Link":

Image
Perfect!!!!!!!!!!! any ETA on v2 ?
Hi Dan,

Looking at the screenshot for the upcoming update, I'm curious, do the "Custom" checkboxes allow for manually adding custom metadata?  I use Emby, which will show the Rotten Tomatoes score if there is a <criticrating> tag.  Emby can scrape the RT score for Movies, but if you want them for TV Shows, they have to be manually added.  I would love to be able to add this to the NFO using EMM.  Will this be possible?

Thanks again for all the effort you've put in over the years!
(2020-03-25, 19:49)KevinSartori Wrote: [ -> ]Hi Dan,

Looking at the screenshot for the upcoming update, I'm curious, do the "Custom" checkboxes allow for manually adding custom metadata?  I use Emby, which will show the Rotten Tomatoes score if there is a <criticrating> tag.  Emby can scrape the RT score for Movies, but if you want them for TV Shows, they have to be manually added.  I would love to be able to add this to the NFO using EMM.  Will this be possible?

Thanks again for all the effort you've put in over the years!
The "Custom" checkboxes are for the 4 custom markings you (already) can set via context menu. But yes, you can add any custom rating in the rating list. I also try to add OMDb as scraper because they provide RT ratings via there API.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23