Kodi Community Forum

Full Version: The Movie DB Tv shows not connecting to server (from China)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have libreelec, running kodi 17.6 and for the past week The movie database TV Scraper has been unable to connect to server (the movies scan fine). I live in China, is the TV shows server being blocked? I've got the latest version of the scraper add on installed and even tried using the previous version, but with no success. It just says that it cannot connect to server.

I can't use other scrapers as these appear to scan after The movie database one which refuses to connect and I have to manually skip each tv program it can't scan. I also can't disable the movie database in the scanner settings.

Any advice?
@jonbennison

We wouldn't know what is being blocked in China. It won't be blocked at TheMovieDB end.

Provide a Debug Log which captures you trying to scrape a few tv shows and we should be able to confirm whether it is blocked (unlikely) or you have another issue which you are misidentifying as being blocked.
(2020-03-01, 08:12)Karellen Wrote: [ -> ]@jonbennison

We wouldn't know what is being blocked in China. It won't be blocked at TheMovieDB end.

Provide a Debug Log which captures you trying to scrape a few tv shows and we should be able to confirm whether it is blocked (unlikely) or you have another issue which you are misidentifying as being blocked.
Is there a way I can test if China is blocking access to the TV Shows server?  Is there a link I can try?
Debug Log is below:
http://ix.io/2d4y
Thanks.

There are so many problems in your setup that frankly I don't know where to start.

But you did not enable debug mode, so I don't have the full picture. Please read the Debug Log guide again and follow each of the 4 steps exactly.

Also, it will be advantageous if you read some of the wiki links in My Signature below
(2020-03-01, 10:19)Karellen Wrote: [ -> ]Thanks.

There are so many problems in your setup that frankly I don't know where to start.

But you did not enable debug mode, so I don't have the full picture. Please read the Debug Log guide again and follow each of the 4 steps exactly.

Also, it will be advantageous if you read some of the wiki links in My Signature below
Thanks, but everything else is working find on the system aside from a album artwork in iTunes, which doesn't scan, so it generates an error. Nothing else is wrong with the functionality as I'm not sure what all the problems are. Anyway, here is a a log with debug mode on

http://ix.io/2d4p
No idea what that is but definitely not a log.

Don't know what you are trying to do with album artwork in itunes. There is no connection between itunes and Kodi music libraries.
(2020-03-01, 11:45)Karellen Wrote: [ -> ]No idea what that is but definitely not a log.

Don't know what you are trying to do with album artwork in itunes. There is no connection between itunes and Kodi music libraries.

It's probably because it's a log generated through LibreEle OS? Regarding itunes: Kodi is reading my iTunes library over NFS, I don't use the kodi music library for storing my MP3s.
(2020-03-01, 07:59)jonbennison Wrote: [ -> ]I have libreelec, running kodi 17.6 and for the past week The movie database TV Scraper has been unable to connect to server (the movies scan fine). I live in China, is the TV shows server being blocked? I've got the latest version of the scraper add on installed and even tried using the previous version, but with no success. It just says that it cannot connect to server.

I can't use other scrapers as these appear to scan after The movie database one which refuses to connect and I have to manually skip each tv program it can't scan. I also can't disable the movie database in the scanner settings.

Any advice?
I have the same problem in China. Then I did some experiments and I'm sure the issue is caused by api.themoviedb.org blocked in China. So either changing the scraper or using a proxy will be the solution to this.
(2020-03-04, 17:07)hwy10 Wrote: [ -> ]
(2020-03-01, 07:59)jonbennison Wrote: [ -> ]I have libreelec, running kodi 17.6 and for the past week The movie database TV Scraper has been unable to connect to server (the movies scan fine). I live in China, is the TV shows server being blocked? I've got the latest version of the scraper add on installed and even tried using the previous version, but with no success. It just says that it cannot connect to server.

I can't use other scrapers as these appear to scan after The movie database one which refuses to connect and I have to manually skip each tv program it can't scan. I also can't disable the movie database in the scanner settings.

Any advice?
I have the same problem in China. Then I did some experiments and I'm sure the issue is caused by api.themoviedb.org blocked in China. So either changing the scraper or using a proxy will be the solution to this. 
I have come to the same conclusion now also. I can't deactivate themoviedb the scraper in LibreELEC and I don't think I can use my shadowsocks VPN as a proxy can I? I even tried using my phone as a hotspot (with my shadowssocks on) but kodi just stuck at preparing/
I've tried using Quasar add on that uses Socks5, but that wouldn't install. So I still need to find a way to install shadowsocks on LibreELEC. Is it possible to run the Linux version of the shadowsocks program maybe?
Quasar is a banned addon (wiki) here due to its use of illegal media sources.

As per our forum rules (wiki), please do not discuss or refer to it (or anything else on that list) here.