Kodi Community Forum

Full Version: How can I display UK certifications
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi Everyone,

I'm using Aeon Nox: Silvo 7.0.9 on Kodi 18.7 Leia.

I'm in the UK, and whenever I look at the information for a movie, the certification says NR.

How can O change this to show UK/GB certifications?

Thanks
(2020-06-06, 14:39)daminator Wrote: [ -> ]How can O change this to show UK/GB certifications?
The skin is looking for the following format for ratings data
UK:U
UK:PG
UK:12A
UK:12
UK:15
UK:18

In your scraper settings, have you set UK for ratings?
(2020-06-06, 19:18)Karellen Wrote: [ -> ]
(2020-06-06, 14:39)daminator Wrote: [ -> ]How can O change this to show UK/GB certifications?
The skin is looking for the following format for ratings data
UK:U
UKTongueG
UK:12A
UK:12
UK:15
UK:18

In your scraper settings, have you set UK for ratings?

Hi Karellen,

Thanks for replying.

I wasn't sure where the scraping was happening, as Kodi is acting as a frontend for media that's connected to a Jellyfin backend. I wasn't sure if the ratings were set by Jellyfin or Kodi, but I know that they have looked fine in other skins.

I just edited the settings in the TMDB scraper, so that it's now using 'gb' (uk wasn't an option in there).

The info screens are still saying NR.

Do I need to refresh something to get new info from TMDB scraper?

Or could this be something to do with me using a Jellyfin backend? As I mentioned, the ratings have shown fine in some other skins.

Thanks
Changing the settings in the scraper will not change what is already in your library. It only affects new items you add to the library.

I have no idea with jellyfin and the type of setup you have. Is jellyfin just hosting the files or is it also supplying metadata?

If Kodi is scraping the metadata, try to Refresh a movie and check for correct rating.
It looks like my data is coming in for the correct country, but it's formatted differently.

It's in the format "GB-12A" etc.

Is there any way to make the skin recognise this format? It works fine in some other skins, but I want to use this one! :-)
(2020-06-07, 01:45)daminator Wrote: [ -> ]It looks like my data is coming in for the correct country, but it's formatted differently.
Strange. Does the scraper save it as "GB-12A"?

(2020-06-07, 01:45)daminator Wrote: [ -> ]Is there any way to make the skin recognise this format?
Yes. There are two methods...

1. Edit the skin files. Dont know what platform you are using but if it is Windows, it is located here... C:\Users\<username>\AppData\Roaming\Kodi\addons\skin.aeon.nox.silvo\16x9
Open the file Variables.xml and then search for UK:12A and you will see something like this...
<value condition="String.IsEqual(ListItem.MPAA,UK:12A) | String.IsEqual(ListItem.MPAA,United Kingdom:12A)">BBFC_12A_Certificate_UK.png</value>
Change the first UK:12A to your format. Nothing else on that line needs changing. Do that for each of your ratings, should be easy to spot as they are all grouped together. This occurs 4 times for each rating in the file.

2. Edit the database to change the values to your required format. But if you say it works in other skins, it will break the rating display in those skins (and probably make it work in other skins)

Whichever method you use, create a backup of the file before making any changes.
Thanks for this Karellen. I'll try it out as soon as I'm back on the main family computer.

I think that narrowed down that Jellyfin is not the cause of the problem.

On a different PC, on a fresh Kodi, I just added some moves directly.

When I looked at them, they also said NR for the parental rating.

Hopefully, changing "UK:" to "GB-" in the skin setting will sort things out.

Fingers crossed.
(2020-06-07, 02:31)Karellen Wrote: [ -> ]1. Edit the skin files. Dont know what platform you are using but if it is Windows, it is located here... C:\Users\<username>\AppData\Roaming\Kodi\addons\skin.aeon.nox.silvo\16x9
Open the file Variables.xml and then search for UK:12A and you will see something like this...
<value condition="String.IsEqual(ListItem.MPAA,UK:12A) | String.IsEqual(ListItem.MPAA,United Kingdom:12A)">BBFC_12A_Certificate_UK.png</value>
Change the first UK:12A to your format. Nothing else on that line needs changing. Do that for each of your ratings, should be easy to spot as they are all grouped together. This occurs 4 times for each rating in the file.
It worked! :-)

Thanks Karellen. I just did your first method. Replaced all "UK:"s with "GB-"s. Restarted Kodi, and now it all works great.

Thanks again,
Damian
Great to hear. I'll mark this solved.

Thread marked solved.
I know this has been marked as solved but I cannot get this to work at all.

I've edited the variables.xml to the suggested "GB-" and also tried "GB:" but am getting a mixture of NR and German ratings displayed.

I have checked I am getting the GB rating from the TMDB and it is set to use the GB format.

Can anyone help?

TIA
@Jbev01

Please zip up your MyVideos database, upload it to a file hosting site and post the link. You can PM me the link if you want it to remain private.
(2020-06-21, 20:55)Karellen Wrote: [ -> ]@Jbev01

Please zip up your MyVideos database, upload it to a file hosting site and post the link. You can PM me the link if you want it to remain private.

@Karellen 

PM sent.

Many thanks
@Jbev01

Ok, had a quick look.

You have 118 movies that do not have a Certification. They are listed here... https://paste.kodi.tv/ehawazowog

Your certifications are using the Rated (with a space) format as shown in the image. So you changing the prefix to GB stopped it from working at all. Whatever you changed, change it back to Rated (with a space after the word)

Image

I'll check tomorrow for your reply.
@Karellen 

Sorry for taking so long to get back.

Thanks for taking a look.  I changed it back and still no luck.

I think i'm going to give up on this one as I don't seem to be able to get i work.  Maybe one day......

ATB
(2020-07-02, 17:56)Jbev01 Wrote: [ -> ]Thanks for taking a look.  I changed it back and still no luck.
Which skin are you using?
Pages: 1 2