Kodi Community Forum

Full Version: Stumped on MPAA inconsistency
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi!  

Some movies seem to scrape just fine for the MPAA rating:

https://i.imgur.com/U5hrAqL.jpg

^See here, two places it says PG-13, one being the icon top right corner.

Then it also shows that rating under it's icon info:

https://i.imgur.com/wr2cEKJ.jpg

All above is correct and goes for almost all movies.  Except this weirdness in about 50 movies in my library:

Shows two different ratings:

https://i.imgur.com/5jP69md.jpg

That shows Casino with an R rating in the info, but the icon of NR.

In the icon list it shows no rating:

https://i.imgur.com/FRyfRgg.jpg


Here's my settings:

https://i.imgur.com/bS9rQ3n.jpg
https://i.imgur.com/D8AxQAM.jpg
Which skin are you using?

I think it is Amber, and I just went through the same issue with another member here... https://forum.kodi.tv/showthread.php?tid=355112
(2020-06-14, 06:09)Karellen Wrote: [ -> ]Which skin are you using?

I think it is Amber, and I just went through the same issue with another member here... https://forum.kodi.tv/showthread.php?tid=355112

Hi!  We're the same dude.  It is Amber.  I thought I'd post here though, since it may be a scraper issue.
a-ha, thats why the screenshots looked so familiar.

Nope, it wouldn't be a scraper issue. The scraper only scrapes one rating per movie, and there is only provision for one rating in the database, so its not possible to have two different ratings scraped.

It will be a skin issue. Maybe when you adjusted the skin xml file, you made a blooper on one of your edits? If not, then this will be a question for bsoriano, as he will be more familiar with the skin than I am.

+edit +
Sorry, realised there were no skin edits. You just changed the prefix
Are the affected movies all one particular rating?
(2020-06-14, 06:22)Karellen Wrote: [ -> ]Are the affected movies all one particular rating?

Yeah, I haven't made any edits to anything yet.

Different ratings.

For example:

99 Homes:  Rated R
Arrival:  Rated PG-13

All show NR icon in the top right of video view, and of course, subsequently show no rating in the icon/list view.
Had a look at the skin file again and it seems there are some helper add-ons in use - possibly Embuary and/or themoviedb.helper.

At a guess I would say that one rating comes from your database, the other comes from one of the skin helper addons. I don't know which is which.

zip up your database and upload it and PM me the link. Then also tell me the name of 5 movies with the issue and I will check what the database entry holds. Unless you know your way around SQL DB, then you can do it.

I'll move you back to Amber forum, so @bsoriano can help out.
Thanks @Litcube I received the databases. I should have been more specific, I only need the MyVideos116.db, so you know for next time.

You have 115 movies that do not have a rating recorded in the database. The list of these movies is here... https://paste.kodi.tv/wojanixipo

Can you check some of these to confirm they match up with your certification display problem.
You also have two tv shows that do not have a rating- Dirty Money and Nazi Secret Files.

You also have a blank tv show for some reason. Enable setting 3.6- Show empty TV shows here... https://kodi.wiki/view/Settings/Media/Videos then browse through your library until you see a blank entry and delete it. Looks like a scrape gone bad.
(2020-06-14, 07:09)Karellen Wrote: [ -> ]You also have two tv shows that do not have a rating- Dirty Money and Nazi Secret Files.

You also have a blank tv show for some reason. Enable setting 3.6- Show empty TV shows here... https://kodi.wiki/view/Settings/Media/Videos then browse through your library until you see a blank entry and delete it. Looks like a scrape gone bad.

Yup!  That's the list of wonky movies.  So there's two sources for the MPAA, one seems to work and the other sucks?  Is that the just of it?  All the movies in that list have a correctly scraped rating within the "info".

EDIT:  Thank you for the tip on the TV shows!
ok, so not really a skin issue but a scraping issue for some reason. (i'll move you back up to scraping)

The simple fix would be to Refresh those movies. Or an even simpler fix is edit the database and add the ratings. Up to you which way you want to proceed.

(2020-06-14, 07:29)Litcube Wrote: [ -> ]So there's two sources for the MPAA, one seems to work and the other sucks?
The scraper should have picked up the ratings, but no idea why it did not. Very unusual. Maybe a bad setting in your scraper to start off with?

Some skins use a helper addon to provide additional movie information, like actors biography, movie cost and revenue figures etc, and Certification is some of the additional info provided. Not all skins use this helper addon, and most likely the addon kicks in when the data is missing from your library.
(2020-06-14, 07:35)Karellen Wrote: [ -> ]ok, so not really a skin issue but a scraping issue for some reason. (i'll move you back up to scraping)

The simple fix would be to Refresh those movies. Or an even simpler fix is edit the database and add the ratings. Up to you which way you want to proceed.
(2020-06-14, 07:29)Litcube Wrote: [ -> ]So there's two sources for the MPAA, one seems to work and the other sucks?
The scraper should have picked up the ratings, but no idea why it did not. Very unusual. Maybe a bad setting in your scraper to start off with?

Some skins use a helper addon to provide additional movie information, like actors biography, movie cost and revenue figures etc, and Certification is some of the additional info provided. Not all skins use this helper addon, and most likely the addon kicks in when the data is missing from your library.

I did try refreshing the movies.  It does not fix the issue.

I actually kinda think you were right originally.  If the scraper is correctly getting the rating in the video info, why is it showing NR in two other places? (i.e.:  Ghost story correctly shows RATED R, but NR in top right and no rating on the list).

Just refreshed:
https://i.imgur.com/LDohBMx.jpg
The NR icon is the fallback for missing icons.

hmmm, I think you found a bug in the scraper, or maybe something changed at TheMovieDB. I used your database in my test setup and was able to confirm that certifications were not being updated.

Using Casino as the example (have also checked with Arrival) the release information for the movie is listed in the image...
Image

There are three US release entries, but only one release entry has a certification, and it happens to be the last one, so the scraper is being fed the Release Information from TheMovieDB API in the order shown in the image, and as can be seen in the API result... https://api.tmdb.org/3/movie/tt0112641/r...5d3e3e0468 the scraper sees the first entry which is a blank certification and enters a null value in the database.

This seems to affect both Universal Movie Scraper and TheMovieDB scraper. Maybe @olympia can check?

I then tested with the new Python scraper and certifications were scraped correctly. Can you...
1. Go to Settings>Install from Repository>Information Providers>Movie information and
2. Install The Movie Database Python
3. Then enter the scraper settings from your current location and adjust your scraper settings. (adjusting from here, sets the default, so you don't have to keep changing them at the Source level)
4. Go to your Source and change to this scraper
5. Refresh your movies

Does it work now?
(2020-06-14, 08:15)Karellen Wrote: [ -> ]I then tested with the new Python scraper and certifications were scraped correctly. Can you...
1. Go to Settings>Install from Repository>Information Providers>Movie information and
2. Install The Movie Database Python
3. Then enter the scraper settings from your current location and adjust your scraper settings. (adjusting from here, sets the default, so you don't have to keep changing them at the Source level)
4. Go to your Source and change to this scraper
5. Refresh your movies

Does it work now?

Dude, you are thorough!

It seems to have reduced my NR down to about 20.

https://i.imgur.com/VUrbRqL.jpg


That screenshot shows my movies sorted by MPAA, with NR at the top.  Wild Bill is the last one, then starts the G titles starting with Elephant.

I have a suspicion that these are correct!  There's no rating for Cheap Thrills in TMDB.  

What is this python version.  Is it old or newer?
(2020-06-14, 08:56)Litcube Wrote: [ -> ]It seems to have reduced my NR down to about 20.
Great. Glad it worked!! Hopefully olympia will be able to fix the bug you found. He is the developer for both Universal Movie Scraper and TheMovieDB.

(2020-06-14, 08:56)Litcube Wrote: [ -> ]What is this python version.  Is it old or newer?
New. Officially released a few weeks ago, but I have been testing for the last year, and it has been rock solid. Scrapers are being moved away from XML based to Python based. There is also a TVDB Python scraper added to the repo a few days ago. I think in the repo it is called TVDB (New), but it works on v19 only.
Pages: 1 2