Kodi Community Forum

Full Version: Kodi loses audio passthrough settings
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have tried a lot but couldn't find the trick.
Usually when passthrough is set in Kodi (18.7) my AVR shows the corresponding audio format that is passed through. That's gone now, I don't know why, I didn't change anything.
I tried to switch passthrough on and off, restarted everything, tried WASAPI and DirectX, switched all the formats my AVR is capable of on and off. Nothing helped. AVR only shows Multi In, no matter which format is coming in, means Kodi sends a bitstream I believe.
I can start VLC as external player from within Kodi, everything is fine. Also my test Kodi 19 works like intended. With the same settings as 18. The AVR shows DD+ if played.

So what is it that I can do to fix this?


Update: I found the answer here:
https://forum.kodi.tv/showthread.php?tid=350056
It's the player setting to sync with the monitors frame rate that prevents passthrough.
It is actually written as a footnote in the settings. But I didn't see that.
If you enabled Sync playback to display, it will disable audio passthrough. See here... https://kodi.wiki/view/Settings/Player/V...to_display
(2020-07-09, 05:40)Karellen Wrote: [ -> ]If you enabled Sync playback to display, it will disable audio passthrough. See here... https://kodi.wiki/view/Settings/Player/V...to_display

This answer solved my passthrough issue that seemed to be something completely unrelated to any video settings. I feel inadequate for not having searched the forum sooner. Thanks for the tip!