Kodi Community Forum

Full Version: Titan BINGIE MOD v1 (UPDATED - 07/24/2020)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2020-12-22, 12:12)HugoL Wrote: [ -> ]
(2020-12-07, 21:51)HugoL Wrote: [ -> ]
(2020-12-07, 21:04)mjeshurun Wrote: [ -> ]Hi @HugoL , many thanks for replying ūüôŹ
Other than Bingie and Bingie MOD, I also installed Estuary Leia Mod, Amber and AppTV skins, but I deleted Amber and AppTV.

Ok. In either bingie skin, reset menus to skin default by going

skin settings > configure shortcuts > restore menu items.

Also do the below option > Restore Default Widgets in Hubs.

And for good measure, go to

Back up and restore > Reset the skin to default settings.

Failing this, you can try a fresh Kodi and bingie install. Bingie 1.03 for the dependencies and then the bingie mod 1.09 skin.
@mjeshurun 

Please read the steps again.  Note that the last option is a fresh Kodi install, not just a fresh bingie install.

I've followed the steps you mentioned (except for "Restore Default Widgets in Hubs" which I didn't find), the steps didn't help solve the black screen problem or the Skin Helper Service/Skin Helper Service Backgrounds error messages.

I then tried to remove kodi completely using these commands in terminal:
Code:
sudo apt-get remove kodi*
sudo apt-get purge kodi*

Then I rebooted the Raspberry Pi and tried to install kodi again using these commands: 
Code:
sudo apt-get install kodi
sudo apt-get install kodi-pvr-iptvsimple

However, once I started kodi, it was not a "fresh" install and all my previous configurations were still there. 

I'm obviously doing something wrong, I just don't know what Sad
(2020-12-22, 16:08)mjeshurun Wrote: [ -> ]
(2020-12-22, 12:12)HugoL Wrote: [ -> ]
(2020-12-07, 21:51)HugoL Wrote: [ -> ]Ok. In either bingie skin, reset menus to skin default by going

skin settings > configure shortcuts > restore menu items.

Also do the below option > Restore Default Widgets in Hubs.

And for good measure, go to

Back up and restore > Reset the skin to default settings.

Failing this, you can try a fresh Kodi and bingie install. Bingie 1.03 for the dependencies and then the bingie mod 1.09 skin.
@mjeshurun 

Please read the steps again.  Note that the last option is a fresh Kodi install, not just a fresh bingie install.

I've followed the steps you mentioned (except for "Restore Default Widgets in Hubs" which I didn't find), the steps didn't help solve the black screen problem or the Skin Helper Service/Skin Helper Service Backgrounds error messages.

I then tried to remove kodi completely using these commands in terminal:
Code:
sudo apt-get remove kodi*
sudo apt-get purge kodi*

Then I rebooted the Raspberry Pi and tried to install kodi again using these commands: 
Code:
sudo apt-get install kodi
sudo apt-get install kodi-pvr-iptvsimple

However, once I started kodi, it was not a "fresh" install and all my previous configurations were still there. 

I'm obviously doing something wrong, I just don't know what Sad

try deleting kodi then run the commands

sudo apt-get clean
and 
sudo apt-get autoremove -y
(2020-12-22, 16:08)mjeshurun Wrote: [ -> ]
(2020-12-22, 12:12)HugoL Wrote: [ -> ]
(2020-12-07, 21:51)HugoL Wrote: [ -> ]Ok. In either bingie skin, reset menus to skin default by going

skin settings > configure shortcuts > restore menu items.

Also do the below option > Restore Default Widgets in Hubs.

And for good measure, go to

Back up and restore > Reset the skin to default settings.

Failing this, you can try a fresh Kodi and bingie install. Bingie 1.03 for the dependencies and then the bingie mod 1.09 skin.
@mjeshurun 

Please read the steps again.  Note that the last option is a fresh Kodi install, not just a fresh bingie install.

I've followed the steps you mentioned (except for "Restore Default Widgets in Hubs" which I didn't find), the steps didn't help solve the black screen problem or the Skin Helper Service/Skin Helper Service Backgrounds error messages.

I then tried to remove kodi completely using these commands in terminal:
Code:
sudo apt-get remove kodi*
sudo apt-get purge kodi*

Then I rebooted the Raspberry Pi and tried to install kodi again using these commands: 
Code:
sudo apt-get install kodi
sudo apt-get install kodi-pvr-iptvsimple

However, once I started kodi, it was not a "fresh" install and all my previous configurations were still there. 

I'm obviously doing something wrong, I just don't know what Sad

No idea about raspberry Pi’s I’m afraid but you will need to get rid of the user data folder.
(2020-12-22, 16:20)cscott1 Wrote: [ -> ]
(2020-12-22, 16:08)mjeshurun Wrote: [ -> ]
(2020-12-22, 12:12)HugoL Wrote: [ -> ]@mjeshurun 

Please read the steps again.  Note that the last option is a fresh Kodi install, not just a fresh bingie install.

I've followed the steps you mentioned (except for "Restore Default Widgets in Hubs" which I didn't find), the steps didn't help solve the black screen problem or the Skin Helper Service/Skin Helper Service Backgrounds error messages.

I then tried to remove kodi completely using these commands in terminal:
Code:
sudo apt-get remove kodi*
sudo apt-get purge kodi*

Then I rebooted the Raspberry Pi and tried to install kodi again using these commands: 
Code:
sudo apt-get install kodi
sudo apt-get install kodi-pvr-iptvsimple

However, once I started kodi, it was not a "fresh" install and all my previous configurations were still there. 

I'm obviously doing something wrong, I just don't know what Sad

try deleting kodi then run the commands

sudo apt-get clean
and 
sudo apt-get autoremove -y
mjeshurun give this a read

https://raspberrytips.com/uninstall-prog...pberry-pi/
(2020-12-22, 16:25)HugoL Wrote: [ -> ]
(2020-12-22, 16:08)mjeshurun Wrote: [ -> ]
(2020-12-22, 12:12)HugoL Wrote: [ -> ]@mjeshurun 

Please read the steps again.  Note that the last option is a fresh Kodi install, not just a fresh bingie install.

I've followed the steps you mentioned (except for "Restore Default Widgets in Hubs" which I didn't find), the steps didn't help solve the black screen problem or the Skin Helper Service/Skin Helper Service Backgrounds error messages.

I then tried to remove kodi completely using these commands in terminal:
Code:
sudo apt-get remove kodi*
sudo apt-get purge kodi*

Then I rebooted the Raspberry Pi and tried to install kodi again using these commands: 
Code:
sudo apt-get install kodi
sudo apt-get install kodi-pvr-iptvsimple

However, once I started kodi, it was not a "fresh" install and all my previous configurations were still there. 

I'm obviously doing something wrong, I just don't know what Sad

No idea about raspberry Pi’s I’m afraid but you will need to get rid of the user data folder.
Have you tried to delete ~/.kodi/userdata/ ?
Can anyone please give me a heads-up on how I can set up imdb ratings for other addons scraped from tmdb not from universal movie scrapers.Please just one hint or tip ūüôŹ
(2020-12-22, 20:29)knowellnoel Wrote: [ -> ]Can anyone please give me a heads-up on how I can set up imdb ratings for other addons scraped from tmdb not from universal movie scrapers.Please just one hint or tip ūüôŹ
Ratings Meta (and API keys in general)
For ratings from IMDB, TMDB, TVDB, Rotten Tomatoes and Metacritic
1) Make sure they are enabled in 'Media Library Views' tab under 'Media Flags, Ratings ......' (they should be ON by default)
2) To enable them in BINGIE views, go to homelayout tab and enable them under 'Footer' header (tick OFF the setting 'Disable ratings flags in bingie views...')
To enable them in libraries, in 'Media Library Views' tab, tick off the setting 'Do not show footer in views'
3) [THIS IS DONE PRIOR TO LIBRARY SCAN] Use scrapers and set in there settings to get ratings from IMDB & TMDB for movies (e.g Universal scraper). and TVDB & IMDB for tv shows (e.g TVDB Scraper).
4) Go to Skin Settings -> Supported addons -> select 'Metadata and Artwork Module', switch to 'API Keys' tab, and fill with your API keys.
For Rottern Tomatoes & MetaCritic you'll need to have an OMDB key - you can get it from here https://www.omdbapi.com/apikey.aspx
for TMDB Key - www.themoviedb.org
Fanart key is not important for ratings but is for fanart images in the skin, get from https://fanart.tv/

also read this https://forum.kodi.tv/showthread.php?tid...pid2994648
(2020-12-22, 19:46)redglory Wrote: [ -> ]
(2020-12-22, 16:25)HugoL Wrote: [ -> ]
(2020-12-22, 16:08)mjeshurun Wrote: [ -> ]I've followed the steps you mentioned (except for "Restore Default Widgets in Hubs" which I didn't find), the steps didn't help solve the black screen problem or the Skin Helper Service/Skin Helper Service Backgrounds error messages.

I then tried to remove kodi completely using these commands in terminal:
Code:
sudo apt-get remove kodi*
sudo apt-get purge kodi*

Then I rebooted the Raspberry Pi and tried to install kodi again using these commands: 
Code:
sudo apt-get install kodi
sudo apt-get install kodi-pvr-iptvsimple

However, once I started kodi, it was not a "fresh" install and all my previous configurations were still there. 

I'm obviously doing something wrong, I just don't know what Sad

No idea about raspberry Pi’s I’m afraid but you will need to get rid of the user data folder.
Have you tried to delete ~/.kodi/userdata/ ?

Here is a brief overview of all the steps I took and the results.

I started by deleting kodi using these two commands:
Code:
sudo apt-get remove kodi*
and
Code:
sudo apt-get purge kodi*

Then I followed @cscott1 's suggestion running these two commands:
Code:
sudo apt-get clean
and
Code:
sudo apt-get autoremove -y

After running the four commands, I followed @redglory 's suggestion to manually delete the
Code:
~/.kodi/userdata/
  folder, and I actually took a step further and deleted all files and folders within the main ~/.kodi folder. 

After completing all the deletion steps, I rebooted the Raspberry Pi and conducted a fresh Kodi install using the commands:
Code:
sudo apt-get install kodi
sudo apt-get install kodi-pvr-iptvsimple

Kodi started as a fresh install with no addons and in the default settings. 
However, once I reinstalled the original Bingie skin, the Skin Helper Service/Skin Helper Service Backgrounds error messages returned and when I tried to use the skin it showed the black screen. 

So out of all this, I'm assuming the problem lies in the installation of the original Bingie skin on Raspberry Pi. I'm guessing this is the problem's, because the problem is happening even before installing the Bingie MOD skin, which is dependent on the original Bingie skin.
(2020-12-23, 02:42)mjeshurun Wrote: [ -> ]
(2020-12-22, 19:46)redglory Wrote: [ -> ]
(2020-12-22, 16:25)HugoL Wrote: [ -> ]No idea about raspberry Pi’s I’m afraid but you will need to get rid of the user data folder.
Have you tried to delete ~/.kodi/userdata/ ?

Here is a brief overview of all the steps I took and the results.

I started by deleting kodi using these two commands:
Code:
sudo apt-get remove kodi*
and
Code:
sudo apt-get purge kodi*

Then I followed @cscott1 's suggestion running these two commands:
Code:
sudo apt-get clean
and
Code:
sudo apt-get autoremove -y

After running the four commands, I followed @redglory 's suggestion to manually delete the
Code:
~/.kodi/userdata/
  folder, and I actually took a step further and deleted all files and folders within the main ~/.kodi folder. 

After completing all the deletion steps, I rebooted the Raspberry Pi and conducted a fresh Kodi install using the commands:
Code:
sudo apt-get install kodi
sudo apt-get install kodi-pvr-iptvsimple

Kodi started as a fresh install with no addons and in the default settings. 
However, once I reinstalled the original Bingie skin, the Skin Helper Service/Skin Helper Service Backgrounds error messages returned and when I tried to use the skin it showed the black screen. 

So out of all this, I'm assuming the problem lies in the installation of the original Bingie skin on Raspberry Pi. I'm guessing this is the problem's, because the problem is happening even before installing the Bingie MOD skin, which is dependent on the original Bingie skin.

Did you try the cheat I suggested setting up Kodi and Bingie up on PC then copying the addon and userdata files to your ras. Pie kodi folder? I mean sometimes the round about way of doing things is the best way as long as it works in the end it doesn't matter how you got there.

In Windows this is where the files are located
Users/your username/AppData/Roaming/Kodi
(2020-12-23, 04:06)cscott1 Wrote: [ -> ]
(2020-12-23, 02:42)mjeshurun Wrote: [ -> ]
(2020-12-22, 19:46)redglory Wrote: [ -> ]Have you tried to delete ~/.kodi/userdata/ ?

Here is a brief overview of all the steps I took and the results.

I started by deleting kodi using these two commands:
Code:
sudo apt-get remove kodi*
and
Code:
sudo apt-get purge kodi*

Then I followed @cscott1 's suggestion running these two commands:
Code:
sudo apt-get clean
and
Code:
sudo apt-get autoremove -y

After running the four commands, I followed @redglory 's suggestion to manually delete the
Code:
~/.kodi/userdata/
  folder, and I actually took a step further and deleted all files and folders within the main ~/.kodi folder. 

After completing all the deletion steps, I rebooted the Raspberry Pi and conducted a fresh Kodi install using the commands:
Code:
sudo apt-get install kodi
sudo apt-get install kodi-pvr-iptvsimple

Kodi started as a fresh install with no addons and in the default settings. 
However, once I reinstalled the original Bingie skin, the Skin Helper Service/Skin Helper Service Backgrounds error messages returned and when I tried to use the skin it showed the black screen. 

So out of all this, I'm assuming the problem lies in the installation of the original Bingie skin on Raspberry Pi. I'm guessing this is the problem's, because the problem is happening even before installing the Bingie MOD skin, which is dependent on the original Bingie skin.

Did you try the cheat I suggested setting up Kodi and Bingie up on PC then copying the addon and userdata files to your ras. Pie kodi folder? I mean sometimes the round about way of doing things is the best way as long as it works in the end it doesn't matter how you got there.

In Windows this is where the files are located
Users/your username/AppData/Roaming/Kodi

Thanks for the tip, @cscott1 !
Copying the addons and userdata folders from my mac to my Raspberry Pi kodi folder actually helped and I no longer have the black screen Smile
However, I'm getting a Skin Helper Service Widgets error.
(2020-12-23, 09:23)mjeshurun Wrote: [ -> ]
(2020-12-23, 04:06)cscott1 Wrote: [ -> ]
(2020-12-23, 02:42)mjeshurun Wrote: [ -> ]Here is a brief overview of all the steps I took and the results.

I started by deleting kodi using these two commands:
Code:
sudo apt-get remove kodi*
and
Code:
sudo apt-get purge kodi*

Then I followed @cscott1 's suggestion running these two commands:
Code:
sudo apt-get clean
and
Code:
sudo apt-get autoremove -y

After running the four commands, I followed @redglory 's suggestion to manually delete the
Code:
~/.kodi/userdata/
  folder, and I actually took a step further and deleted all files and folders within the main ~/.kodi folder. 

After completing all the deletion steps, I rebooted the Raspberry Pi and conducted a fresh Kodi install using the commands:
Code:
sudo apt-get install kodi
sudo apt-get install kodi-pvr-iptvsimple

Kodi started as a fresh install with no addons and in the default settings. 
However, once I reinstalled the original Bingie skin, the Skin Helper Service/Skin Helper Service Backgrounds error messages returned and when I tried to use the skin it showed the black screen. 

So out of all this, I'm assuming the problem lies in the installation of the original Bingie skin on Raspberry Pi. I'm guessing this is the problem's, because the problem is happening even before installing the Bingie MOD skin, which is dependent on the original Bingie skin.

Did you try the cheat I suggested setting up Kodi and Bingie up on PC then copying the addon and userdata files to your ras. Pie kodi folder? I mean sometimes the round about way of doing things is the best way as long as it works in the end it doesn't matter how you got there.

In Windows this is where the files are located
Users/your username/AppData/Roaming/Kodi

Thanks for the tip, @cscott1 !
Copying the addons and userdata folders from my mac to my Raspberry Pi kodi folder actually helped and I no longer have the black screen Smile
However, I'm getting a Skin Helper Service Widgets error.

Try installing this version of the cherrypy module see if it helps.

https://github.com/AnonTester/script.module.cherrypy

also posting a log of the error might help
Does anyone else get the wrong episode show in their next up sometimes? Like it goes one episode ahead, I can fix by going into more episodes then marking the correct one as watched then unpatched but I would like to have it update correctly or maybe fix itself on a skin reload. Not sure if I’m the only one who faces this error tho
(2020-12-22, 21:02)cscott1 Wrote: [ -> ]
(2020-12-22, 20:29)knowellnoel Wrote: [ -> ]Can anyone please give me a heads-up on how I can set up imdb ratings for other addons scraped from tmdb not from universal movie scrapers.Please just one hint or tip ūüôŹ
Ratings Meta (and API keys in general)
For ratings from IMDB, TMDB, TVDB, Rotten Tomatoes and Metacritic
1) Make sure they are enabled in 'Media Library Views' tab under 'Media Flags, Ratings ......' (they should be ON by default)
2) To enable them in BINGIE views, go to homelayout tab and enable them under 'Footer' header (tick OFF the setting 'Disable ratings flags in bingie views...')
To enable them in libraries, in 'Media Library Views' tab, tick off the setting 'Do not show footer in views'
3) [THIS IS DONE PRIOR TO LIBRARY SCAN] Use scrapers and set in there settings to get ratings from IMDB & TMDB for movies (e.g Universal scraper). and TVDB & IMDB for tv shows (e.g TVDB Scraper).
4) Go to Skin Settings -> Supported addons -> select 'Metadata and Artwork Module', switch to 'API Keys' tab, and fill with your API keys.
For Rottern Tomatoes & MetaCritic you'll need to have an OMDB key - you can get it from here https://www.omdbapi.com/apikey.aspx
for TMDB Key - www.themoviedb.org
Fanart key is not important for ratings but is for fanart images in the skin, get from https://fanart.tv/

also read this https://forum.kodi.tv/showthread.php?tid...pid2994648

After hours of fiddling with it finally it's perfect now thank you so much man for the quick help.
By the way is there any addon that would recommend me the movies that I gave a thumbs up? if there is please do let me know.
Also I'm kind of curious guys since universal scraper is used for movies in my library so is there any way I can add other addons to be used for my library like when I add a widget and add a video addon for the movies there is no detailed description nor ratings showing so my question is with how many addons can universal scraper can be used and how can I get all the description and ratings of the movies which I have chosen from outside of my library?
(Thanks in advance)
(2020-12-24, 06:06)knowellnoel Wrote: [ -> ]Also I'm kind of curious guys since universal scraper is used for movies in my library so is there any way I can add other addons to be used for my library like when I add a widget and add a video addon for the movies there is no detailed description nor ratings showing so my question is with how many addons can universal scraper can be used and how can I get all the description and ratings of the movies which I have chosen from outside of my library?
(Thanks in advance)

From what I understand universal movie scraper is only for movies in library. Addons can’t be used for library unless u do something called library integration which can be found under different names in addon settings. TMDB helper is a great one that I used bc the addon itself lets u play with any addon u have installed such as Netflix, Disney or a direct file that u have in ur library.

Ratings, fan art and description in. Titan bingie mod from addons are addon-dependent so it depends on the addon you’re using to get help on getting plot ratings etc. tbh I just moved into library integration as many here advised and it made everything easier. If u want help for the addon ur using its better to go to r/Addons4Kodi unless it’s an official addon then ur good to mention it