Kodi Community Forum

Full Version: YouTube
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
@PureHemp 
Thanks for doing the heavy lifting, I cleaned it up a bit, made the xml requests threaded to hopefully help with loading times and added it to the in-development version. 

If anyone runs into issues with this please include a complete debug log (wiki)

I've updated post #2 and the repositories with 6.8.9~beta1 
Code:
~beta1
[fix] my subscriptions section using YouTube RSS |contrib: PureHemp|
(2020-11-28, 17:45)anxdpanic Wrote: [ -> ]@llobarrosalpa 
Without the debug log (wiki) I can only guess. Enable Settings - MPEG-DASH - Use MPEG-DASH and Settings - MPEG-DASH - Use for videos

@starslayer74 
Sorry I missed that, Settings - Maintenance - Delete access_manager.json and then re-login (not re-entering keys)

@anxdpanic  I did that.... still getting an error.... here's an updated logfile https://paste.kodi.tv/amisotedig
@starslayer74 
Still showing the same issue, that file is corrupt. You may have to shut down Kodi and manually delete userdata (wiki)/addon_data/plugin.video.youtube/access_manager.json
(2020-11-29, 05:16)anxdpanic Wrote: [ -> ]@starslayer74 
Still showing the same issue, that file is corrupt. You may have to shut down Kodi and manually delete userdata (wiki)/addon_data/plugin.video.youtube/access_manager.json

That seemed to do the trick. I think part of the problem is that I actually transferred all of my kodi data to another drive, and it must have gotten corrupted in that move. 

Now, I just need to go back over because I apparently fatfingered my api key and secret when I typed them in. 

I appreciate the assistance.
Thanks for the fix! With the parallized version i almost "feel" no difference to before, having 100 subscriptions. Pretty cool, really Wink

The only difference i see is the sorting, usally "Live" channles were listed at the beginning of the list. I am used to that, but thats a really minor thingie.

Didn't look at the implementation, so it would maybe be useful, if one of you could say how exactly the caching works. The feeds are updated only once an hour? So if i go in "My Subscriptions" at 9:00AM, and then again at 9:30AM it wont be updated? But a 10:00AM browsing in would again?

Also i noticed a lot of DNS lookups of www.youtube.com when entering "My subscriptions", so it _might_ help speeding up things using a dns-cache like pihole Wink
From me also a really big THANK YOU!
@PureHemp : very thanks to you too.
The only thing that scares me is that youtube will end up removing the rss feeds too.
You save my day !!!
(2020-11-29, 02:34)anxdpanic Wrote: [ -> ]@PureHemp 
Thanks for doing the heavy lifting, I cleaned it up a bit, made the xml requests threaded to hopefully help with loading times and added it to the in-development version. 

If anyone runs into issues with this please include a complete debug log (wiki)

I've updated post #2 and the repositories with 6.8.9~beta1 
Code:
~beta1
[fix] my subscriptions section using YouTube RSS |contrib: PureHemp|

That was indeed an update! Took the loading time down from 2 minutes to 18 seconds! Great work Smile 

Jomjom79
Thank you to @PureHemp and @anxdpanic !
Thank you to @PureHemp and @anxdpanic  Nod
(2020-11-28, 18:57)redkoatz Wrote: [ -> ]
(2020-11-28, 18:36)anxdpanic Wrote: [ -> ]@Skeeve 
Enable Settings - MPEG-DASH - Use MPEG-DASH and Settings - MPEG-DASH - Use for videos

Huh

in settings of addon youtube with session started
Can't seem to find a solution to this quota exceeded message.
I have read all the thread but not sure if someone actually fixed this?
Something for Kodi 19 early adopters; Tubed is a new add-on to access your YouTube content that is currently in beta. You'll find more information in the link.
(2020-11-29, 02:34)anxdpanic Wrote: [ -> ]@PureHemp 
Thanks for doing the heavy lifting, I cleaned it up a bit, made the xml requests threaded to hopefully help with loading times and added it to the in-development version. 

If anyone runs into issues with this please include a complete debug log (wiki)

I've updated post #2 and the repositories with 6.8.9~beta1 
Code:
~beta1
[fix] my subscriptions section using YouTube RSS |contrib: PureHemp|

Thank you @PureHemp and @anxdpanic.

I was afraid my many subscriptions would take a long time but it seems fine.

jonib
My subbed videos and recommendations are suddenly not loading, everything else seems to be fine, wonder if it's me, youtube or the addon but I'll wait a bit to see if it gets resolved