Kodi Community Forum

Full Version: YouTube
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi about half of my videos dont play.   Been reading here and see some trying the 6.8.10.    How do I know what version to use.   Im on 18.9 Lea     And thank you guys for all you do
(2021-02-18, 03:51)nycman Wrote: [ -> ]Hi about half of my videos dont play.   Been reading here and see some trying the 6.8.10.    How do I know what version to use.   Im on 18.9 Lea     And thank you guys for all you do

Install either version of 6.8.10 alpha 1 but do not use the "matrix" version. That's for Kodi 19
Can someone please show me the repo that hosts the alpha/beta versions of the addon?

---edit
Nvm, found it!
https://github.com/anxdpanic/plugin.vide...t-versions
Will this Kodi YouTube plugin running on a Vero4K give me a Viewport setting of 3840x2160, or 1920x1080x2 ?

This information is in the “stats for nerds” window, while playing a 4K stream.
(2021-02-21, 19:33)jim_p Wrote: [ -> ]Can someone please show me the repo that hosts the alpha/beta versions of the addon?

---edit
Nvm, found it!
https://github.com/anxdpanic/plugin.vide...t-versions
Hi i just installed the alpha plug in and it worked.     Which repo on that page should i use with it?
So yes...long time kodi user and can confirm that on all very different devices used for kodi (7!) had the same failure all using 18.9 Leia - a very strange one for us however...

All 'normal videos' seemed to play BUT not one video that would be classed as a 'music video' or any video that was 'music' tbh played since last week or so.

Updating to the alpha version in matrix 19 as mentioned has now allowed any music video type to work again.

thanks friends.
@nycman 
The one that is named repository.yt.testing_official-2.0.0.zip. You can install the one below that, that has "unofficial" in its name, if you want the "unofficial" version of the yoube addon.
The unofficial one allows view overrides, just that Smile
Hi,

I'm trying to get the YouTube addon working on Kodi under Enigma2.  I have an API key, but am unable to paste it in via the Kodi GUI. Is there a file which the add-on will read, if present, to start up YouTube? Presumably it is somewhere under Kodi's home directory...
You can either put them in userdata/addon_data/plugin.video.youtube/api_keys.json or in userdata/addon_data/plugin.video.youtube/settings.xml (3 variables, youtube.api.key, youtube.api.id and youtube.api.secret, self explanatory) or enable the addon's web interface from its settings and put them there. All three ways are described here
https://github.com/anxdpanic/plugin.vide...l-API-Keys

TIL that you have to restart kodi after doing the above Tongue
(2021-02-22, 12:38)jim_p Wrote: [ -> ]You can either put them in userdata/addon_data/plugin.video.youtube/api_keys.json or in userdata/addon_data/plugin.video.youtube/settings.xml (3 variables, youtube.api.key, youtube.api.id and youtube.api.secret, self explanatory) or enable the addon's web interface from its settings and put them there. All three ways are described here
https://github.com/anxdpanic/plugin.vide...l-API-Keys

TIL that you have to restart kodi after doing the above Tongue

Many thanks. Will give it a try.

And thanks for the quick response.
(2020-09-07, 19:54)anxdpanic Wrote: [ -> ]Latest stable version: 6.8.9   HOW-TO:Install add-ons from zip files (wiki)
Wiki: Installation#stable-versions
Changelog:
Code:
6.8.9
[fix] my subscriptions section using YouTube RSS |contrib: PureHemp|
[fix] items per page settings on Kodi 19
[chg] recommendations only available for users with custom history playlist id configured
[chg] no longer show watch later unless custom watch later playlist is configured
[rem] remove usage of discontinued api and dual login (no longer required)

Latest in-development version: 6.8.10-dev
Wiki: Installation#in-development-versions
Changelog:
Code:
~alpha1
[fix] fix javascript player retrieval and playback of some videos for affected users |contrib: thomazz-nl|
- Invalid URL 'http://': No host supplied
...
Thank you very much! This fix solved all my kodi-problems :-) I tried different OS and Kodi-versions til I realized, that it was a youtube-addon-problem.
@anxdpanic THANK YOU VERY MUCH
Quote:Latest in-development version: 6.8.10-dev
Wiki: Installation#in-development-versions
Changelog:
~alpha1
[fix] fix javascript player retrieval and playback of some videos for affected users |contrib: thomazz-nl|
- Invalid URL 'http://': No host supplied
...

Thanks a lot @anxdpanic and thomazz-nl for fixing the issue Smile I can confirm installing 6.8.10~alpha1 works like a charm and kodi is now playing all video's again Smile
(2021-02-22, 07:44)jim_p Wrote: [ -> ]@nycman 
The one that is named repository.yt.testing_official-2.0.0.zip. You can install the one below that, that has "unofficial" in its name, if you want the "unofficial" version of the yoube addon.
The unofficial one allows view overrides, just that Smile

thanks a lot
Hey there !
I'm still confused as to what I should do to get back the Watch Later option / playlist on my (CoreElec) Kodi 18.9 setup with the 6.8.10~Alpha 1 Youtube add-on version.
Any ideas ?
One of my systems running KODI 19.0 gets an error "YouTube Error Check log for more information". The YouTube version is 6.8.9+matrix.1 and the error is on every item I try to run. The log is at https://paste.kodi.tv/egewituwuz.
Thanks