Kodi Community Forum

Full Version: YouTube
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
The issue is solved.

I have uninstalled the addon and then I have installed it again (version 6.8.10). Now the videos that wasn't loading are loading fine without the "Invalid URL 'http://': No host supplied" error. If someone is experiencing the same error, please check that the 6.8.10 version is installed and not the alpha one.

As I suspected, the issue has nothing to do with Libreelec 8.2.5 Kodi Kripton 17.6 running on Raspberry Pi3 b+

Cheers.
I have a Youtube TV subscription which provides local sports which are otherwise blacked out. Does this Youtube add-on support this on Kodi? If so would appreciate link/instructions how to enable.
i found out that i missing some subscriptions in this addon. those subscriptions are visible on my youtube desktop
those channels are "child friendly" (COPPA)
i can found there videos by using the search...
as example; channels like Lawrence systems, jayztwocars and hacksmith vlogs are NOT visible in this addon, only by manual search i can found them, but its not always showing there latest video...
last week those channels were still visible...

did i screw something up or did google change there API againHuh
I did renew the api key...

running kodi 18.9 (OSMC) addon v6.8.10
Can someone explain how i'm supposed to set up this mythical "HTTP server" that the addon can take advantage of? Specifically, i'd like to get mpeg-dash vods working, which it seems to require HTTP server for? But the documentation for this is totally non-existent and I have no idea what I'm doing. Is this related to the web interface for Kodi as a whole? or is that a totally different thing?

Update, I needed to restart kodi it seems before it started up the server.
How to install unofficial version for matrix (Kodi 19). When I open unofficial repo from:

https://panicked.xyz/repositories/matrix...trix.1.zip

Its empty, no video addons inside?
(2021-04-24, 18:01)letac Wrote: [ -> ]How to install unofficial version for matrix (Kodi 19). When I open unofficial repo from:

https://panicked.xyz/repositories/matrix...trix.1.zip

Its empty, no video addons inside?

You install with the zip file itself. No need to open it. Click on "addons / install with zip file" in kodi
(2021-04-24, 23:58)blueribb Wrote: [ -> ]You install with the zip file itself. No need to open it. Click on "addons / install with zip file" in kodi

I already have repo installed, from zip file. When I try to install video addon from installed repository, its empty, there is no video addon section inside, just repository section:

Image
(2021-04-25, 12:50)letac Wrote: [ -> ]
(2021-04-24, 23:58)blueribb Wrote: [ -> ]You install with the zip file itself. No need to open it. Click on "addons / install with zip file" in kodi

I already have repo installed, from zip file. When I try to install video addon from installed repository, its empty, there is no video addon section inside, just repository section:

Image
What Repo ?

Here is the page that contains the latest stable versions of the YouTube Addon:

6.8.10 YouTube Addons
(2021-04-23, 23:44)sjaakNL Wrote: [ -> ]i found out that i missing some subscriptions in this addon. those subscriptions are visible on my youtube desktop
those channels are "child friendly" (COPPA)
i can found there videos by using the search...
as example; channels like Lawrence systems, jayztwocars and hacksmith vlogs are NOT visible in this addon, only by manual search i can found them, but its not always showing there latest video...
last week those channels were still visible...

did i screw something up or did google change there API againHuh
I did renew the api key...

running kodi 18.9 (OSMC) addon v6.8.10
I'm having this exact problem. I've done a little research and it appears to be exclusively channels that are marked as "made for children" that are affected.

I noticed this when going through the subscriptions in a web-browser. I could see notifications were turned off for channels that were missing, and when I tried to turn them on, a little popup appeared saying "This action is turned off for channels that are made for children".

Many of the channels affected are not specifically for children, such as Technology Connections, Techmoan, and CineFix, but the popup appears for every one of them when I attempt to turn notifications on.

There is a long list of restrictions on these channels, and my guess is that one or more of these restrictions is responsible for channels no longer appearing in the subscriptions list. More details at Watching Made for Kids content

Kodi Version: 18.9   Add-on version: 6.8.10
(2021-04-25, 14:46)blueribb Wrote: [ -> ]Here is the page that contains the latest stable versions of the YouTube Addon:
I was following instructions from post #2:

https://github.com/anxdpanic/plugin.vide...t-versions

Maybe they are obsolete now? Anyway, your link works, thank you.
Hello dudes wondered if there was a quick answer for this or if it's a known problem.

I don't know which exact build of the add-on, and Kodi exact build I have. (Although I know it's 18.9).

I'm running OSMC on an rPi2b

It used to be the case that I could share a YouTube video to my Kodi installation 'queue on Kodi'.

That still works but at some point I noticed only called up the 480p version of the clip, whereas obviously there are bountiful 1080p and beyond on there.

I've only ever installed the official YouTube add-on, but need to check which version I'm on really.

Just wondered if this is common it what can be done about it.

Kind regards.
(2021-04-25, 15:10)fr1day Wrote: [ -> ]
(2021-04-23, 23:44)sjaakNL Wrote: [ -> ]i found out that i missing some subscriptions in this addon. those subscriptions are visible on my youtube desktop
those channels are "child friendly" (COPPA)
i can found there videos by using the search...
as example; channels like Lawrence systems, jayztwocars and hacksmith vlogs are NOT visible in this addon, only by manual search i can found them, but its not always showing there latest video...
last week those channels were still visible...

did i screw something up or did google change there API againHuh
I did renew the api key...

running kodi 18.9 (OSMC) addon v6.8.10
I'm having this exact problem. I've done a little research and it appears to be exclusively channels that are marked as "made for children" that are affected.

I noticed this when going through the subscriptions in a web-browser. I could see notifications were turned off for channels that were missing, and when I tried to turn them on, a little popup appeared saying "This action is turned off for channels that are made for children".

Many of the channels affected are not specifically for children, such as Technology Connections, Techmoan, and CineFix, but the popup appears for every one of them when I attempt to turn notifications on.

There is a long list of restrictions on these channels, and my guess is that one or more of these restrictions is responsible for channels no longer appearing in the subscriptions list. More details at Watching Made for Kids content

Kodi Version: 18.9   Add-on version: 6.8.10
Can anybody offer some help or advice for this one? Is it a bug, a setting, are sjaakNL and I the only ones experiencing this issue?

I'm happy to upload any debug or other information that might help, but I'm not sure how to capture information on something that's just missing and not throwing up an error.

To recap, several channels are missing from the subscriptions view. These channels all seem to have been marked as "Made for Children" (COOPA) by YouTube.

I can watch videos from missing subscriptions by searching for them in the plugin, and I can see the subscriptions without issue when using a web browser.
Is anyone else having issues with youtube since yesterday? I get the usual 403 error all day long, so it is definitely related to the api and my keys. And the same happens with youtube-viewer (perl script for the same job, also uses the api keys to work).
(2021-05-03, 14:50)jim_p Wrote: [ -> ]Is anyone else having issues with youtube since yesterday?
Mine is working (with its usual nuances).
And again............with increasing frequency the MPEG-DASH it will become inusable on my side:

I continue to obtain this issue totally randomly and whitout any explanation.
Continue to obtain "Permanet FAILURE" whit all MPEG-DASH video or live..... look here:

https://paste.kodi.tv/ujunuyopuy.kodi


The MPEG-DASH it's at same time works perfectly for any other addons using it like twitch........... on youtube i need to disable or no video it's can be playable.

@anxdpanic or any other have some idea intervenes with some suggestions ?!?!!? Thanks in advange.......