Kodi Community Forum

Full Version: YouTube
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
No stream available:

I edited video_info.py, and the streams are intermittently successful.
Also, "My Subscriptions" list is empty since editing.

FYI, after installing an update, the commented-out lines need to be re-done (my update seemed to be the existing version (didn't know which it was before updating).

Addon 6.8.11 in Kodi 18.7 on Rpi (v. 6.8.11 is the latest update available;  I will wait and see if .14 comes up - I'm not confident in going to github and using the zip file)
Now that the video issue is resolved (thanks for the people who worked on the solution), I've noticed that not all of the channels I am subscribed to are being listed in 'Subscriptions'. It seems to be those channels where the bell icon has a cross through it because the channel is marked as having content that's made for children.

Any ideas why that might be and if there's a way to resolve it?
is everyones "My Subscriptions" updating?

EDIT: actually was on my end all is good, thank you for the fix guys.
I cant now start video after update, so new fix maybe?


Update .14 is working (for now)
Just to be sure that everyone is aware, there have been several updates/fixes in quick succession.

The latest version at the moment is v6.8.14.

Here is the official link to the latest versions. You can also download these and 'install from zip' if necessary.


I've noticed that some videos only play audio after the v6.8.14 update.
(On Kodi 18.9)
That is with MPEG-DASH enabled, with it being disabled the videos play fine.
Example videos: RQ49RlWewM0 or UHnbFSs6dlI
(Just search for above and the videos will be found, it's the video_id)

Enabling MPEG-DASH and changing video quality from 720p to Adaptive(MP4/H264) also remedy the issue.
720p and HDR enabled.
getting an error in the latest update that I've never seen before


any idea what that means?

EDIT - rebooted and the error went away
Anyone on 18.9 (or 18.x in general) that got the update to 6.8.14? As seen here, it is available from the main repo for both 18 and 19

I got the today on both my machines that run kodi 19 (libreelec x64 nightly and debian unstable x64), but not on the ones that run 18 (libreelec stable 9.2.6 on x64 and coreelec 9.2.7 on arm64). Moreover, I have anxdpanic's "YouTube Test Repo (Official)" on the stable libreelec installation, but this provides 6.8.13 right now.
And yes, I have tried force refresh on both kodi 18 systems.

I ran a second force refresh right now and the update showed up on the libreelec stable system, on both the the offical and test repos, but still nothing on coreelec.
No streams found is error that i have, i'm casting from android youtube app using yatse to kodi addon is updated to .14 version
(2021-06-18, 00:51)Doktor-X Wrote: [ -> ]No streams found is error that i have, i'm casting from android youtube app using yatse to kodi addon is updated to .14 version

Have you REBOOTED Kodi after updating to v6.8.14?
I got the updated 6.8.14 yesterday and rebooted LibreELEC.  For several hours My Subscriptions would take about 10-15 seconds to load and was empty.  Eventually it started populating and I could watch videos from my feed.  Today I have the same problem:  Searching, browsing individual channels from the Subscriptions list, and generally playing videos is basically fine, I just don't get anything in the My Subscriptions list.  Turning on debug logging doesn't show anything that looks like an error from the YouTube plugin:  kodi.log

Plenty of retries and reboots and I still don't get anything in My Subscriptions.  Anybody seen this?  I saw one post yesterday, but they said the problem was on their end, so I'm not sure what happened there.
YouTube currently plays nothing from no matter what version.

? ? ?

It affects all Movies, not just this Movie.


YouTube Videos and Subsciptions are both working for me Nod
(2021-06-18, 01:05)jmh2002 Wrote: [ -> ]Have you REBOOTED Kodi after updating to v6.8.14?

Not just rebooted, shutdown and power up multiple times, some videos working fine, but some have this anoying error and are unable to be played. Im running coreelec if this have any affect on finding problem. Tonight ill extract kodi logs when error happens again

Same problem here, i am on version 6.8.14+matrix.1

"No Streams Found" on all videos i try and play.

Best Regards