Kodi Community Forum

Full Version: YouTube
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2021-06-18, 10:24)mrpg Wrote: [ -> ]Hi,

Same problem here, i am on version 6.8.14+matrix.1

"No Streams Found" on all videos i try and play.

Best Regards
Patric
Same for me, I'm using Youtube addon 6.8.14 and Kodi 19.1 on a Ultra Chromecast. Untill two days ago my videos played just fine.
I used to play the same workout video every morning for 18 days already, but I tried other videos and they all give the 'no streams found error'
Sometimes after opening the videos and watching the commercials I was able to open the video yesterday, but today not even that worked anymore.
Seems like Google 'fixed' something again to make it unable to properly play. Hate it when they try to force people to watch their bloody ads.
Same here.
I fixed it by uninstalling Youtube addon Wink Too much hassle for something i do not use or need much.

Hope it gets a (temp) fix again for those that want to use Youtube.
Same here, I am on version 6.8.14+matrix.1 on Kodi Matrix 19.1 x64 (Windows)
& CoreElec/OpenElec boxes same issue.

Using 'NewPipe' & 'SkyTube' on Android devices and PC Android Emu with no ads if that helps friends on here! lol

apologise if cant say other apps in this thread but what they do prove is that it can be done...

Thanking devs in advance when fixes arrive.
Raspberry Pi 3 running OSMC 17.6

Subscription feed was unreliable for several days and then completely failed on 6/17/21.  Update to 6.8.14 with reboot restored the subscription feed.  Completed videos now play as before except without audio.  Other information:

1.  Audio plays normally on the Radio addon.  The DemocracyNow! addon correctly plays videos with audio, as do other video addons.  Only the YouTube addon lacks audio.

2.  Changing YouTube 6.8.14 settings to Audio Only removes the video stream (as expected) but ***plays the audio***.

3.  YouTube 6.8.14 correctly plays currently live streaming videos, complete with audio.  Backwards search during live streams correctly plays video+audio from earlier points in that stream.  Completed live stream videos do not have audio.

Hope this helps.
(2021-06-18, 04:42)jmh2002 Wrote: [ -> ]YouTube Videos and Subsciptions are both working for me Nod
Which version are you using and on what platform?
Same for me. I use it mostly for movie trailers in KODI (18.9) but unfortunately that function is now broken due to no streams found. I can go into the addon and do a search and bring up the trailer I was wanting to play.
Yesterday YT played well om my Libre Elec on PRi , but not today. No streams found ...
So could understand after reading 2 last pages that on version 6.8.14 editing the file : video_info.py don't help anymore ?
Waiting for the next Youtube addon update ?
Not PRi but RPi of course Smile
(2021-06-18, 18:32)drummerbod Wrote: [ -> ]
(2021-06-18, 04:42)jmh2002 Wrote: [ -> ]YouTube Videos and Subsciptions are both working for me Nod
Which version are you using and on what platform?

Per my previous recent posts, Kodi Matrix + v6.8.14 and running on LibreElec, Windows, and Android.

Everything has returned to working as per normal. Watching videos, Watch Later, History, My Subscriptions, etc, etc.
maybe this log is of any help:

https://paste.ubuntu.com/p/nCPffGnWWq/

It´s from a user of the german Kodinerds board. From what I see there´s something wrong with the URL:

2021-06-18 21:32:15.994 T:140449848407808 WARNING: [plugin.video.youtube] DEPRECATED "plugin://plugin.video.youtube/?action=play_video&videoid=45om7hohGLw"
2021-06-18 21:32:15.994 T:140449848407808 WARNING: [plugin.video.youtube] USE INSTEAD "plugin://plugin.video.youtube/play/?video_id=45om7hohGLw"

Hope this helps
Something i noticed just was that one of the videos coming up with the no streams found error is asking for age verification when i try to watch it on the official youtube mobile app.

Wonder if that is what is causing some things not to play in Kodi?

Maybe worth checking any videos you are having issues with to see if they want age verification.
Up until about 2 hours ago Youtube was working fine.

I eliminated any possibility of the addon by rolling back to previous versions but the same error is present.

So I guess that it is something at Youtube's end.
Working fine here, however youtube probably roll their changes gradually.
Are there any plans to support mysql for multidevices use? I tried to move search database to mysql alongside with MyVideosxxx and MyMusic in the same manner (i.e. use mysql if advancedsettings.xml presents and local one search database if that file absents) and definitely it works. I can now stop playback from search result in one room and continue watching in another one. And I even don't need use any account, which one is very handy, because me and my wife don't need share personal account details when one of us go here and there and switch between different rooms devices.
I made it for linux kodi 18.9.
So it gotta be interesting to make it official feature in some manner, I think
OSMC/Kodi 2020.11 on RPI with youtube app 6.8.14

Still "No stream" for any video, including ones I've already seen.

Those who say everything works fine, what versions are using ?