Kodi Community Forum

Full Version: YouTube
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
just updated to 6.8.15 on krypton, i get no video and these in the log:
ERROR: Open - error probing input format, https://consent.youtube.com/ml?continue=...3172&src=1
I cant belive that no one have problem playing age restricted videos except of me
(2021-06-27, 17:00)Doktor-X Wrote: [ -> ]I cant belive that no one have problem playing age restricted videos except of me

I had that problem once.
(2021-06-27, 17:00)Doktor-X Wrote: [ -> ]I cant belive that no one have problem playing age restricted videos except of me
I'm a newb scrolling this thread...and your post caught my eye. Full disclaimer, I've only just started using Kodi and this add-on...so I'm not sure if my observation below will actually help. But sharing anyway just in case.
 
Few weeks ago, I had a problem on the Nvidia Shield YouTube app where simple Kodi tutorials wouldn't play because they were "age restricted" for whatever absurd reason.

Now if I logged into the same YouTube account on a PC web browser, they would play just fine.

So after some digging, it turns out if your YouTube account is one of those "Brand Accounts" it will have problems playing age-restricted videos in some circumstances. You can check if your specific YouTube account is a "brand account" by visiting this link (if it's listed there, it's that type of account)...
https://myaccount.google.com/brandaccounts

It was only after I followed some complicated tutorial (can't find it now) to change one of my brand accounts to a "Personal" account that I was able to see age-restricted videos on the Nvidia Shield again.

Again, I'm not confident this relates to your problem - just putting it out there.
Where get custom history playlist id?
(2021-06-28, 18:02)FreakMurderer Wrote: [ -> ]Where get custom history playlist id?

Hope this helps Nod

https://forum.kodi.tv/showthread.php?tid...pid3039109

(2021-05-24, 21:34)jmh2002 Wrote: [ -> ]Watch Later and History require the various special mods posted earlier in the thread...

Here's a couple of GitHub links with the instructions:

History: https://github.com/anxdpanic/plugin.vide...-759817192

Watch Later: https://github.com/anxdpanic/plugin.vide...-766843932
(2021-06-28, 11:31)FamShoppa Wrote: [ -> ]
(2021-06-27, 17:00)Doktor-X Wrote: [ -> ]I cant belive that no one have problem playing age restricted videos except of me
I'm a newb scrolling this thread...and your post caught my eye. Full disclaimer, I've only just started using Kodi and this add-on...so I'm not sure if my observation below will actually help. But sharing anyway just in case.
 
Few weeks ago, I had a problem on the Nvidia Shield YouTube app where simple Kodi tutorials wouldn't play because they were "age restricted" for whatever absurd reason.

Now if I logged into the same YouTube account on a PC web browser, they would play just fine.

So after some digging, it turns out if your YouTube account is one of those "Brand Accounts" it will have problems playing age-restricted videos in some circumstances. You can check if your specific YouTube account is a "brand account" by visiting this link (if it's listed there, it's that type of account)...
https://myaccount.google.com/brandaccounts

It was only after I followed some complicated tutorial (can't find it now) to change one of my brand accounts to a "Personal" account that I was able to see age-restricted videos on the Nvidia Shield again.

Again, I'm not confident this relates to your problem - just putting it out there.


Yes i have one youtube brand channel under my google email, so this must be problem. Now i need to find that tutorial that you say helpd you, to see if it will help me
(2021-06-28, 22:07)Doktor-X Wrote: [ -> ]
(2021-06-28, 11:31)FamShoppa Wrote: [ -> ]
(2021-06-27, 17:00)Doktor-X Wrote: [ -> ]I cant belive that no one have problem playing age restricted videos except of me
I'm a newb scrolling this thread...and your post caught my eye. Full disclaimer, I've only just started using Kodi and this add-on...so I'm not sure if my observation below will actually help. But sharing anyway just in case.
 
Few weeks ago, I had a problem on the Nvidia Shield YouTube app where simple Kodi tutorials wouldn't play because they were "age restricted" for whatever absurd reason.

Now if I logged into the same YouTube account on a PC web browser, they would play just fine.

So after some digging, it turns out if your YouTube account is one of those "Brand Accounts" it will have problems playing age-restricted videos in some circumstances. You can check if your specific YouTube account is a "brand account" by visiting this link (if it's listed there, it's that type of account)...
https://myaccount.google.com/brandaccounts

It was only after I followed some complicated tutorial (can't find it now) to change one of my brand accounts to a "Personal" account that I was able to see age-restricted videos on the Nvidia Shield again.

Again, I'm not confident this relates to your problem - just putting it out there.


Yes i have one youtube brand channel under my google email, so this must be problem. Now i need to find that tutorial that you say helpd you, to see if it will help me

Looking through my browsing history, I believe I used this tutorial as a "base"...
https://www.youtube.com/watch?v=nOkmINpAzZU

Then I think I cross-referenced with various web searches.

Be prepared to do stuff like 2-step verification or similar. I remember it being a chaotic and annoying process.

Good news is that it worked, and my subscriptions and playlists were converted into a personal YouTube account.
(2021-06-29, 00:20)FamShoppa Wrote: [ -> ]
(2021-06-28, 22:07)Doktor-X Wrote: [ -> ]
(2021-06-28, 11:31)FamShoppa Wrote: [ -> ]I'm a newb scrolling this thread...and your post caught my eye. Full disclaimer, I've only just started using Kodi and this add-on...so I'm not sure if my observation below will actually help. But sharing anyway just in case.
 
Few weeks ago, I had a problem on the Nvidia Shield YouTube app where simple Kodi tutorials wouldn't play because they were "age restricted" for whatever absurd reason.

Now if I logged into the same YouTube account on a PC web browser, they would play just fine.

So after some digging, it turns out if your YouTube account is one of those "Brand Accounts" it will have problems playing age-restricted videos in some circumstances. You can check if your specific YouTube account is a "brand account" by visiting this link (if it's listed there, it's that type of account)...
https://myaccount.google.com/brandaccounts

It was only after I followed some complicated tutorial (can't find it now) to change one of my brand accounts to a "Personal" account that I was able to see age-restricted videos on the Nvidia Shield again.

Again, I'm not confident this relates to your problem - just putting it out there.


Yes i have one youtube brand channel under my google email, so this must be problem. Now i need to find that tutorial that you say helpd you, to see if it will help me

Looking through my browsing history, I believe I used this tutorial as a "base"...
https://www.youtube.com/watch?v=nOkmINpAzZU

Then I think I cross-referenced with various web searches.

Be prepared to do stuff like 2-step verification or similar. I remember it being a chaotic and annoying process.

Good news is that it worked, and my subscriptions and playlists were converted into a personal YouTube account.

Update to my problem. Now it works !!!!!!

I think that problem was in my age settings inside of google account it was 1900 i have chang it and i can finaly play all videos
(2021-06-27, 16:00)speising Wrote: [ -> ]just updated to 6.8.15 on krypton, i get no video and these in the log:
ERROR: Open - error probing input format, https://consent.youtube.com/ml?continue=...3172&src=1

ok. found out that the option "use website urls" was responsible for this.
Edit: delete post
Hi!

Is there a setting in the addon to start everything according to the plugin link instead of .mpd?

plugin://plugin.video.youtube/play/[email protected]
http://IP:PORT/@.mpd
Website more up to date than the addon list.

I have notice that on many channels that I visit that the list of videos available on thee website is more up to date than the list available through the addon.

It can take a day or two for the addon list to update and sometimes there are videos that never appear.

I have turned off filtering an age related restrictions but I cannot seem to get a comparable listing.

None of the content requires any additional sign in on the website either.

Is this normal behaviour?
Is there a way to force an update check?


Thanks.
Hi. I have a problem with the Youtube add-on not finding the streams when using MPEG-DASH. The error message is "The Playback Failed, One or more items failed to play..." I have tried to reset and clean all settings in the add-on but it doesn't work. I have 6.8.15 installed on 19.1. Anyone here experiencing the same?

I am using the API key client secret and client ID I got from Google. It worked earlier this month but the last week I have had this problem.

Roger J.
@anxdpanic

if added files as Watch Later, it displays funny translation green marked in below pic.
Image


The strings.po (resource.language.de_de) of translation is correct.

msgctxt "#30713"
msgid "Added to Watch Later"
msgstr "Zu Später Ansehen hinzufügen"

Have you recommendation to fix it, please.